Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
Sign in to follow this  
GerdS

Cessna 172SP, Baraon B58: Schalter rasten nicht ein

Recommended Posts

Hallo Heinz,

wir trafen uns auf der Flusi-Konferenz in Oberschleißheim.

Du wolltest meine Anregung mitnehmen, dass es hilfreich wäre, wenn man mit einer Taste das "3D-Cockpit Maus-Look" an einer bestimmten Stelle "einfrieren" und wieder "bewegen" könnte (vgl. FSX).

Ich habe deine Anregung, mal upzudaten, umgesetzt und siehe: schon hatte ich in dieser Sicht den Zoom +- auf dem Scrollrad. Ist doch schon mal eine Weiterentwicklung!

Inzwischen ist es mir auch gelungen, mit Hilfe der PlugIns "XPUIPC" und „XPGF_SB_Windows“ mein Multiradio von Open Cockpit und mein MCP von GoFlight einzubinden.

Funktioniert tadellos; es geht also voran, für mich als FSX-User.

Nun mein Problem:

Einige Kippschalter haben nur Tastenfunktion.

1. Flapsschalter: die Landeklappen stehen default auf Stufe Eins. Wieso?

Beim Betätigen des Flapsschalter bewegen sich die Flaps zwar in die gewünschte Richtung,

gehen beim Loslassen aber wieder in ihre Ausgangsposition zurück. Wieso?

2. Fuel Selector: steht auf Rechts. Beim Umschalten auf eine der anderen Positionen springt der Schalter nach dem Loslassen wieder in die Ausgangsposition zurück. Wieso?

3. Lichtschalter: beim Loslassen springt der Schalter wieder in die Ausgangsposition zurück,

und das Taxi/Landlight geht wieder aus. Das ist bei allen 5 Lichtschaltern so und bei Fuel Pump. Einzig Pitot Heat bleibt in seiner Position. Wieso?

Das Verhalten ist sowohl bei der Default-Cessna als auch bei der Default-Baron B58 beobachtbar.

Hast du eine Idee?

Gruß

Gerhard

Share this post


Link to post
Share on other sites

Hallo Gerhard,

Welche X-Plane Version hast Du installiert? Zur Zeit ist Vers. 10.05r1 aktuell.

Ich habe gerade einmal die Cessna172SP (Standard) getestet.

Ich kann Deine angeführten Fehler leider nicht nachvollziehen. Fuel steht in der Mitte beim Laden und kann mit der Maus nach rechts oder Links bewegt werden (3D Cockpit Command Look).

Auch die Flaps bleiben in der letzten Position stehen. Und können mit der Maus, der Tastatur oder den Joystick Buttons bewegt werden.

Allerdings habe ich die von Dir benannte Hardware nicht zum Testen hier...

Es könnte an den zusätzlichen PlugIns liegen. Eventuell einmal nicht benötigte deaktivieren (Menü PlugIns - Plugin Admin - Enable/Disable).

Oder die Preferences (Einstellungen) sind nicht mehr in Ordnung. Passiert manchmal, wenn man z.B. im Menü Flugzeug "KI fliegt das Flugzeug" gewählt hat. Dann könnte man diese einmal zurücksetzen (siehe hier).

Dann musst Du allerdings Deine Konfigurationen neu durchführen...

Gruß

Share this post


Link to post
Share on other sites

Hallo Gerhard,

Welche X-Plane Version hast Du installiert? Zur Zeit ist Vers. 10.05r1 aktuell.

Ich habe gerade einmal die Cessna172SP (Standard) getestet.

Ich kann Deine angeführten Fehler leider nicht nachvollziehen. Fuel steht in der Mitte beim Laden und kann mit der Maus nach rechts oder Links bewegt werden (3D Cockpit Command Look).

Auch die Flaps bleiben in der letzten Position stehen. Und können mit der Maus, der Tastatur oder den Joystick Buttons bewegt werden.

Allerdings habe ich die von Dir benannte Hardware nicht zum Testen hier...

Es könnte an den zusätzlichen PlugIns liegen. Eventuell einmal nicht benötigte deaktivieren (Menü PlugIns - Plugin Admin - Enable/Disable).

Oder die Preferences (Einstellungen) sind nicht mehr in Ordnung. Passiert manchmal, wenn man z.B. im Menü Flugzeug "KI fliegt das Flugzeug" gewählt hat. Dann könnte man diese einmal zurücksetzen (siehe hier).

Dann musst Du allerdings Deine Konfigurationen neu durchführen...

Gruß

Hallo Heinz,

Ich habe die Version 10.05r1. Das Problem hatte ich schon vor den beiden neu installierten Plugins. Ich könnte mir vorstellen, dass es mit den Preferences zusammenhängt. Ich werde sie mal zurücksetzen.

Gruß

Gerhard

Share this post


Link to post
Share on other sites

Hallo Heinz,

das mit den Preferences war schon der richtige Weg. Im Ursprungszustand tun die Schalter alle vorschriftsmäßig. Ursache dafür waren die Einstellungen für meine PFC Hardware auf der Karteikarte „Geräte“ unter „Einstellungen -> Joystick, Tastatur und Geräte“:

1. der Haken im 3. Feld von unten „PFC 3-Positionen Klappenschalter (Cessna)“ bewirkt, dass die Landeklappen default auf Stufe Eins stehen, und sich auch immer wieder dorthin zurückbewegen, wenn ich den Landeklappenschalter an der Konsole betätige. Er tut es aber auch ohne das Häkchen dort; ist also gebongt.

2. der Haken im 1. Feld „PFC Hardware für seriellen Anschluss (cat-2 oder höher) bewirkt, dass die anderen Kippschalter und der Fuel-Selektor die oben beschriebene „Fehlwirkung“ einnehmen.

Ohne das Häkchen tut aber meine Hardware nicht. Das ist doch ein Bug, oder?

Da haut's mich doch glatt um!

Die Hardware funktioniert seit FS2004 tadellos; beiliegend ein Bild vom DB-9 Serial Anschluss.

Ich habe neben der Power Supply nur das DB9-Kabel angeschlossen, sonst nix.

Wie kann man sich diese Fehlfunktion erklären?

Hat man das nicht getestet unter dem zeitlichen Releasedruck?

... oder ist die Einstellung zu kompliziert für mich ... habe ich etwas noch nicht bedacht?

Jetzt schaue ich doch glatt noch einmal bei Holger Reibold auf S. 78 nach; und?

"... sei für mich als Einzelplatzinstallation nicht relevant ..." Das wars dann wohl -

Gruß

Gerhard

post-35739-0-31865700-1337107076_thumb.j

Share this post


Link to post
Share on other sites

Hallo Gerhard,

da wir die PFC Hardware nicht haben, kann ich da kaum etwas zu sagen. Ich kanns nicht selbst testen...

Ich denke, es ist am Besten, wenn Du Dich an den X-Plane support (info@x-plane.com) wendest, oder direkt an PFC.

Bei einer Mail an den X-Plane Support, immer die Log.txt mitsenden (befindet sich im X-Plane 10 Hauptordner).

Gruß

PS: Oder jemand aus dem Forum hat Erfahrung mit PFC Hardware... ?

PPS: Eventuell lohnt sich auch ein Warten auf das nächste X-Plane Update. Das wird ein größerer Sprung werden. Sollte nicht mehr allzu lange dauern.

Share this post


Link to post
Share on other sites

Hallo Heinz,

mit der Probiererei der Preferences bin ich nun selbst dahinter gekommen.

Mein PFC-Throttle funktioniert auch ohne den Haken im 1. Feld.

Einfach nur das 4. Feld von oben „PFC throttle quadrant“ anklicken, quadrant auswählen, und das wars; gear- und Flaps-Schalter funktionieren dann auch.

Ist wirklich einfach, nur: gibt keine Beschreibung dazu, auch auf der PFC-Homepage ist das Feld X-Plane leer, und diese Probiererei kostet schon ne Menge Zeit und Durchhaltevermögen …

Gruß

Gerhard

Share this post


Link to post
Share on other sites

Hallo Gerhard,

gut, dass es funktioniert.

Spezielle Beschreibungen sind noch verbesserungswürdig, das stimmt.

Allerdings wundert es mich, dass selbst PFC keine Informationen bietet.

Es gibt ein (englisches) umfangreiches "Wiki" zum X-Plane 10 (siehe hier). Das erfordert aber auch "Durchhaltevermögen" und Zeit.

Gefunden habe ich dort allerdings auch noch keine genaueren Infos zur PFC Hardware...

Gruß

Share this post


Link to post
Share on other sites

Hi nochmals Heinz,

vielen Dank für den Link. Der ist ganz wertvoll.

Aus irgendeinem Link hatte ich schon die Expert Essays von XP 9. Mit deinem Link weiß ich jetzt, wie man dahin kommt. :)

Dort habe ich zwar eine Stelle mit "FPC" gefunden; ist aber für dieses Problem nicht sehr hilfreich.

Na denn: auf zu den nächsten Problemen, die schon vor der Tür stehen.

Gruß

Gerhard

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...