Jump to content

Sporadic crashes with AES 2.12 in FSX


Recommended Posts

Good day,

I'm experiencing exactly the same symptoms beckerm13 has already described in http://forum.aerosoft.com/index.php?/topic/46228-fsx-aes-ctd/, but I'm using AES 2.12.

I also tried the resolutions proposed in the above mentioned thread, but none of those are any good for my system.

I've seen two types of errors: usually it's in g3d.dll, but I also get "6025 pure virtual function call" errors.

The crashes appear sporadically, so as if this was some kind of timing or race-condition problem. It works sometimes, but mostly it doesn't.

In case AES and the aircraft manage to load fine, then everything just works smoothly and stable as it should.

I know it's one of those errors that make developers cringe, but if you've got any more input on this and hints what I could try, please let me know.



Windows 7 64 bit, 12GB RAM, Intel i7 990X, Geforce GTX460 2GB,

FSX SP2 installed in C:\FS\FSX, AES 2.12, UAC off, FSX running as admin, AES help running as admin

Link to comment
Share on other sites

Can you please mal a zip of your FSX.CFG and attach it here?

Will do as soon as I'm home from work.

Yesterday I did some more testing and found out that the situation dramatically improves if I proceed as follows:

1. Use an aircraft without intelliscene.cfg (Trike, or default C172 with intelliscene.cfg renamed) and place it at a parking pos on an AES-supported airport

2. Wait until everything is completely loaded and AES displays the yellow dialog ("aircraft not configured...")

3. With everything loaded and settled, choose any aircraft with intelliscene.cfg present

4. Observe everything working

I tried this a couple of times and could not reproduce any crash. I don't want to speak too soon though. Time will tell.

Link to comment
Share on other sites

Can you place try to remove the line:


in the [Main] section and then check, if the load is possible without a crash.

Yes, I had tried this already, it didn't help.

It's definitely a timing problem. Proceeding as described in my previous post, I haven't run into any crashes any more.

Link to comment
Share on other sites

Can you please unzip the attached file into the AES\SCENERY Folder and replace the original file.

Then try if the situation changed and the crash is gone or not.

Tested your fix a couple of times. I couldn't make FSX crash no matter what I tried, so I'd tentatively say that your new file fixes the issue.

Of course this is not representative for the whole user base.

May I ask what changes you made? What was the problem?

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...