Jump to content

Lightning F2A


wingman5
 Share

Recommended Posts

Hi guys
 It's taken a while to get the F2A to you, but existing owners of the F6 can download it again and the new model of the F2A is included so it's free . 

   2021-5-27_16-50-7-404.thumb.jpg.938264e2f5f169608a282f877e6b5433.jpg

 

2021-6-7_16-16-15-546.thumb.jpg.1a29baddefc8bc9e3653971859e2b65d.jpg

 

2021-7-1_15-2-10-484.thumb.jpg.3324a5abc0157b6b965e85079a163a63.jpg

 

2021-1-5_14-17-45-208.thumb.png.ad1e26ac9bf80bbc037206f524b82518.png

 

 

  Even looks good in MSFS...... can't get it to fly though  ! :0(

 

Image2.thumb.jpg.0d77513aa6ae34b565f625006d954830.jpg

 

Image6.thumb.jpg.0b1e4840cbffdd0cd5e789886b87ba93.jpg

 

  Hope you enjoy

 Dave Rowberry

Link to comment
Share on other sites

Hi WH

   The new F2A is exactly that , totally new . The one that came with the original F6 was only an exterior model as the VC was F6, but the latest F2A has the full F2A VC  and an updated exterior with all the blanks and pitot covers etc .

   The F6 itself is unchanged but the installer will now cater up to P3D v5 .

Cheers

 DR

  • Like 1
Link to comment
Share on other sites

  • 7 months later...
Am 27.7.2022 um 15:24 schrieb wingman5:

 Hi  RW

       The F2a ( and all the other lightnings) should work fine in P3d v5.

 What exactly is the problem you are having ?

 Dave R

Hello Dave,

I can load the F6 with no problem, but when I try to load the F2a, I can see the the virtual Cockpit for a split second, then CTD.

If I switch from  F6 to F2a from outside view, I can see the interior structure of the F2a starts to show up/loading, but again CTD.

Perhaps it is a texture problem?

Thanks for the quick reply

Raphael

 

Link to comment
Share on other sites

Hi Dave

it is in the aircraft folder. I uninstalled the F6 2.3 , cleared all entries in the roaming folder and reinstalled it.

With the F6 still no problem, but when I start from the menu and try to load the F2a, CTD after 3 sec.

I have no idea where the problem is...

 

Best regards

Raphael

Link to comment
Share on other sites

Hi Raphael

 That is a bit weird, an incompatible sound controller has sometimes caused problems ,

    Try opening the F2A's panel folder and open the panel .cfg in notebook, then put a // in front of the [Vcockpit01] 

gauge01=ASC!MAIN,   so it reads.....   //gauge01=ASC!MAIN,    and save .

   If the aircraft loads you will not get the extra switch sounds ,  but we can sort that later.

 Cheers

 Dave

Link to comment
Share on other sites

Hi Raphael

     This is strange , if the F6 works there is no reason the F2A shouldn't. the only difference is minor details.

 All I can think to do is swap things out with the F6 to try and show where the problem lies.

  In the model.F2A folder rename the interior .mdl ( put an X in front of it ) and copy the F6 interior model across and rename that as EElightningF2a_interior.mdl . If that is a no go do the same for the exterior model . you could try the same putting the F2 into the F6 . You will get some black areas where the textures are missing , but it will show that the basic model is working.

 Another thing to try is hiding the  .dll's in the panel folder ( again just rename with an X in front of it .)

 I have had the saved default flight cause problems before , try changing that.

  Dave

   

 

Link to comment
Share on other sites

Hello Dave,

I did what you have recommended.

I put the F6 interior MDL in the F2a folder, renamed it and started the sim. I ended up sitting in the F2a with the F6 cockpit, but when I switched to outside view- CTD.

I put the F6 exterior MDL in the F2a folder, renamed it etc. The result was a working F6 wth a F2a livery.

In the F2a folder I switched back to the original F2a interior MDL- the F2 didn't even load- CTD.

Thereafter I put the F2a interior, later interior MDLs in the F6 folder. It both worked (with some missing textures)...

Cheers Raphael

Link to comment
Share on other sites

Hi Raphael

   So the F6 models work in the F2A folder and the F2A models work in the F6 folder.  Have you tried with the F2A interior in the F2A folder but with the F6 as the exterior model  ? It seems as if one of the commands for a function exclusive to the F2A is causing a problem . If it is in the exterior model the only real difference between the F2 and the 6 is the gunpack . In the interior model it is the gunsight.

   You could try cancelling al the entries in the panel cfg that pertain to the Lit_F2A folder i.e.....

//gauge00=Lit_F2A!LitF2A_load.xml, 0, 0, 681,780

and those in the [Vcockpit01 ,03 , 04 

Set the models back in the correct folders and If things load ok clear the // off one by one until you get the CTD .
  Have you got  the F53 and does  load Ok ?

 and do you have Tacpack ?

 Cheers

 Dave

Link to comment
Share on other sites

Hello Dave,

the F2a folder with F2a interior MDL and F6 exterior MDL crashes.

I don't have Tacpack installed and I cancelled // all entries with Lit_F2a, as you have recommended.

Still CTD. On Friday I will install the F53 and check if it works.

 

Thanks

Raphael

 

[Window Titles]
Window00=Main
Window01=Loading State
Window02=Flight Reference Cards
Window03=FRC Emerg drills
window04=TACAN freq card
Window05=Hypoxia Blackout


[VIEWS]
VIEW_FORWARD_ZOOM=1.0
VIEW_FORWARD_DIR=0.0, 0.0, 0.0

//-------------------------------------------------------------------

[Window00]
size_mm=1024
position=7
visible=0
ident=MAIN_PANEL
BACKGROUND_COLOR=0,0,0

//------------------------------------------------------------------------

[Window01]
size_mm=681,780
windowsize_ratio=1.0
position=0
visible=0
zorder=10
window_size=0.300,0.600
window_pos=0.015, 0.015
ident=10001
BACKGROUND_COLOR=0,0,0

//gauge00=Lit_F2A!LitF2A_load.xml, 0, 0, 681,780


//-----------------------------------------------------------------
[Window02]
size_mm=500,1200
windowsize_ratio=0.6
position=1
visible=0
ident=10002
BACKGROUND_COLOR=0,0,0

//gauge00=Lit_F2A!Lit_FRC,   20,50,450,1000

 

//----------------------------------------

[Window03]
size_mm=500,1200
windowsize_ratio=0.6
position=2
visible=0
ident=10003
BACKGROUND_COLOR=0,0,0

//gauge00=Lit_F2A!Lit_Emerg,  0,50,450,1000

 

//------------------------------------

[Window04]
size_mm=500,1000
windowsize_ratio=0.6
position= 7
visible=0
ident=10004

//gauge00=Lit_F2A!Lit_tacan_freq.xml, 0, 0, 500,1000

//------------------------------------------------------
[Window05]
Background_color=0,0,0
size_mm=1024,1024
window_size_ratio=1
position=0
visible=0
ident=10005

//gauge00=Lit_F2A!hypoxia,  0,0,1024,1024


//---------------------------------------------------

[Vcockpit01]
file=Radarback.bmp
size_mm=512,512
window_size_ratio=1.000  
visible=1
texture=$VC_scope

//gauge00=Lit_F2A!B-scope,       0, 0,512,512
gauge01=ASC!MAIN,              0, 0, 1, 0, 0
gauge02=LightningF6!FuelXFR,   0, 0, 0, 0
//gauge03=Lit_F2A!Reheat,        0, 0, 0, 0
//gauge04=Lit_F2A!drag_chute,    0, 0, 0, 0
//gauge05=Lit_F2A!trigger,       0, 0, 0, 0          
//gauge06=Lit_F2A!hypoxia2,      0, 0, 0, 0
gauge07=Lit_Tac!Guns,          0, 0, 0, 0
gauge08=Lit_Tac!Missile_L,     0, 0, 0, 0
gauge09=Lit_Tac!Missile_R,     0, 0, 0, 0
gauge10=Lit_Tac!Missile_Pair,  0, 0, 0, 0
gauge11=Lit_Tac!Lit_SMS,       0, 0, 0, 0
//gauge12=Lit_F2A!gunpack,       0, 0, 0, 0
//gauge13=Lit_F2A!gunpurge,      0, 0, 0, 0
//gauge14=Lit_F2A!panel lights,  0, 0, 0, 0
//gauge15=Lit_F2A!trans,         0, 0, 0, 0
//gauge16=Lit_F2A!canopy,        0, 0, 0, 0
//gauge17=Lit_F2A!gear_sound,    0, 0, 0, 0
//gauge18=Lit_F2A!missiles,      0, 0, 0, 0
//gauge19=Lit_F2A!Reheat02,      0, 0, 0, 0
//gauge20=Lit_F2A!seat,          0, 0, 0, 0

 

//---------------------------------------------------------

[Vcockpit02]
file=Radarback.bmp
size_mm=512,512
window_size_ratio=1.000  
visible=1
texture=$VC_radar

gauge00=Lit_Tac!RadarLock,     0, 0,512,512
gauge01=Lit_Tac!keys,          0, 0, 0, 0

//---------------------------------------------------------

[Vcockpit03]
Background_color=0,0,0
size_mm=256,512
window_size_ratio=1.000  
visible=1
texture=$VC_PAS

//gauge00=Lit_F2A!PAS,     0, 0,256,512


//---------------------------------------------------------

[Vcockpit04]
Background_color=0,0,0
size_mm=256,256
window_size_ratio=1.000  
visible=1
texture=$VC_SD

//gauge00=Lit_F2A!PAS_SD,     0, 0,256,256

//---------------------------------------------------------

 


[Color]
Day=255,255,255
Night=160,160,160
Luminous=255,255,255

 

[Default View]
X=0
Y=0
SIZE_X=8191
SIZE_Y=6143

 

Link to comment
Share on other sites

Hi Raphael
 The thing to do is find out what your system objects to in the F2A .
As the exterior and interior models work in the F6 folder that clears those .
The rest of the F2A's workings seem to be proved by the fact that they load if combined with the F6 model .
 I was hopeing that it might have been a command called up in the panel folder but that seems not to be the case 
 I said to try the F53 as that has the same extras ( intake blank and pitot cover etc ) as the F2A . but it's clutching at straws. It's awful hard to find a fault I can't duplicate. 
   Does the F2A show in the preview without crashing  ?
 Cheers
 Dave

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...