Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
Sign in to follow this  
kronovan

Twin Otter Amphibian - Can't Set Prop Levers to Retard to Feather (approx 23%)

Recommended Posts

I'm encountering this when starting up Cold & Dark on a ramp with the amphibian edition of the aircraft; I typically only bush pilot, so I haven't tried the other flavors. When I get to the point of doing the Prop Feather tests, the Retard to Feather never works. I've tried slowly moving my props to settings from 1% to 100%, but nothing in that range ever gives me a green "v". I'm able to right-click to override and succeed on the next test to set props to full. All other tests previous to this are a success with no need to override any.

 

Any ideas why this is happening?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...