Recently we have seen a lot of codes used to unlock our products being offered for discounted prices. Almost all of them are bought using stolen credit cards. These codes will all be blocked by our systems and you will have to try to get your money back from the seller, we are unable to assist in these matters. Do be very careful when you see a deal that is almost too good to be true, it probably is too good to be true.

Jump to content
Sign in to follow this  
Joan Alonso

Microstuttering on ground

Recommended Posts

Hi,

 

I struggled months ago with an old PC, so I upgraded to a new one. It's a custom config I made specially for gaming and mainly P3D only. The difference was amazing, I never had a PC powerful enough or according with P3D recommended requirements before, I'm really happy with it, I think I got a good deal.

I thought I would never face again with stuttering, low FPS or any kind of -ings related to P3D behaviour.

I'm looking for advice if someone is experiencing the same and/or what can be upgraded to get a microstuttering free experience with the bus. My rig is:

 

I7 8700

GTX 1070 8GB

16GB CRUCIAL BALLISTIX SPORT 2666 (1)

SSD EVO 500GB

MSI Z370I

P3D4.4

Windows 10 Home

 

Pretty good system I thought, well, not so strong to run the bus smoothly. 

 

Surprisingly, the AS Airbus runs great and with higher FPS than any other commercial aircraft I have, but with terrible and constant microstuttering, only (and that's the key) on ground.

I have really conservative preferences in P3D (close to nonsense with my rig), most of the sliders are to the left. To the left I mean most of them at 0. I really want the sim to be smooth, not visually outstanding.

The point is that I get steady FPS and no stuttering with any other aircraft. In fact, sorry, I get lower fps but steadier and smoother with the other bus.

 

The CPU never gets above 40% load with constant 4.3 GHz, no other main tasks are running while running P3D. The GPU never exceeds 40% load in common conditions, the max GPU load I had was 60%-70% at night with trueglass working and many spot lights close to the aircraft at a payware scenery. Which makes me think that none of them are struggling at all. The microstuttering is present in any scenario, also with clear skies, no weather injection, no FPLAN added, default scenery and default shaders. It happened also with P3D4.3.

 

Could some calculations ruining the smoothness when on ground? I understand the need for a frame by frame calculation to simulate the systems of an Airbus, but can be some part of the code optimised/reworked to avoid this situation? If not, what's wrong with my system that I can not run the bus as smooth as the other aircraft?

 

My relevant P3D settings (always and in all situations):

- 1440x900

- Vsync On / Triple Buffering / Unlimited

- FXAA On

- 8MSAA

- Anisotropic 16

- No Traffic (any)

- No Bathymetry

- Internal and External Vehicle Shadows only

- Cloud Distance 80

- Dynamic Reflections Off

 

What I tried so far: (not necessarily in that order, i tried many things many times).

- Reinstall AS Airbus

- Nvidia Drivers up to date

- Revert Nvidia Drivers

- Nvidia CP Default settings / tweaked for performance.

- Shaders delete

- P3D.cfg rebuild

- Added Exceptions to Windows Defender

- Deactivate Firewall

- Deactivate Windows Defender

- Deactivate Windows Search

- HyperThreading Enabled and Disabled

- Checked RAM XMP On

- Afiinity Mask On/Off

- USB and wireless peripherals removal

- Reinstall W10

 

Any help will be much appreciated. Thanks!

 

 

Share this post


Link to post

Ok! I found something interesting, indeed, a stutter free solution.

We know that P3D uses one core for rendering tasks, so when loading any aircraft you can see the core 0 with higher load than others. Even not being near 100% load this was causing stuttering with the Aerosoft Airbus. I really do not know why it only happened with this aircraft. I tried AM settings and nothing worked, because every setting was loading the rendering tasks to a single core, so stutters again.

 

I have hyperthreading enabled with all cores enabled with P3D by default. So here's the trick, the only thing that will spread the core usage through all cores is (no AM in P3D.cfg) to open task manager, opening affinity dialog for P3D without touching anything and closing it. That will spread the CPU usage of P3D. 🤔

 

It seems that the developer can do some adjustments with core usage. But I don't know if LM or AS can do something to "solve" or modify this.

Or maybe it's only beneficial for my system? Anyway, the bus is smooth as butter right now.

 

Some people say that setting Affinity Mask=0 in P3D.cfg does the same without need of doing this every time P3D is started. Can not say if it works, I'll try tomorrow, it's been a looong day (another one) tweaking P3D. 

 

Here is an explanation of this at P3D forums.

https://www.prepar3d.com/forum/viewtopic.php?f=6314&t=129222

 

 

 

Share this post


Link to post

EDIT:

AffinityMask=0 does not work. Process lasso neither. The point is setting the affinity after P3D is started. So the only way of spreading CPU core usage is to set affinity manually every time. Maybe a bat file would do the trick.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...