Jump to content

Connection


Recommended Posts

Hier kann es verschiedene Ursachen haben:

 

Das Flugzeug muss auf einem Airport stehen, der in AESHelp auf FSX (also On) steht. Nur dann ist die Verbindung aktiviert und AESConfig kann verbinden.

Ausserdem kann es vorkommen, dass Firewall Programme auch die interne Kommunikation blocken. Hier ware zu testen, den TCP Port 19540 freizugeben, der wird von AESConfig standardmäßig verwendet.

Die UAC blocked auch Verbindungen, da muss sichergestellt sein, dass beide Programm im gleichen Modus laufen (Standard oder Admin), aber dass hast Du ja schon gemacht.

 

 

Link to post
Share on other sites

EDIT: Funktioniert leider immer noch nicht... Ich hätte vorher testen sollen bevor ich was schreibe. Obwohl ich jetzt AESConfig und den Port in der Firewall vom Antivirus und von Windows freigegeben habe, funktioniert es leider immer noch nicht. Ich habe AES auch schon mehrfach deinstallieren und das ganze natürlich auf verschieden Airports (Freigeschaltet und ON (AES an sich funktioniert ja, nur das Configtool halt nicht)) Ich hoffe du kannst mir trotzdem noch irgendwie helfen! Vielen Dank im Voraus!

Mit freundlichen Grüßen 

Robin

Link to post
Share on other sites

Das mit dem "Als Admin Starten" hast Du aber auch noch gechecked, nach der Freigabe?

 

Schaue mal im <FSX>\Vistamare Verzeichnis in die ViMaCore.CFG

Dort sollte  eine [NET] Section drin sein. Entweder sollte ide IPAddr= auf 127.0.0.1 stehen, oder die IP Addresse enthalten, die deine Netwerkkarte hat (ggf. im CMD Fenster mit IPconfig checken)

 

[Net]
; This section defines the network parameters:
;    StartTCP:    whether to start TCP/IP support (1) or not (0) on startup;
;                    this saves some machine resources until needed;
;                    modules like IntelliScene can start TCP/IP support later
;                    (default: 0)
;    IPAddr:        the IP address on which ViMaNET will listen for incoming client
;                    packets (default: 127.0.0.1)
;    Port:        the port for the above address (default: 19540)
IPAddr=127.0.0.1
StartTCP=1
Port=19540

 

Link to post
Share on other sites

In meiner ViMaCore.CFG ist die NET Section gar nicht drinnen. :/

 

[Keys]
VistaMare CORE=X:\Microsoft Flight Simulator X\VistaMare\ViMaCoreX.dll
[VistaMare CORE]
Code0=855
Name0=Cycle transp. interf. windows

 

So sieht die CFG aus. 

 

Vielen Dank für die jetzige Hilfe und ich bin guter Dinge das wir trotzdem noch eine Lösung finden! :)

 

Robin

Link to post
Share on other sites

Kannst Du mal in der ViMaCore.CFG  und der  ViMaIScnX.CFG (diese liegt im >FS>\Vistamare\Bin Verzeichnis)

eine Section

 

[Settings]
LogLevel=5

 

einfügen (oder den LogLevel Wert auf 5 erhöhen).

 

Starte dann den FS und versuche AESConfig nochmals zu verbinden.

Dann sollten im Vistamare Verzeichnis eine ViMaCoreLog.txt und im ..\Bin eine ViMaIScnXLog.txt entstanden sein, die Zippe bitte und hänge sie hier an.

Link to post
Share on other sites

Also laut dieses Log's ist die interne Verbindung gestartet und die Kommunikation läuft zumindest für die Verbindung mit FSUIPC.

Leider benötige ich das  ViMaIScnXLog.txt, um mehr zu sagen.

Entpacke bitte beiliegende ZIP in das fs\Vistamare\Bin Verzeichnis und wiederhole den Test, dann hast du auch dieses Logfile.

ViMaIScnX.zip

Link to post
Share on other sites

Sorry, welchen Button?

 

Du musst schon etwas genauer beschreiben, was Du machst, sonst wird das nichts.

 

Beschreibe bitte genau, ggf mit screenshots, wie Du AESConfig startest und beendest. 

Link to post
Share on other sites

Okay,

 

Ich starte AESConfig ganz normal. (Adminstrator Modus). AESConfig verbindet sich aber nicht zum FSX, wie schon erwähnt. Oben links bleibt das Kästchen weiter rot mit der Schrift "Disconnected". Wenn ich dann das Programm über den unteren Knopf "Programm verlassen" schließen möchte, schließt es sich zwar für 1 - 2 Sekunden, öffnet sich aber danach wieder. Erst wenn ich das Programm über den Task-Manager schließe, ist es auch wirklich zu. Vielleicht kannst Du damit ja was anfangen.

 

Liebe Grüße

 

Robin

Link to post
Share on other sites

Das sich das AESConfig nicht schließt, bzw wieder aufgeht, wenn die Verbindung nicht zustande kommt, konnte ich nachstellen. Das wird mit der nächsten Version behoben.

 

Ich kann auch nachstellen, dass bei eingeschalteter UAC und

1.) einem normal gestartetem FSX (also nicht als "als Administartor")  und einem "Als Administrator" gestartetem AESConfig

2.) der FSX "Als Administartor" gestartet ist und AESConfig "normal ohne Administator",

in beiden Fällen die Verbindung nicht zu standekommt.

 

Starte ich sowohl FSX als auch AESConfig "Als Admin..." oder beide ohne, dann funktioniert die Verbindung.

Also wenn Du AESConfig "Als Administator" startest oder im Shortcut unter > Eigenschaften > Kompatibilität der Haken bei "Programm als Administator ausführen" gesetzt ist, dann muss auch der FSX so gestartet werden.

Oder eben der Haken weg und ganz normal AESConfig starten.

 

Bei ausgeschalteter UAC ist das egal, da verbindet er immer.

 

Wie schon weiter oben geschrieben, kann ich nicht beurteilen, ob es da andere "Sicherheitstools" gibt, da auf die Verbindung Auswirkung haben.

 

Link to post
Share on other sites

Hey,

 

tatsächlich, es lag daran das ich den FSX irgendwie doch nicht als Admin gestartet habe.

 

Jetzt funktioniert alles prima!

 

Vielen vielen Dank für deine Hilfe und deine Geduld! SO muss Service sein! :)

 

Liebe Grüße und einen schönen Abend

 

Robin

Link to post
Share on other sites

Kleine bekannte Ursache (siehe post #2), große Wirkung. B)

 

 

Da dieser Thread beantwortet wurde haben wir ihn geschlossen. Wenn Sie weitere Fragen haben können Sie jederzeit einen Neuen öffnen.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...