Sign in to follow this  
Blackpoint

FPS Drops unter Last XP10

Recommended Posts

Hallo Gemeinde,

 

ich fliege auf XPlane 10, da ich meiner Hardware im Moment nicht mehr zumuten möchte ;-)

Folgendes: Ich habe meinen Prozessor, einen i7 870 auf 3,8 GHZ hochgeprügelt. Soweit so gut.

Leider habe ich das Problem, dass ich in den Bergen(dort habe ich immer ausgiebig getestet, weil ich gerne mit dem Heli dort rumfliege) die Frames immer dann einbrechen, wenn die CPU kurz ihre "Lastspitze" erreicht. Es hat keinen Einfluss, wenn ich irgendwelche Regler, die die CPU betreffen komplett rausnehme. Klar, wenn ich Verkehr auf max Stelle, dann geht nix mehr, aber ansonsten sind meine Settings human und daran sollte es eher nicht liegen.

Meine Frage an die Experten: Kann es mit dem Overclocking zusammenhängen, dass die FPS unter kurzer Vollast so zusammenbrechen? Das Bild steht dann quasi kurz für 0,2-0,5s(gefühlt) vielleicht alle 20 Sekunden mal.

Grafikkartenspeicher ist nicht voll, habe ich schon mit GPU-Z ausgelesen, genausowenig wie der Ram. XPLANE hab ich schon auf eine SSD verfrachtet, um Festplattenruckler auszuschließen.

Leider kann ich nicht sagen, wie der i7 870 im Standardtakt auch solche Einbrüche hatte, weil es schon einige Jahre her ist, als ich angefangen habe ihn zu overclocken.

Temperaturen sind soweit auch im Rahmen.

Lässt mich somit nur vermuten, dass der Prozessor wohl einfach langsam zu alt ist...

 

Weitere Infos:

i7 870 @3,8GHZ

GTX 770 4GB

8GB Ram

Gigabyte H55m-USB3

 

Szenerie

ZL16 Ortho4XP Kacheln

W2xpEurope OSM

HD Mesh v3

 

Test fand in den Bergen rund um Zermatt statt.

Kann natürlich sein, dass die Berge auch so viel CPU fressen?Ich weiß es ehrlich gesagt nicht.

 

Vielleicht kann ja jemand von euch was dazu sagen.

 

Anbei noch ein Bild meiner Settings.

xplaneSettings.thumb.jpg.4bd1edd33f9db50bfa8021a23ba3d87d.jpg

Share this post


Link to post
Share on other sites

Flieg mal eine Runde und wenn es ruckelt, beende XP10. Danach schau Dir mal die Log.txt im XP-Hauptverzeichnis an. Ich vermute mal, dass im Augenblick des Ruckelns Texturen nachgeladen werden.

Share this post


Link to post
Share on other sites

Also ich habe mal geguckt, konnte aber keine Auffälligkeiten feststellen. Wenn ich den Task Manager mal laufen lasse nebenbei, dann "zuckt oder stockt" er immerwenn die Auslastung für einen kleinen Moment nach oben schießt. Dieses hochschießen passiert ca. alle 30 Sekunden mal mehr/ mal weniger stark. Je nachdem wie stark die Last ansteigt, stockt er eben stärker/länger oder eben kürzer.

Die Frage ist, ob das normal ist, dass der Prozessor alle 30 Sekunden irgendwas starkes berechnen muss?

Share this post


Link to post
Share on other sites

Ich denke, eigentlich nicht. Ggf. könntest du die Log.txt auch gerne mal hier ins Forum posten (bitte als Dateianhang, nicht als komplette Textkopie!). Was du auch noch schauen könntest, wäre ob ein Virenscanner XP durch eine Echtzeitprüfung ausbremst. Man sollte in diesem Fall eine Ausnahme definieren, damit nicht immer parallel mitgescannt wird, wenn XP viele kleine Objektdatein (jedes Gebäude, Bäume, Lichter usw.) öffnet.

Share this post


Link to post
Share on other sites

Hier mal die Log.txt. Nicht wundern über die Taktfrequenz, hatte gerade mit deaktiviertem Turbo mal versucht.

Virenscanner hatte ich XPlane schon als Ausnahme hinzugefügt. Brachte keine Änderung.

 

 

Log.txt

Share this post


Link to post
Share on other sites

Kurzes Update:

Nach langer Recherche  in mehreren Foren, unter anderem auch in diesem hier, hatten andere Nutzer dasselbe Problem mit Microrucklern und Ähnlichem. Dort wurde empfohlen den NVidia Treiber 337.88 zu laden, da der das Problem beheben sollte.

Ich dachte, das ist schon Ewigkeiten her und das wäre mittlerweile gefixt. Betroffen waren vorallem 970er Karten aber auch 770er.

Egal, ich habs versucht und bin aktuell am testen. Bis jetzt kann ich sagen, dass es deutlich besser wurde. Keine längeren stehenden Bilder mehr. Die Auslastung der CPU schwankt nicht mehr ganz so stark und es scheint, doch wenn sie schwankt gibt es keine größeren Stolperer mehr. Muss wohl irgendwie ein Zusammenspiel zwischen CPU und GPU sein.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this