Jump to content

Wrong camera move direction


Recommended Posts

My profile ist "Simple joystick (TCA)".

 

My controllers are

 

CH Pro Pedals USB (joy0) (CH)
T.A320 Pilot (joy1) (Thrustmaster)
Flight Throttle Quadrant (joy2) (Saitek)
Flight Throttle Quadrant (joy3) (Saitek)

 

I'm sure, it doesn't depends on profile or controllers. 

 

In the cockpit, the camera moves in the right direction, but when you switch to External View, the camera moves in the opposite direction. There is only one command "Camera up" for all views, so it can't really be the profile or controller.

Link to comment
Share on other sites

I mean camera movement, not rotation.

 

To clearly recreate the problem I uninstalled WoA. I also deleted the WoA directory in AppData (C:\User\<user>\AppData\Local\WoA_Gliders). Then I reinstalled WoA (Version 1.0.0) from Steam.

 

The WoA directory in AppData does not exist yet after the installation. It is created with the execution of WoA. I have attached my directory to this message.

 

To recreate the problem now, I didn't have to do anything but:

  1. Start WoA
  2. Select any flight.
  3. When loaded, press F2 key to switch to External View.
  4. Then press LALT-UP to move the camera up.

==> Camera moves down. ERROR!

 

If I now switch to Cockpit View (F1) or Free Camera (F5), the camera moves up, as it should.

 

If you now look into my files, you will find the following:

 

The current profile is "Simple joystick (TCA)".

 

File scripts\inputProfiles\current.cfg
    profile1.cfg

 

File scripts\inputProfiles\profile1.cfg
    name = "Simple joystick (TCA)",
    binding = "binding2.dat",
    mapping = "mapping2.lua",

 

file scripts\inputConfigs\binding2.dat
    action("Cam_Rot_135",State,key_NUMPAD3);
    action("Cam_Red_225",State,key_NUMPAD1);
    action("Cam_Red_315",State,key_NUMPAD7);
    action("Cam_Red_45",State,key_NUMPAD9);

    action("Cam_Red_Pitch_N",State,joy0_pov0_0);
    action("Cam_Red_Pitch_P",State,joy0_pov0_180);
    action("Cam_Red_Roll_N",State,key_NUMPAD7);
    action("Cam_Red_Roll_P",State,key_NUMPAD9);

 

As stated in my other message, the problematic lines are in file binding2.dat.

 

This problem should be replicated by every user, including you and the developers.

 

In this case above I have only one joystick connected. Therefore, "Simple joystick (TCA)" was certainly set up.

WoA_Gliders.zip

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...