Jump to content

Archived

This topic is now archived and is closed to further replies.

BadPilot1966

Developers: Twin Otter and Prepar3D v2.5 - already tested?

Recommended Posts

Question for the developers of the Twin Otter Extended: I'm thinking of changing from Prepar3D v2.4 to v2.5. Has the Twin Otter already been officially tested with v2.5? I'm a little concerned about possible problems, because the folder structure within the software has been changed. A clear statement about the compatibility from the devs would be very nice! :)

Ahem... And a second question: Does the version of SimConnect you had to install with the Twin Otter Extended for Prepar3D v2.4 also work with v2.5? :confused_s:

Share this post


Link to post
Share on other sites

I have the Twin Otter Extended installed with P3D V2.5 and have not seen any problems.

Remember to also install the Twin Otter Hotfix for P3D found in the pinned section of the Twin Otter support forum.

You might need to install the FSX simconnect files for P3D too as noted in Lockheed Martin P3D forums.

But to make it clear - an "Official" test has not been done, but it works also with the old filestructure.

Finn

Share this post


Link to post
Share on other sites

I am also using it with P3dv2.5 (with it's hotfixes), and I found no problems with the Twin Otter Extended,

Share this post


Link to post
Share on other sites
Yep, everything is ok!
Generally these hotfixes reach those software that use EXE.dll. In this case, should be promoted to reinstall the software and everything is ok! :glare_s:

Share this post


Link to post
Share on other sites

Thank you very much for your helpful replies! But I still wonder, why the developers do not make an official comment about the compatibility with version 2.5... There could be some hidden problems with the new folder structure you're not yet aware of. Would be really nice, if Aerosoft could at least tell us, if or when they will find the time to check this out...

It's the same thing with the new Airbus btw: I did not find any official comment about the compatibility with P3D v2.5. Don't get me wrong: I'm very thankful to any user, who shares his experiences! But a confirmation from someone, who has programmed this software and knows the details would be really appreciated... :)

@ Finn: P3D shows that SimConnect 2.5.0.0 is installed ("About Prepar3D"). Do I still have to install it? Could you please tell me, where I can find the information in the P3D forums?

Share this post


Link to post
Share on other sites

First simconnect:

Try to run the Simconnects.msi installer in Your Prepar3D v2\redist\Interface\FSX-SP2-XPACK\retail\lib folder

Second "Official" test:

The TWin otter is now more than a year old and we had numerous P3D V2.x updates. We simply cannot keep occupying a tester team to check out all products everytime a new 3D version is released.

We assured that it worked with P3D V2.0 and has issued hotfixes as problems was revealed.

So the best testing are the tests done by the users, reporting any new issues.

Finn

Share this post


Link to post
Share on other sites

Finn, thank you for your hint concerning SimConnect!

I really do not expect Aerosoft to "keep occupying a tester team to check out all (..) products everytime a new 3D Version is released"... ;)

But wouldn't it be nice, if the developers could find the time to let us know, if the new folder structure is relevant for addons declared as compatible with P3D v2? :)

It is understood, that this structure will be kept with further updates of P3D, so it's not just a minor update like v2.1 - v2.4.

But I really don't want to rush anybody! I absolutely appreciate that it takes time to keep track with all these P3D updates... :)

And a big thankyou again to those community members above answering my questions and trying to help me!

Share this post


Link to post
Share on other sites

I agree with You regarding the new folder structure, though using the old still seems to work.

I´m not sure if the installers for products like the Twin Otter will be updated.

Finn

Share this post


Link to post
Share on other sites

I installed P3D v2.5 (with P3D hotfix 2.5.12944.0) today and indeed the Twin Otter Extended seems to work without any problems - great! :)

But SimConnect wasn't properly installed with P3D, although it shows, that SimConnect 2.5.0.0 was installed ("About Prepar3D")!

So installing SimConnect (see Finns hint above) definitely is required! (This was also important for the A320/321, which didn't work correctly without it.)

Now my two favourite AddOns seem to work without any problems in P3D v 2.5 - how great is that? :cool3_s:

Share this post


Link to post
Share on other sites

For most FSX addons, especially aircraft, the FSX Simconnect version is required.

Finn

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...