We got a new video from World of Aircraft: Glider Simulator and are asking for some alpha/beta testers! Check this post.

 

Jump to content

Archived

This topic is now archived and is closed to further replies.

haseen

Feelthere Team offers Aerosoft Twotter Ex: on 4th of July, 2014.

Recommended Posts

Dear:

1. Discounted Price: I am thinking to buy Aerosoft Twin Otter Extended, Download version. At Aerosoft its price is $42.59. But Feelthere is offering the product at $37.99-30% OFF = $26.59 for 4th of July. Is the offered product by Feelthere is exactly same as Aerosoft's? Is the discounted price okay?

2. Autopilot: I don't have the "Maule" aircraft in my FSX as it is the FSX Classic, SP2 Acceleration. Previously Twin Otter used Maule autopilot. That's why I shelved the idea to get that. Now, will Twin Otter Extended autopilot have full functionality in my FSX classic? Please confirm.

Regards,

Haseen Ahmad

Bangladesh.

Share this post


Link to post
Share on other sites

Hi Haseen, no worries about the Ext. Twotter version in the feelThere store. Should be the latest one anyway.

Something strange about the feelThere checkout I noticed is, they add VAT (value added tax) to my purchase, despite the fact that I'm situated in Germany, and I'm buying download from feelThere/U.S.A.

So my heads-up would be, make sure in the purchasing/checkout/payment process, that any VAT will not spoil your bargain. Cancel the purchase process, if necessary.

For your question (2.) someone else will have to pop in, as my FSX is deluxe with SP1+2.

Share this post


Link to post
Share on other sites

Hi Haseen,

2) Sure, in the Twin Otter Extended we use a fully custome Autopilot which does not use any default functions.

Share this post


Link to post
Share on other sites

Hi Haseen,

2) Sure, in the Twin Otter Extended we use a fully custom Autopilot which does not use any default functions.

However, the product page does state.......

System requirements:

Microsoft Flight Simulator X (SP2, Acceleration Pack or Gold Edition)

......which is normal for most add-ons.

Share this post


Link to post
Share on other sites

However, the product page does state.......

System requirements:

Microsoft Flight Simulator X (SP2, Acceleration Pack or Gold Edition)

......which is normal for most add-ons.

SP2 is available for the FSX standard edition also. That's why Emanuel has cleared things up: no deluxe edition needed, no default Maule and/or its A/P needed.

Share this post


Link to post
Share on other sites

Feelthere Twin Otter offers only Three models, DHC-6-300?! Not all eleven! I finally purchased from Aerosoft this evening with $42. No discount.

Share this post


Link to post
Share on other sites

Paul, are you up to these days, not with Lou Betty any more ? haven't heard about you for a long time .

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...