We have at this moment problems with e-mails coming to us via Microsoft servers (Outlook, Hotmail, Live, etc). We are in contact with Microsoft to solve this issue.

Jump to content

Recommended Posts

Danke, da hab ich schon gesucht..... oh jetzt seh ich´s , heißt jetzt anders deshalb hab ich ´s übersehen. Hab nach "D+A+CH" gesucht, die iHd heißt "Dach", also mein Fehler.

Share this post


Link to post
Share on other sites

Hallo Pilotbalu, habe nun auch die neue DACH_ihd installiert. Für meinen betagten Computer ideal. Ausserdem war dein Tip mit den Exclusion für Venedig Super. Was wüede ich nur ohne dich tun.X-plane ist ja nicht gerade einfach in den Griff zu bekommen. Also nochmals danke an das ganze Forum

Share this post


Link to post
Share on other sites

Hab mir mal die DACH_xd installiert und festgestellt, dass alle (?) Stromleitungen fehlen...

Hab mir gedacht: Na, dann erstell ich mir die eben kurzerhand selber mit 0.7.2 anhand der Vector Rules aus config.xml - doch auch da: Fehlanzeige... DIe DSF werden zwar erstellt und decodiert mit XGrinder sieht man auch, dass networks erstellt wurden, doch dargestellt wird irgendwie nichts. Fehlermeldungen hab ich bisher keine Verdächtigen im log.txt gefunden.

Bevor ich hier weitersuche: Ist das bei andern auch so?

Nachtrag:

Vielleicht habe ich die Ursache entdeckt: Meiner Meinung nach hat die Datei World2XPlane-0.7.2\application\resources\objects\road.net einen Fehler in der Zeile 61.

Ist:

ROAD_DRAPED 3 250 0.10 0.00

Soll:

ROAD_DRAPED 3 256 0.10 0.00

Um das zu testen, müsste man nun die zweite Vector Rule (Filter: "power=line") in config.xml bzw. config_hd.xml korrigieren (Element "vector-definition") und neu generieren. Ich befürchte, dass bei den aktuellen hd und xd Szenerien von Simheaven keine Stromleitungen >166kV dargestellt werden...

Share this post


Link to post
Share on other sites

Ich hab mittlerweile eine Lösung für die fehlenden Stromleitungen gefunden, die für mich funktioniert. Dabei habe ich in der config.xml einzig die zweite Vector Rule so angepasst, dass die Definition "220" aus dem Standard roads.net (d.h. virtueller Pfad lib/g10/roads.net) genommen wird, also:

        <rule type="vector">
            <filter type="key-value">
                power=line
            </filter>
            <node-filter>
                power=pole
                power=tower
            </node-filter>
            <vector-file>lib/g10/roads.net</vector-file>
            <vector-definition>220</vector-definition>
            <nodes-as-points>true</nodes-as-points>
            <pass-through>false</pass-through>
        </rule>

Hab mir dann nur die Networks generieren lassen und das Ganze von der Ladepriorität her vor die Simheaven xd-Szenerie gesetzt - passt wieder!

Die ganzen Network-Definitionen sowie die zugehörigen Objekte in W2XP (inkl. World Models Lib) sind aus meiner Sicht etwas chaotisch organisiert und teilweise auch redundant vorhanden (z.B. als Library sowie auch als lokale Kopien in den generierten Szenerien)... Kein Wunder gibt's damit Probleme... Ich hab mal das Ganze bei mir etwas aufgeräumt (z.B. Objekte von ./application/resources/objects in die World Models LIbrary verschoben) und damit ist's nun etwas übersichtlicher geworden... Schade bloss, dass nur die World Models Library wirklich Open-Source ist, ansonsten könnte sich die Community an solchen "internen" Aufräumaktionen konstruktiv beteiligen, sowie auch config.xml's für unterschiedlichste Bedürfnisse entwickeln und pflegen...

Share this post


Link to post
Share on other sites

Hi Daikan

A feature was added into 10.30 for using multiple road files after I sent a request to Ben. Originally X-Plane didn't support it, and it's a new feature which I'm grateful was added so quickly :-). However, it seems there may be a bug in X-Plane itself, as whenever I try to add any more road types or powerlines, no roads are rendered at all (and no errors show up in the log). Also, the powerlines do actually work for me (Including the download from Simheaven), and it makes no difference what number I give the vector-definition.

The reason I created my own powerlines is so that each pylon's position is respected unlike the default ones. Up until now, I believe it's been working fine, so I'm not sure what's going on and why it's not working for some people. I'd be really grateful if someone could create a really small scenery which should have powerlines and doesn't (All my attempts failed and my scenery works), and send it to me or to Ben Supnik (Create a fake scenery with some powerlines around an airport). Perhaps I'm missing something, or there is indeed a bug in X-Plane. As far as I know, only W2XP is using the multiple road network file feature.

Regarding going opensource, well OSM2XP has been opensource for a few years and nobody has touched it ;-). I don't think anybody would work on it either way

Tony (World2XPlane)

Share this post


Link to post
Share on other sites
As far as I know, only W2XP is using the multiple road network file feature.

Hello Tony,

I've been playing for a while with several .net in a .dsf.

Currently I use the feature for my custom bridges ;

the roads.net and a bridges.net side by side in the DSFs.

This even runs under 10.40b2.

Of particular importance are the node IDs.

As far as I know : start at 0 with no gaps.

What I found out is that node-IDs for one .net can not be reused for the other (-> crash).

Unless these nodes for the various .net have exactly the same position are thus co-located.

The specs as published are still a bit 'thin' and we'll have to ask Ben what is intended and what is not.

----------------------------------------------------------------------------------------------------------------------------------

Hallo Tony,

Auch ich spiele schon seit einer Weile mit mehreren .net in einem DSF .

Zur Zeit benutze ich das Feature für eigene Brücken.

Dazu habe ich neben der roads.net eine bridges.net in den selben DSF's.

Das läuft auch unter 10.40b2.

Wichtig sind vor allem die Knoten IDs.

Soviel ich weiß sollen die bei 0 beginnen und keine Lücken haben.

Was ich herausgefunden habe ist , dass Knoten-IDs für die eine .net nicht für eine Andere wiederverwendet werden können (-> crash) .

Es sei denn , diese Knoten für die verschiedenen .net haben genau die gleiche Lage sind also co-located.

Die veröffentlichten specs dazu sind noch etwas 'dünn' und wir werden wohl Ben fragen müssen was beabsichtigt ist und was nicht.

Share this post


Link to post
Share on other sites
The reason I created my own powerlines is so that each pylon's position is respected unlike the default ones. Up until now, I believe it's been working fine, so I'm not sure what's going on and why it's not working for some people. I'd be really grateful if someone could create a really small scenery which should have powerlines and doesn't (All my attempts failed and my scenery works), and send it to me or to Ben Supnik (Create a fake scenery with some powerlines around an airport). Perhaps I'm missing something, or there is indeed a bug in X-Plane. As far as I know, only W2XP is using the multiple road network file feature.

Regarding going opensource, well OSM2XP has been opensource for a few years and nobody has touched it ;-). I don't think anybody would work on it either way

Hi Tony,

As far as I remember I contributed the file w2xp.net to the world models library sometime last year with both the intent to create "nodes as points" networks (aimed mainly at cable ways at first) as well as to have a single network definition for W2XP which can be further developed in the future and which can be used in addition to the stock roads.net... However, it seems there is now a local objects\road.net file included with each generated scenery and which I think is a copy of the file <W2XP_HOME>\application\resources\objects\road.net. Not sure what the idea was behind including a local network definition instead of using the one provided by the library... Same goes for some assets used by the local network definition (e.g. some are local, some are taken from the library - for no apparent reason IMO). I think it would be good to stick with as few network definitions as possible given the possibly buggy implementation in XP...

I'm including a small test area around Locarno / Switzerland where W2XP 0.7.2 created power lines that could not be rendered (without creating any errors in XP). The area includes at least 3 types of power line definitions:

Locarno.osm.zip

Share this post


Link to post
Share on other sites

Mit welchen Vorlagen hast du die US-Szenarien mit 0.6.0 und 0.7.1 erstellt?

Das war eine angepasste sd. Doch das Problem erledigt sich eh, weil ich diese Erzeugung nun ganz raus lasse und alles von darunter (also z.B. HD Scenery Mesh) genommen wird.

Warte mal bitte ab, bis die neuen Dateien (dann ohne Zusatz) schätzungsweise Ende der Woche fertig und online sind. In allen w2xp-Szenerien außerhalb Europas verwende ich dann nur w2xp- und original XP-Objekte und für den Rest Fassaden.

Share this post


Link to post
Share on other sites

Also bei den world-models (normal und ext_LOD), die auf simheaven.com zu laden sind, habe ich alle png zu dds konvertiert.

Share this post


Link to post
Share on other sites

Stimmt, ich hab auch eben nachgeguckt. In der nächsten Version werde ich das ändern. Wer nicht warten will, kann die PNGs z.B. über XGrinder diese in DDS wandeln.

Share this post


Link to post
Share on other sites

Hallo PilotBalu
Ich habe gerade versucht deinen neuen Versionen von W2XPL Verfügung SimHeaven.

Ich habe festgestellt, dass in der Schweiz in den Alpen kann nicht weder Kabel noch Sesselbahnen oder Skilifte gefunden werden! (Es zuvor existierte) Was ist leider schade, wenn wir Rettungshubschrauber üben möchten ...
Wird es eine zukünftige Version, die dies korrigiert werden?

In allen Fällen ist ein sehr großes Dankeschön für all die Arbeit, die Sie tun, um zu verbessern X-Plane werden!

 

[EDIT] : An einigen Stellen werden die Aufzüge von Hochspannungsleitungen ersetzt (zB Verbier Kanton Wallis)

Share this post


Link to post
Share on other sites

Ich habe festgestellt, dass in der Schweiz in den Alpen kann nicht weder Kabel noch Sesselbahnen oder Skilifte gefunden werden!

Einen möglichen Workaround habe ich hier beschrieben.

Share this post


Link to post
Share on other sites

Ich habe festgestellt, dass in der Schweiz in den Alpen kann nicht weder Kabel noch Sesselbahnen oder Skilifte gefunden werden! (Es zuvor existierte)

Ja, das ist richtig, es wird in den neuen Szenerien kein eigenes roads.net eingebunden, sondern das von darunter liegenden Szenerien genommen, damit fallen auch die Lifte raus.

Das ist halt schwierig, es jedem Recht zu machen, die einen wollen eine möglichst hohe Performance, die anderen möglichst viel Details. Wäre schön wenn beides ginge, doch das ist halt nicht. Also hab ich einen Mittelweg gewählt, damit möglichst viele diese Szenerien nutzen können. Wenn man eine spezielle Version haben will, dann bietet dies ja World2XPlane. Die Config kann nach Belieben angepasst werden.

Ich weiß die Helipiloten haben da erhöhte Anforderungen an die Details, was ja auch richtig ist, fliege ja selbst manchmal Einsätze. Da wäre sicher eine spezielle Heli-Szenerie mit mehr Details und verbesserten Texturen sinnvoll.

Share this post


Link to post
Share on other sites

Hallo zusammen

Schade, werden die Seilbahnen bei der neuen Version nicht mehr dargestellt. Ich fliege zu 100% mit Hubschraubern im X-Plane und somit ist die sehr interessant.

 

@Daikan: Mit deinem Workaround werden die Seilbahnen bei der neuen Version auch wieder dargestellt?

 

Herzliche Grüsse,

Simon

Share this post


Link to post
Share on other sites

@Daikan: Mit deinem Workaround werden die Seilbahnen bei der neuen Version auch wieder dargestellt?

Ja, das sollte funktionieren. Ich hab mir z.B. ein "config-vectors.xml" erstellt (angehängt), womit ich mir nur die Strassen, Stromleitungen und Bergbahnen generiere. Die so erstellte Szenerie kann man dann in der Ladepriorität vor die W2XP Szenerie von Simheaven setzen.


 

config-vectors.xml

Share this post


Link to post
Share on other sites

Ja, das sollte funktionieren. Ich hab mir z.B. ein "config-vectors.xml" erstellt (angehängt), womit ich mir nur die Strassen, Stromleitungen und Bergbahnen generiere. Die so erstellte Szenerie kann man dann in der Ladepriorität vor die W2XP Szenerie von Simheaven setzen.

Hallo Daikan
Ich bin mit deiner Datei "config-vectors.xml" und ich danke dir.
Nur bedauern, für die Bergbahnen. Mit der Version 5 W2XP, ich habe ein Szenario, in dem der Aufzug hatte den Punkt der Abreise und Ankunft, und alle Zwischenmast.
Mit einer Konfigurationsdatei, ich habe die Start- und Endpunkte ...
Welche Veränderungen zu tun, um zu bekommen, was ich will.
Vielen Dank für deine Antwort

 

Hello Daikan
J'ai bien utilisé ton fichier "config-vectors.xml" et je t'en remercie.

Seul regret, pour les Bergbahnen. Avec la version 5 de W2XP, j'ai un scénario dans lequel le remonte-pente avaient le point de départ et d'arrivée , ainsi que tous les pylône intermédiaires .
Avec ton fichier de configuration, je n'ai que les points de départ et d'arrivée …
Quels changements effectuer pour obtenir ce que je souhaite .

Meri de ta réponse 

 

 

Share this post


Link to post
Share on other sites

Hallo Daikan

 

Danke für dein File? Aber wie kann ich das Installieren? 

Muss ich die xml im Custom Scenery abspeichern?

 

Danke und Gruss,

Simon

Share this post


Link to post
Share on other sites

Nein, einfach irgendwo hinkopieren - völlig egal wo. In World2XPlane muss man das File dann in der Lasche "Advanced" als "Config File" referenzieren.

Ich habe eine korrigierte (siehe Details) und aktualisierte Version für 0.7.4 angehängt.

Aber Vorsicht, 0.7.4. hat einen Bug mit Network Exclusions... D.h. man muss die Network Exclusions selber setzen, wenn man Networks separat generieren möchte. Dies um zu verhindern, dass Strassen, Stromleitungen und evt. Seilbahnen doppelt erscheinen. Das geht z.B. mit WED oder Overlay Editor in dem man eine eigene Szenerie erstellt, welche nur die Exclusions enthält und diese in scenery_packs.ini gleich hinter die generierte Szenerie setzt.

config-vectors.xml

Share this post


Link to post
Share on other sites

Hoi

 

Irgendwie komme ich nicht nach, wie das gehen soll.

Ich speichere das File beim XPlane 10 ab. Und nachher muss ich was machen? Welche Lasche? 

 

Gruss Simon

Share this post


Link to post
Share on other sites

simu83: Hast du mal World2XPlane runtergeladen und installiert? Dies ist das Tool von dem dieser Thread handelt...

Wenn nicht, würde ich mal vorschlagen dies zu tun. Evt. auch mal die Anleitung lesen, die im Download enthalten ist...

Mein File hat nicht direkt mit X-Plane zu tun (XPlane kann damit nichts anfangen), sondern enthält Anweisungen für World2XPlane...

Share this post


Link to post
Share on other sites

Ach so...

 

Ja dann probiere ich es mit diesem Tool...

 

Danke schön!

 

Gruss Simon

Share this post


Link to post
Share on other sites

World2Xplane wendet sich an Entwickler und Experten, nicht an Anfänger.

Wenn du also nicht sooo fit bist, dann lade und installiere dir lieber schon fertige w2xp-Szenerien, die z.B. auf meiner Seite angeboten werden, für die ganze Welt! :) Falls du das machst, bitte das ReadMe beachten, da noch weitere Bibliotheken notwendig sind, damit die Szenerie läuft.

Share this post


Link to post
Share on other sites

World2Xplane wendet sich an Entwickler und Experten, nicht an Anfänger.

Wenn du also nicht sooo fit bist, dann lade und installiere dir lieber schon fertige w2xp-Szenerien, die z.B. auf meiner Seite angeboten werden, für die ganze Welt! :) Falls du das machst, bitte das ReadMe beachten, da noch weitere Bibliotheken notwendig sind, damit die Szenerie läuft.

Mein Problem ist, dass die bei den neuen Versionen die Seilbahnen, Skilifte usw. nicht mehr angezeigt werden. Demzufolge benötigte ich das Tool welches sich an Entwickler und Experte richtet.:D

Mal schauen ob ich es hinkriege.

 

Gruss Simon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...