Jump to content

Recommended Posts

Danke schön! :)

Es sind noch ein paar Dinge zu verbessern, z.B. werden manche Wälder nicht von Straßen freigeschnitten, flackernde, da doppelte OSM Fassaden. Tony hat wegen solchen Dingen die 0.7.1 wieder zurückgezogen, ich hab trotzdem die Szenerien veröffentlicht, da sie m.E. performanter als die 0.6.0 Szenerien sind und damit mehr testen können und die kleinen Fehler noch ausgemerzt werden.

Nun zu deiner Frage: Ich hatte für die Kontinente die hd-Version gemacht, durch die Verwendung der (europäischen) Libraries sah das dann aber sehr europäisch aus. Um das schöner hinzubekommen, müsste man nur die Regeln definieren, um die Fassaden durch Standard-Objekte zu ersetzen, die ja amerikanisch orientiert sind.

Findet sich dafür ein Freiwilliger???

Share this post


Link to post
Share on other sites

Danke schön! :)

Es sind noch ein paar Dinge zu verbessern, z.B. werden manche Wälder nicht von Straßen freigeschnitten, flackernde, da doppelte OSM Fassaden. Tony hat wegen solchen Dingen die 0.7.1 wieder zurückgezogen, ich hab trotzdem die Szenerien veröffentlicht, da sie m.E. performanter als die 0.6.0 Szenerien sind und damit mehr testen können und die kleinen Fehler noch ausgemerzt werden.

Nun zu deiner Frage: Ich hatte für die Kontinente die hd-Version gemacht, durch die Verwendung der (europäischen) Libraries sah das dann aber sehr europäisch aus. Um das schöner hinzubekommen, müsste man nur die Regeln definieren, um die Fassaden durch Standard-Objekte zu ersetzen, die ja amerikanisch orientiert sind.

Findet sich dafür ein Freiwilliger???

Hallo PilotBalu,

nachdem ich gesehen habe, dass Du wieder fleißig warst (vielenDank dafür!) habe ich mir die neue Version von World2XPlane runtergezogen (DACH HD). Hab sofort bemerkt, dass die Ladezeiten sich wesentlich verkürzen, aber dafür sind wesentlich weniger Objekte zu sehen. In Frankfurt stehen fast nur noch Einfamilienhäuser und die mit der Vorgängerversion sichtbare Skyline ist auch verschwunden. Ich mach doch bestimmt wieder fast falsch :-(

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

Setz doch mal mal mal die Anzahl der Objekte höher.

Sent via Tapatalk

Hab ich gemacht... Bin jetzt bei megatons... Dann sieht das auch richtig schick aus :-) Aber die Hochhäuser in Frankfurt sind trotzdem weg... Ist das normal? Ich habe den Eindruck, dass nur noch Einfamilienhäuser gezeigt werden. Bei der füheren Version von World2XPlane musste ich teilweise bis zu 10 Minuten warten, bis x-Plane fertiggeladen hatte. Jetzt gehts wesentlich flotter. Deshalb meine Befürchtung, ich könnte irgendwas vergessen haben...

Share this post


Link to post
Share on other sites

Hi, danke PilotBalu für die neuen Szenerien!

In deinen Szenerien, wie auch in den von mir generierten, ist mir aufgefallen dass X-Plane bei manchen Objekten manche Teile schlicht nicht anzeigt. So kommt es vor (in deiner Szenerie z.b. bei einem Turm in der Nähe des Kölner Doms) dass bei mehrteiligen Gebäuden manche Teile nicht angezeigt werden (auch aus nächster Nähe - ein LOD Issue scheint es also nicht zu sein) und deshalb die Teile die angezeigt werden in der Luft herumhängen, z.B. das Dach. Das sieht mächtig irritierend aus.

Aber ich glaube Tony hat dieses Issue schon an die X-Plane macher weitergeleitet (im Kontext meines Bug-Reportes vom fehlenden TV-Tower in München). Weis jemand wo ich den Bugreport dazu anschauen kann? Auf X-Plane finde ich keinen öffentlich einsehbaren Bugtracker zu X-Plane.

Danke!

Share this post


Link to post
Share on other sites

Hab ich gemacht... Bin jetzt bei megatons... Dann sieht das auch richtig schick aus :-) Aber die Hochhäuser in Frankfurt sind trotzdem weg... Ist das normal? Ich habe den Eindruck, dass nur noch Einfamilienhäuser gezeigt werden. Bei der füheren Version von World2XPlane musste ich teilweise bis zu 10 Minuten warten, bis x-Plane fertiggeladen hatte. Jetzt gehts wesentlich flotter. Deshalb meine Befürchtung, ich könnte irgendwas vergessen haben...

Es sollte normal so sein, das höhere Gebäude auch aus weiterer Entfernung angezeigt werden und je näher man kommt, die kleineren Gebäude dazu kommen. Ich hab fast die Vermutung, dass dies genau anders rum ist. Könntet ihr mal testen, wann ihr bei niedrigem LOD welche Gebäude seht? Kommen die kleineren oder die größeren zuerst?

Share this post


Link to post
Share on other sites

Es sollte normal so sein, das höhere Gebäude auch aus weiterer Entfernung angezeigt werden und je näher man kommt, die kleineren Gebäude dazu kommen. Ich hab fast die Vermutung, dass dies genau anders rum ist. Könntet ihr mal testen, wann ihr bei niedrigem LOD welche Gebäude seht? Kommen die kleineren oder die größeren zuerst?

Hmm, also bei mir werden in Ffm die Hochhäuser richtig angezeigt, auch aus nächster nähe. Das mit dem LOD funktioniert auch gut: Aus Ffm sehe ich den Feldberg-Turm und die Biblis-Türme nicht. Wenn ich aber hineinzoome sehe ich den Feldbergturm und mit etwas Transparenz sogar auch die Biblis-Türme.

Was auch eine gute Idee wäre: Das anzeigen nicht nur von der Höhe der Gebäude abhängig machen, sondern auch von der Höhenlage des Grundes. Ein kleines Haus auf einem Berg wird man aus weiter Entfernung eher sehen wollen als ein kleines oder mittelhohes Haus in einem Tal aus gleicher Entfernung. Der Feldbergturm ist ein gutes Beispiel, der ist ja nicht sonderlich hoch, aber relativ exponiert.

Share this post


Link to post
Share on other sites

Das ist ne gute Idee, wird aber nicht funktionieren da 1. OSM keine Höhendaten hat und 2. X-Plane nur die Entfernung zum Objekt zur Berechnung (ob das Objekt angezeigt werden soll oder nicht) heranzieht.

Share this post


Link to post
Share on other sites

Das ist ne gute Idee, wird aber nicht funktionieren da 1. OSM keine Höhendaten hat und 2. X-Plane nur die Entfernung zum Objekt zur Berechnung (ob das Objekt angezeigt werden soll oder nicht) heranzieht.

Vielleicht kann man es ja als Feature Request an X-Plane schicken. Aber ich glaube wenn es so einfach wäre dann hätten die es schon längst implementiert. Alternativ dazu war ja mal die Idee entstanden, dass G2XPL die Map-Farbe an einer bestimmten Stelle an W2XPL übermittelt, das daraus wiederum die Dach-Farbe generiert. Vielleicht könnte man aus G2XPL zu der Farbe vielleicht auch die Höheninformation exportieren.

Share this post


Link to post
Share on other sites

Vielleicht kann man es ja als Feature Request an X-Plane schicken. Aber ich glaube wenn es so einfach wäre dann hätten die es schon längst implementiert. Alternativ dazu war ja mal die Idee entstanden, dass G2XPL die Map-Farbe an einer bestimmten Stelle an W2XPL übermittelt, das daraus wiederum die Dach-Farbe generiert. Vielleicht könnte man aus G2XPL zu der Farbe vielleicht auch die Höheninformation exportieren.

Ideal wäre das vielleicht immernoch nicht weil ich gaube, dass eher der relative Höhenunterschied zur Sichtposition zählt als die absolute Höhenlage des Objektes, d.h. es kann dann nur durch X-Plane direkt gemacht werden. Aber vielleicht funktioniert es trotzdem ganz gut :)

Share this post


Link to post
Share on other sites

Kann ich dir auch nicht sagen, im changelog.txt steht nix, die Bezeichnung in der Application ist noch 0.7.1 und bei einem Durchlauf von DACH konnte ich keine Änderungen feststellen.

Share this post


Link to post
Share on other sites

ich habe eine Frage:

Ich habe mir jetzt opensceneryx runter geladen und installiert. Ich habe mir ebenso die r2-library beschafft. des Weiteren auch world2xplane Germany hd.

Installiert ist bisher, wie gesagt opensceneryx. und ich habe auch die Richtigkeit der Verzeichnisse geprüft. Wie geht es jetzt weiter? Wie installiere ich die r2 library und world2xplane? Einfach nur mit 7zip entpacken in custom scenery, oder gilt es etwas zu beachten?

vorab Vielen Dank für die Infos.

grüße

Michael

Share this post


Link to post
Share on other sites

0.7.2 ist draußen. Kennt jemand die Änderungen?

Gekritzelt mit meinem Galaxy Note 8.0 via Tapatalk 4 Pro

Just a minor bug fix, it is a new version which just fixes a crash. The 0.7.* branch currently has a problem with some floating buildings due to OSM3D being disabled for performance.

Share this post


Link to post
Share on other sites

@PilotBalu

ich kann die w2xp_Germany_osm.7z nicht öffnen gibt es da bekannte Probleme oder sitzt das Prob vorm Rechner ??

Share this post


Link to post
Share on other sites

Guten Tag,

ich habe eine Problem mit World2xplane.

Ich möchte gerne Gelnhausen EDFG, Aschaffenburg EDFC und Mainbullau EDFU korrekt dargestellt bekommen. Hessen und Unterfranken kann ich korrekt übersetzen (mit config-hd-autogen) und die sehen für sich allein auch gut aus. Wenn ich in der scenery_packs Datei (Reihenfolge der Einträge insgesamt beachte ich) beide eintrage, sehe ich Fehler wo vorher keine waren: Unterfranken vor Hessen bedeutet nördlich von EDFC kein Wald und Hessen zuerst bedeutet dass EDFU im Wald liegt weil die "Hochebene" plötzlich bewaldet ist.

Schneide ich mit osmconvert einen Teil von germany-latest aus, werden keine Häuser dargestellt. Lasse ich germany-latest insgesamt berechnet (config-hd-autogen), sind Häuser an Stellen wo bei der Umrechnung mit hessen-latest (gleiche config-datei) keine sind. Um EDFU herum ist dann auch Wald.

Was kann ich tun, damit EDFC und EDFU korrekt dargestellt werden?

Beste Grüße

Lindoriel

Share this post


Link to post
Share on other sites

Das wird das Problem mit sich überschneidenden Teilen sein, du musst bei der Erzeugung eine poly file angeben, damit mehrere w2xp-Szenerien, die dieselbe Kachel erzeugen, auch korrekt angezeigt werden. Und natürlich auch die Exclusions entsprechend setzen.

Share this post


Link to post
Share on other sites

Hallo,

ich habe die W2XP DACH HD installiert und bekomme diese Fehlermeldung:

0:00:16.320 E/SYS: | Error loading the scenery package:
0:00:16.320 E/SYS: | Custom Scenery/w2xp_D+A+CH_hd/
0:00:16.320 E/SYS: | The scenery may not look correct.
0:00:16.320 E/SYS: | Please see the log.txt file for detailed error information.
0:00:16.320 E/SYS: | (io_dsf.cpp:675)
0:00:16.320 E/SYS: +-------------------------------------------------------------------------------
0:00:16.320 E/SCN: Custom Scenery/w2xp_D+A+CH_hd/Earth nav data/+50+000/+51+006.dsf:
0:00:16.320 E/SCN: Unable to locate object: objects/forests/trees/tree15m2.obj
Failed to find resource 'objects/forests/trees/tree4p5.obj' at 'Custom Scenery/w2xp_D+A+CH_hd/objects/forests/trees/tree4p5.obj'
Den Ordner forests gibt es auch nicht im Ordner w2xp_D+A+CH_hd/objects.
Vielleicht kann mir jemand sagen, wieso diese Ordner nicht da sind.
Habe die 1GB Datei mit 7Zip entpackt.
So sieht meine ini aus:
I
1000 version
SCENERY
SCENERY_PACK Custom Scenery/ruscenery/
SCENERY_PACK Custom Scenery/Aerosoft - EBBR Brussels/
SCENERY_PACK Custom Scenery/Aerosoft - EDDF Frankfurt/
SCENERY_PACK Custom Scenery/Aerosoft - EDLP Paderborn-Lippstadt/
SCENERY_PACK Custom Scenery/Aerosoft - EGSS London-Stansted/
SCENERY_PACK Custom Scenery/Aerosoft - LEBL Barcelona/
SCENERY_PACK Custom Scenery/Aerosoft - LFMN Nice Cote d Azur X/
SCENERY_PACK Custom Scenery/Aerosoft - LFPG Paris CDG/
SCENERY_PACK Custom Scenery/Aerosoft - LFPO Paris Orly/
SCENERY_PACK Custom Scenery/Aerosoft - LPFR Faro/
SCENERY_PACK Custom Scenery/Aerosoft - LSGG Genf/
SCENERY_PACK Custom Scenery/EDLY Borken-Hoxfeld/
SCENERY_PACK Custom Scenery/EDXE Rheine-Eschendorf/
SCENERY_PACK Custom Scenery/EDLS/
SCENERY_PACK Custom Scenery/EDLT Muenster-Telgte/
SCENERY_PACK Custom Scenery/EDLB Borkenberge/
SCENERY_PACK Custom Scenery/ETHE Rheine-Bentlage AB/
SCENERY_PACK Custom Scenery/Global Airports/
SCENERY_PACK Custom Scenery/KSEA Demo Area/
SCENERY_PACK Custom Scenery/KSEA Demo Terrain/
SCENERY_PACK Custom Scenery/LOWI Demo Area/
SCENERY_PACK Custom Scenery/OpenSceneryX/
SCENERY_PACK Custom Scenery/world-models/
SCENERY_PACK Custom Scenery/Europe_Library/
SCENERY_PACK Custom Scenery/ff_library/
SCENERY_PACK Custom Scenery/R2_Library/
SCENERY_PACK Custom Scenery/w2xp_D+A+CH_hd/
SCENERY_PACK Custom Scenery/z+52+007_D_Osnabrueck_bx17/
SCENERY_PACK Custom Scenery/z+51+007_D_Dortmund_bx17/
Nette Grüsse
Christoph

Share this post


Link to post
Share on other sites

Hallo,

habe die Lösung gefunden:

Man benötigt auch die aktuelle World-models Datei.

Das steht leider nicht im Readme der Installation.

Share this post


Link to post
Share on other sites

Guten Tag,

ich habe eine Problem mit World2xplane.

Ich möchte gerne Gelnhausen EDFG, Aschaffenburg EDFC und Mainbullau EDFU korrekt dargestellt bekommen. Hessen und Unterfranken kann ich korrekt übersetzen (mit config-hd-autogen) und die sehen für sich allein auch gut aus. Wenn ich in der scenery_packs Datei (Reihenfolge der Einträge insgesamt beachte ich) beide eintrage, sehe ich Fehler wo vorher keine waren: Unterfranken vor Hessen bedeutet nördlich von EDFC kein Wald und Hessen zuerst bedeutet dass EDFU im Wald liegt weil die "Hochebene" plötzlich bewaldet ist.

Schneide ich mit osmconvert einen Teil von germany-latest aus, werden keine Häuser dargestellt. Lasse ich germany-latest insgesamt berechnet (config-hd-autogen), sind Häuser an Stellen wo bei der Umrechnung mit hessen-latest (gleiche config-datei) keine sind. Um EDFU herum ist dann auch Wald.

Was kann ich tun, damit EDFC und EDFU korrekt dargestellt werden?

Beste Grüße

Lindoriel

So, ich habe zufällig die Lösung gefunden. In meiner config ist exclude- objects, forest und facades = true, weiter unten gibt es noch ein smart-exclusions, das steht bei mir auf false.

Habe EDFC und EDFU disabled, anschließend war die Gegend um Aschaffenburg und Mainbullau o.k. Beide Flugplätze wieder enabled, trotzdem ok.

Reihenfolge in der scenery_packs ist dabei immer die gleiche: - Flughäfen, - libraries, world2xplane, Fotoscenery. Weiß der Geier was das war...

Eine weitere Frage: Wie kann ich die Anzahl der Bäume, welche an Feldrändern und in Wohngebieten gesetzt werden, reduzieren?

Danke & beste Grüße

Lindoriel

Share this post


Link to post
Share on other sites

Vorankündigung der XD-Version

In den letzten Wochen habe ich mich mit der xd-Version befasst, die Berechnung ist sehr speicherintensiv, so dass w2xp selbst bei meinen 32 GB RAM öfters die Flügel gestreckt hat. Doch Kachel für Kachel arbeite ich mich voran, nun sind für D+A+CH 2/3 der Kacheln erzeugt und ich konnte es in den generierten Gebieten mal probefliegen.

Wie schon die alte xd-Version sieht diese viel voller aus als alle anderen Versionen. Bei der xd-Version werden keine smart exclusions erzeugt, Autogen wird in w2xp selbst mit denselben Objekten erzeugt, so dass die Performance sogar besser ist als mit "durchmischten" Versionen. :)

Bilder sagen mehr als Worte, habe hier ein paar Screenshots angefügt, oben links ist der Wert für fps eingeblendet, doch seht selbst:

post-62088-0-40008600-1431164499_thumb.j

post-62088-0-85582700-1431164505_thumb.j

post-62088-0-97440500-1431164521_thumb.j

post-62088-0-11632300-1431164519_thumb.j

post-62088-0-55303900-1431164520_thumb.j

post-62088-0-44657500-1431164523_thumb.j

Nun kommt sicher die Frage, wann das online geht... Ich kann es nicht genau sagen, da das schwierigste Gebiet mit dem Ruhrgebiet erst noch erzeugt wird, ich hoffe innerhalb einer Woche, vielleicht früher, vielleicht später. ;)

  • Upvote 2

Share this post


Link to post
Share on other sites

Die Bilder sind Klasse auch deine FPS sind noch sehr gut was für ein eine Hardware hast du.

Bin echt auf die neue Version gespannt :lol:

Share this post


Link to post
Share on other sites

Hardware steht in meinem Profil, muss man nicht bei jedem Post lesen ;) Hardware ist zur Zeit etwas über Durchschnitt würde ich sagen:

Main computer: Intel Core i7-3770K, Gigabyte Z77X-UD5H, Asus GTX680 4GB VRAM, 32 GB RAM G.Skill Ares 1866 MHz, 10 TB internal harddisks, 120 GB Intel SSD (System), 1 TB Samsung SSD (X-Plane), 9 TB external harddisks, Windows 7 Professional (x64), X-Plane 10 (x64), 100 MBit internet access, 3 monitors 27", iPad 2 running AirTrack

Share this post


Link to post
Share on other sites

Sieht gut aus :rolleyes:

nur zur Info Armin. Bei den Testgenerierungen mit meiner XD Version musste ich im Ruhrgebiet <random-placement-limit> auf 850000 reduzieren. Mit dem Default Wert ist es sonst immer abgebrochen (auch mit der 0.7.1).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...