Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content

Recommended Posts

Das ist normal.

Windows zeigt bei X-Plane inklusive großer Zusatzszenerien (Fotokacheln, w2xpl usw.) in der Regel "keine Rückmeldung" an. Auch wenn X-Plane zeitgleich im Hintergrund fleißig lädt.

Du kannst dabei mal den Taskmanager oder Ressurcenmonitor öffnen und zuschauen, wie X-Plane langsam aber stätig den Arbeitstpeicher zuschaufelt, auch wenn Windows behauptet es gäbe keine Rückmeldung mehr.

Philip

Share this post


Link to post
Share on other sites

Tatsächlich, es hat geklappt. Hat aber fast 20 Min. gedauert.

Nagelneuer Gaming-PC, komische Sache. Hilft ein SSD Einbau? Reichen 256GB?

Share this post


Link to post
Share on other sites

Prozessor ist ein i7 4790K. Sollte passen, hoff ich.

Meinte ob 256GB als Erfahrungswert reichen. Aber ich denke doch schon.

Share this post


Link to post
Share on other sites

Also, mein X-Plane Verzeichnis ist momentan 593 GB groß.

Dies sind hauptsächlich ZL17 Tapeten in Deutschland und ein paar wenige ZL18 Tapeten in der Schweiz.

Wenn man bedenkt, dass allein die 4 ZL18 Tapeten zusammen 140 gb belegen, solltest du einfach einmal in dich gehen, was du alles mit X-Plane noch anfangen möchtest.

Mir würde eine 256 GB SSD nicht reichen.

Philip

Share this post


Link to post
Share on other sites

Ich habe damals auch in den sauren Apfel gebissen und mir eine 1TB SSD gekauft. War zwar Schweineteuer (360 Euro) aber es hat sich gelohnt. Ich konnte mein ganzes XP auf die SSD schieben. Seit dem startet es schnell und was noch wichtiger ist ich habe keine Laderuckler an den Kachelgrenzen. Davor hatte ich eine WD Raptor Festplatte die ging eigentlich auch von der Geschwindigkeit bis ich auf w2xp umgestiegen bin. Für w2xp ist eine Festplatte einfach zu lahm da dort hundert tausend kleine Dateien geladen werden müssen und sich die Zugriffszeiten somit summieren, hier kann die SSD klar punkten.

Share this post


Link to post
Share on other sites

Habe auch 580GB Daten und eine 1T SSD ist in Moment noch zu Teuer ...

(Geld geht für den Bau und Test des Home Cockpit drauf ^_^ )

Ich bin am überlegen ob ich mir die hier Kaufen soll mit SSD Cache, was haltet ihr davon?

Da die w2xp Daten doch oft genutzt werden sollte man doch was merken oder?

http://pc-eagle.shop2go.biz/shop/details.php?art=132135&artname=Seagate+8.9cm+%283.5%22%29+++1TB+SATA3+Desktop+SSHD+8GB+SSD+intern+bul

Share this post


Link to post
Share on other sites

Dann vielleicht doch lieber eine kleine SSD und nur w2xp draufpacken!? Dann kannst du sicher sein das wirklich w2xp auf dem schnellen Speicher ist. Ich vertraue so einer Hybridplatte irgendwie nicht. Man weiss nie was auf der HDD ist und was auf der SSD. Oder kann man das irgendwo nach schauen ?

Share this post


Link to post
Share on other sites

Dann vielleicht doch lieber eine kleine SSD und nur w2xp draufpacken!? Dann kannst du sicher sein das wirklich w2xp auf dem schnellen Speicher ist. Ich vertraue so einer Hybridplatte irgendwie nicht. Man weiss nie was auf der HDD ist und was auf der SSD. Oder kann man das irgendwo nach schauen ?

Kenne keine Software wo man das sehen kann, aber je Öfters man ein Programm aufruft um so schneller wird es nach und nach.

Wie z.b. der Windows Start.

Habe schon ein ähnliches System laufen nur nutze ich 20GB von meiner 120GB SSD, für eine 2T HDD als Cache.

In Prinzip wenn ich nur X-Plane auf der SSHD Installiere werden 8GB Cache gefühlt mit Daten wo XP immer nutzt.

Foto Texturen werde es wahrscheinlich nicht sein, und ob sich dann beim Fliegen das bemerkbar macht, keine Ahnung deshalb die Frage.

Hm wie kann man w2xp auf eine SSD auslagern ? Wie gesagt es sind 580 GB Daten wo mein XP hat.

Share this post


Link to post
Share on other sites

Tja ich hatte mir von meiner 1TB-Hybridplatte mehr versprochen. Ich habe X-Plane zusammen mit w2xpl auf einer 256GB SSD.

Das passt noch gut von der Grösse weil ich die Simheaven-Version habe und auch nur mit den wichtigsten Ländern.

Auf die Hybridplatte sollten dann die ZL16/17-Kacheln weil mir dafür eine SSD auch zu teuer war. Die 1TB SSHD sitzt aber Extern an eSATA2.

Mechanische Festplatten sind physisch nämlich nicht SATA3 schnell. Der SSD-Cache lernt mit der Zeit was an Daten am Häufigsten gebraucht wird

und läd sie dann entsprechend vor für eine schnelle Zugriffszeit. Aber ich musste elendig warten (min 10 Min), bis die Platte die ZL-Kachen geladen hatte.

Testweise intern an SATA3 war es auch nicht nenneswert besser. Aus Platzmangel musste aber eine externe Lösung her.

Also eine 256GB SSD in ein USB3-Gehäuse und siehe da, nach 2-3 Min sind die Kachel fertig. Die Grösse reicht auch erstmal,

da ich mit den ZL-Kacheln notgedrungen auch nur auf die wichtigsten Gebiete beschränken muss.

Wer meherere USB-Platen verwendet, die den USB3-Speed voll ausreizen, sollte darauf achten, dass sie jeweils an nur einem Controller hängen.

Neuere Boards haben für die hinteren und vorderen Anschlüsse je ein USB3-Chip. Der Rest wird über interne Hubs verteilt

und da müssen sich die Platten die Geschwindigkeit teilen. Ich denke die SSHD lässt sich gut für AdOn-Szenerien nutzen.

Da kommt auch einiges zusammen.

Share this post


Link to post
Share on other sites

Bei solchen Platte ist auch nur die Zugriffszeit etwas schneller als bei 7200U/Min und die Datenrate ist real immer noch deutlich unter 300MB/Sek.

Schon als Systemplatte wurde mir in Fachkreisen von der WD1000DHTZ wegen ihrer Lautstärke abgeraten, obwohl sich da in den Jahren viel verbessert hat.

Ich habe noch aus meiner Anfangszeit als Flusianer eine 15 Jahre alte 18GB SCSI-Serverfestplatte im Schrank liegen.

Kann man auch keinem rationelldenkenden Menschen erzählen was die damals gekostet hat. :confused2_s:

Aber ihr Sound als Triebwerks-Simulator ist heute noch phänomenal :crylaugh_s:

Share this post


Link to post
Share on other sites

Darf ich mal kurz fragen, was Eure Posts mit dem Thema "W2XP" zu tun haben?

  • Upvote 2

Share this post


Link to post
Share on other sites

Darf ich mal kurz fragen, was Eure Posts mit dem Thema "W2XP" zu tun haben?

Grundsätzlich sind w2xpl-Szenerien aufgrund der ungewöhnlich hohen Anzahl kleiner nicht zusammenhängender Einzelobjekte eine verhängnisvolle Falle für mechanische Festplatten. Da diese beim Laden von w2xpl-Szenerien eigentlich nurnoch damit beschäftigt sind, den Lesekopf auf der Platte hin und her zu bewegen und dabei immer nur einzelne winzige Minidateien laden.

Daher kann sich die Ladezeit des Simulators von etwa 20 Minuten auf ca. 3 Minuten verkürzen, wenn man von einer HDD auf eine SSD umsteigt. Dies betrifft zwar auch große Fotoszenerien, da sind auch viele Dateien enthalten, extrem ist dieser Ladezeitenzusammenhang aber nur bei w2xpl Szenerien.

Deshalb hat es mit diesem Thema zu tun.

(Auch wenn es w2xpl als solches nicht berührt)

Philip

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest

Das ist wohl richtig, aber wir sollten tatsächlich solche Hardware Diskussionen lieber im Hardware Forum durchführen. Dafür ist es ja da...

Das ist dann auch für andere Leser besser auffindbar.... :)

Man kommt nicht unbedingt darauf, dass es HD und SSD Diskussionen und Lösungen im World2XPlane Thread gibt ......

Gruß Heinz

Share this post


Link to post
Share on other sites

Hätte da mal eine Frage zu W2XPL. Na ja, eingentlich zwei. ;-)

1. Beim Umwandeln der OSM-Daten mit World2XPlane bekomme ich bei größeren Paketen z.B.Germany irgendwann die Fehlermeldug "Generation failed" Habs bestimmt schon 10mal mit allen möglichen Einstellungen und unterschiedlichen config.xml versucht. Einige Kacheln werden bearbeitet, aber nach ca. 5-15 Kacheln bricht w2Xplane ab. Physikalischer RAM immer auf Anschlag bei 95 - 99%

Es ist mir nicht möglich diese Datei zu bearbeiten. Einzelne deutsche Bundesländer klappen. Wobei ich auch Bayern und BW mehrmals versuchen mußte, da auch hier öfters die besagte Fehlermeldung kam.

Hat jemand einen Tip, woran es liegen könnte? Mein PC ist eigentlich sehr performant. Intel K2600 mit 4 x 4 GHz. 16 MB Ram, GTX 970. SSD für Win7 64 und eine weitere für XPlane 10 64Bit.

Und meine 2. Frage: Kann ich aus den Dateien/Ordnern der einzelnen Bundesländer ein Verzeichnis Deutschland erstellen?

Hab schon mal alle Bundesländer genommen, Die Ordnerstruktur beibehalten und einfach alle Dateien von BY, BW, HH usw. genommen und in die entsprechenden Ordner meines selbst erstellten Germany-Ordners kopiert. Funktionieren tuts bin mir aber nicht sicher ob ich die Bundesländer mit oder ohne Poly-Datei verwenden soll, und ob ich sonst noch irgend was beachten muß?

Gruß Gerhard

Share this post


Link to post
Share on other sites
  1. 16GB sind mit grosser Wahrscheinlichkeit zu wenig, um im Memory-Modus ganz Deutschland in einem Durchgang zu generieren. Ich bin z.B. auch daran gescheitert und musste für die Generierung von DACH auf den Local-Storage Modus ausweichen, was dann gefühlt etwa 10-20x langsamer ist - trotz SSD. Der Vorteil ist, dass W2XP dann eine persistente OSM-Datenbank erzeugt, wo es immer wieder darauf aufsetzen kann ohne die Datenstruktur von Grund auf neu anzulegen (nützlich, wenn man z.B. mit den neuesten OSM-Rohdaten aktualisieren will)
  2. Ich schätze das funktioniert so nicht, denn benachbarte Bundesländer benutzen jeweils eines oder mehrere gleichnamige (aber inhaltlich unterschiedliche) DSF-Dateien und da es pro Custom Scenery nur genau eine DSF pro 1x1° Kachel geben kann, gibt es dann einen Konflikt. Und auf jeden Fall die Poly-Files verwenden, da es ansonsten Ärger mit Exclusions gibt, wenn die Teilgebiete (teilweise) innerhalb der gleichen Kachel liegen.

Share this post


Link to post
Share on other sites

Danke Daikan,

Hab jetzt 32 GByte RAM

Bis jetzt siehts gut aus. Testweise Bayern generiert. Alles i.o. RAM bei max. 52 %

Deutschland lasse ich über Nacht laufen.

Bin eingentlich guter Hoffnung. :-)

Gruß Gerhard

Share this post


Link to post
Share on other sites

Wäre ja auch zu schön gewesen. World2XPL hat erneut mit Error abgebrochen. :-(

Ist aber nach ca. 24 Std bei ungefähr 65 Kacheln gewesen.

World2Xplane zeigt mir hier nur 16 GB Speicher an. Win7 hingegen hat 32 GB und benutzt hier im Schnitt ca. 70 %.

Kann ich unter W2XP oder Win7 noch was optimieren?

Nach der Fehlermeldung hab ich nochmal auf "Start" gedrückt. W2XP rödelt wieder. Mal sehen wie lange.

Anbei zwei Hardcopy von W2XP und der aktuellen Speicherbelegung.

Für jeden Tip dankbar

Gerhard

post-122401-0-80121000-1425142655_thumb.

post-122401-0-38672200-1425142656_thumb.

Share this post


Link to post
Share on other sites

Schau dir doch mal deine "World2Xplane.ini" an. Kann es sein das bei dir noch der Default eingetragen ist ?

Wenn ja ist das typisch für java ... der nimmt dann nur einen Teil des Speichers. Du kannst hier Parameter angeben wieviel Memory

verwendet werden soll.

.

Im Beispiel unten z.B. max. 14GByte (vmarg5 und vmarg6) physikalisch und virtuell (passt für eine 16GB Maschine)

Immer ein wenig Luft lassen damit die Maschine noch atmen kann ...

main.class=com.world2xplane.GUI.GUI
classpath.1=*.jar
vmarg.1=-d64
process.priority=high
vmarg.2=-XX:+AggressiveHeap
vmarg.3=-XX:+UseParallelGC
vmarg.4=-XX:+UseAdaptiveSizePolicy
vmarg.5=-Xmx14G
vmarg.6=-Xms14G

Share this post


Link to post
Share on other sites

Setze einfach den Haken bei Use Local Storage. Dann kannst du, nachdem er abgebrochen hat einfach dort weitermachen. Alle bis dahin bearbeiteten Kacheln sind dann schon gespeichert. Lediglich die, die gerade bearbeitet wurden sind verloren. Bei mir hat er bei der Deutschland Konvertierung trotz Use Local Storage und auch 14 GB Ram zugeteilt mehrfach mit anderen Fehlermedungen abgebrochen. Insgesamt musste ich aber lediglich drei mal neu starten und dann hatte es w2xpl geschafft.

So ein großes Gebiet einfach nur im Arbeitsspeicher durchlaufen zu lassen ist halt schon sehr mutig...

Share this post


Link to post
Share on other sites

Danke Euch beiden. Genau so nen Tip hab ich gesucht.

Wuste nicht, daß ich in der ini-Datei mehr Speicher zuweisen kann.

Hab jetzt mal 28 GB eingetragen und versuche mein Glück neu.

@ubbi: mit Haken bei use local Storage hab ich ein unerklärliches Phänomen.

Ich bekomme z.B. keinen Münchner Fernsehturm (Bayern) mehr angezeigt. Lasse ich den Haken bei Use Local Storage weg, ist der Olympiaturm da !?!?

Ich gebe Bescheid, wenn es geklappt hat. ;-)

Ach ja, und noch was., Hab eigentlich gedacht, mein Rechner wäre sehr gut ausgestattet und ich wundere mich deshalb, daß W2XP über 24h für Germany benötigt.

Wie ist das bei Euch? Hab schon mal was von ca. 8 Std. gehört.

Edit:

Währen ich dies schrieb hat W2XP gerechnet. Wahnsinn, wie die Kiste jetzt rennt. 10 Kacheln in 40 Minuten. So weit war ich gestern nicht nach 4 Std.

Der ini-Eintrag ist Gold wert. Vielen Dank nochmal. :bow_down2_s:

Mal schauen, ob ich Germany unter 8 Std. fertig hab. ;-))

Gruß Gerhard

Share this post


Link to post
Share on other sites

Du solltest auch noch mal prüfen was in deiner config.xml steht.

Viele Objekte generieren für die große OSM Deutschland Datei braucht viel Speicher.

In der config.xml kannst du einiges einstellen wenn es doch wieder knapp mit dem Speicher wird.

Einfach mal in die Doku von W2XP schauen ....

Ich nehme deshalb immer die Bundesländer und verbinde die dann mit den passenden poly Dateien.

Da kann ich dann mehr Objekte pro OSM Datei generieren ohne das mir der Speicher so schnell ausgeht .....

... und na ja ... ich simuliere ja auch noch Objekte in der conig.xml dazu (sieht meiner Meinung nach einfach besser aus)...

Deshalb gibt es ja auch die w2xp_D+A+CH_beta6.0-xd die PilotBalu generiert hat.

P.S: Ach ja und das Thema mit den Fernsehtürmen .... nimm doch einfach einen von Google Earth (Sketchup) oder

falls du noch FSX Scenerien hast (z.B. VFR Germany oder German Landmarks) konvertiere dir die doch daraus ....

Die sehen sehr gut aus, passen immer und du kannst das Problem mit der Generierung vergessen

Share this post


Link to post
Share on other sites

Ich habe mir jetzt mal w2xp sd beta 6 gedownloaded und habe trotz relativ geringen einstellungen immer nur 16 fps in berlin Tegel...gibts da ieinen Trick ?

post-95139-0-07771900-1425212817_thumb.j

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...