Recommended Posts

4 hours ago, Pitt153 said:

Die beiden Häuser werden mit Flachdach angezeigt.

Das mit der best-fit" Objekt-Regel habe ich nicht realisiert.

Das Problem ist, das es im Netz kaum bis keine config_hd.xml Datei mehr gibt,

an Hand  derer ich lernen kann. (Sind z.Teil alle gelöscht worden.

Ist es so, daß ich die resendital_csv in den World-Models entsprechend anpassen muß?

Benutzt habe ich die config_hd.

 

Aus meiner Sicht kann man alles nötige anhand der mitgelieferten config_hd.xml und csv's erlernen. Die csv's muss man nicht unbedingt anpassen, es sei denn du fügst neue Objekte hinzu oder löschst/änderst bestehende.

 

Im Prinzip kannst du auch die X-Europe Bibliothek als Grundlage nehmen, dann musst du aber die csv's selber erstellen.

 

Die Flachdächer in deinem Fall scheinen - wie bereits vermutet - daran zu liegen, dass keine best-fit Regel anschlägt - sehr wahrscheinlich weil der Grundriss zu gross ist. Interessant wäre hier ein Vergleich mit X-Europe.

Share this post


Link to post
Share on other sites

servus,

ich habe einige fragen zur config.xml...

ist es möglich, für die 3D Modelle unterschiedliche texturen zu verwenden und wenn ja, wo kann ich das definieren? weil industrie- u. häusergebäude verwenden dieselbe textur (concrete1.png). und wie kann ich das 3D modeling deaktivieren? gibts da ein 'tag' für?

ich versuche das meiste in config.xml auf fassaden umzuschreiben, gelingt auch sehr gut, viele neue sachen sind auch dazugekommen, wie z.b. autohäuser, krankenhäuser, schulen etc. aber es gibt immer ein problem mit dem 'tag retail'.. retail gebäude stehn immer mal wieder in Parkhäuser oder supermärkten, hab schon alles probiert, bin soweit, dass ich den 'tag retail' ganz rausnehme. 

hoffe, habe mich verständlich ausgedrückt und danke schonmal.

viele grüsse

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, Blen said:

ist es möglich, für die 3D Modelle unterschiedliche texturen zu verwenden und wenn ja, wo kann ich das definieren?

 

Auf Seite 47 im Manual steht:

 

Quote

If the object inside OSM contains height, colour or material information, World2XPlane will generate unique facade for it and ignore the facade or area-­type area.

 

Da 3D Modelle ja anstelle von Fassaden benutzt werden sofern building:part=* Tags vorhanden sind, würde ich also erwarten dass dies über die OSM-Tags building:material oder building:colour möglich ist.

 

Mögliche Werte für building:material kann man vielleicht anhand der Unterordner im "textures" Ordner ableiten. Selber ausprobiert habe ich das aber noch nie.

 

38 minutes ago, Blen said:

und wie kann ich das 3D modeling deaktivieren? gibts da ein 'tag' für?

 

Global geht das über

<enable-osm-3d>false</enable-osm-3d>

Pro Objekt kann man das nur über "vorgeschaltete" Rules mit entsprechendem Filter unterdrücken, sodass das Objekt "konsumiert" wird, bevor es eine 3D Facade Rule erreicht.

 

Share this post


Link to post
Share on other sites
vor 1 hour , Daikan sagte:

 

Da 3D Modelle ja anstelle von Fassaden benutzt werden sofern building:part=* Tags vorhanden sind, würde ich also erwarten dass dies über die OSM-Tags building:material oder building:colour möglich ist.

danke daikan, werd ich mal ausprobieren.

 

vor 1 hour , Daikan sagte:

<enable-osm-3d>false</enable-osm-3d>

hab ich schon ausprobiert aber dann kommt ne Fehlermelung

 

vor 1 hour , Daikan sagte:

Pro Objekt kann man das nur über "vorgeschaltete" Rules mit entsprechendem Filter unterdrücken, sodass das Objekt "konsumiert" wird, bevor es eine 3D Facade Rule erreicht.

das hab ich leider nicht verstanden aber danke für deine schnelle antwort.

Share this post


Link to post
Share on other sites

Eine Frage zum Clipping von Forrest: Ich habe festgestellt, daß, wenn z.B. eine Autobahn mit einem natural=scrup "übermalt" wurde,

um die weissen Flecken auf der OSM Karte wegzubekommen, dieses "scrup" nicht geklippt wird. Gibt es eine Möglichkeit in worldxplane2, daß "Clipping" auch auf den Tag "natural=scrup" auszuweiten?

Freue mich auf eine Antwort.

Peter

natural = scrub A2 Bielefeld Süd.png

Share this post


Link to post
Share on other sites
On 12/15/2018 at 9:16 PM, Pitt153 said:

Eine Frage zum Clipping von Forrest: Ich habe festgestellt, daß, wenn z.B. eine Autobahn mit einem natural=scrup "übermalt" wurde,

um die weissen Flecken auf der OSM Karte wegzubekommen, dieses "scrup" nicht geklippt wird. Gibt es eine Möglichkeit in worldxplane2, daß "Clipping" auch auf den Tag "natural=scrup" auszuweiten?

 

Leider nein - ist ein bekannter Bug. Es gibt noch viele andere Fälle, wo das Clipping nicht funktioniert und die Vermutung ist, dass nur Polygone mit "landuse=forest" berücksichtigt werden.

 

Siehe auch:
https://forum.aerosoft.com/index.php?/topic/130901-simheaven-x-europe-20/&amp;do=findComment&amp;comment=878268
 

 

Share this post


Link to post
Share on other sites

Hallo Daikan, danke für den Hinweis. Dann bleibt nichts anderes übrig, als in OSM selber "Hand" anzulegen.Grossflächige Gebiete, die über Autobahnen "gemalt" wurden, um die weissen Flecken aus OSM zu füllen, (davon gibt es einige in OSM, wobei man den Mappern nicht unbedingt einen Vorwurf daraus machen kann, da sie es nicht wissen - hier wäre ein Eintrag in WIKI sinnvoll) kann man mit JOSM relativ einfach splitten. Für Ostwestfalen bin ich schon damit angefangen, mit Worldxplane2 generiert und siehe da, der unnatürliche Baumbewuchs auf den Strassen ist weg. Wenn das alle in ihren Heimatregionen machen, kriegen wir das doch wohl hin..😉

Share this post


Link to post
Share on other sites

Hallo, weiß jemand, wo ich die Version 0.74.(nicht 0.741) beziehen kann. (bzw. hat jemand noch die Version? ) Hintergrund ist, daß Tony in der 7.4.1 einige Funktionen deaktiviert hat. (z.B. building=colour)

 

Share this post


Link to post
Share on other sites

servus,

 

kann mir nochmal jemand erklären, wie man die 3d gebäude deaktiviert?

 

<enable-osm-3d>false</enable-osm-3d> funktioniert nicht, hab schon alles mögliche ausprobiert.

 

wäre wirklich sehr dankbar für Hilfe

Share this post


Link to post
Share on other sites
33 minutes ago, Blen said:

kann mir nochmal jemand erklären, wie man die 3d gebäude deaktiviert?

 

<enable-osm-3d>false</enable-osm-3d> funktioniert nicht, hab schon alles mögliche ausprobiert.

 

Bei mir funktioniert's.

Was genau passiert denn bei dir? Fehlermeldung? Screenshot inkl. Koordinaten? Vielleicht magste mal deine config.xml anhängen?

 

Share this post


Link to post
Share on other sites
vor 23 Stunden , Daikan sagte:

 

Bei mir funktioniert's.

Was genau passiert denn bei dir? Fehlermeldung? Screenshot inkl. Koordinaten? Vielleicht magste mal deine config.xml anhängen?

 

ich bekomme immer die fehlermeldung "generation failed, please check log window for details!"

wäre wirklich toll daikan, wenn du dir die config.xml mal ansehen könntest 😏, irgendwie komm ich überhaupt nicht weiter damit.

config.xml

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now