Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content

Archived

This topic is now archived and is closed to further replies.

steveX

Mehr Frames? Kein Problem!

Recommended Posts

Hallo zusammen

 

Habe tagelange getüftelt und getestet, um das maximale aus den Einstellungen zu gewinnen.

War einfach nie zufrieden mit den Frames, aber die Mühe hat sich schlussendlich gelohnt.

 

Kurz zusammengefasst konnte ich durch folgende Massnahmen ca. 15-17 FPS gewinnen. Durch den Leistungsgewinn, kann ich XPlane jetzt sogar mit HDR betreiben.

 

Z.b. Einstellungen mit HDR, CRJ200, Start bei LSZH (Zürich), Aerosoft Airport Addon (LSZH), Static Planes (LSZH), HD Mesh.

Start mit ca. 25-30 Frames. Nach dem Start steigen die Frames auf gute 40-50 FPS.

 

Ich habe zwei Konfigurationen zusammengestellt. Die Nvidia Einstellungen sind jeweils auch unterschiedlich. (mit oder ohne HDR)

 

Das wichtigste ohne HDR ist auf jeden Fall, dass ihr das Antialiasing und Anisotropic-Filter auf das min. einstellt und dies durch die Nvidia Einstellungen regeln lasst.

 

Zu den ganzen Einstellungen kommen noch die neuen Wolken in der reduzierten Auflösung. Durch diese Clouds ist es ohne Probleme möglich die Wolkendetails auf 50% oder mehr einzustellen.

Die Wolken sind aus Xplane.org, aber ich habe diese als Zip beigefügt.

Überschreibt einfach die Dateien aus eurem Xplane Ordner in:

 

XP10\Resources\Bitmaps\world\clouds

 

Probiert die Einstellungen einfach aus. Mir hat es sehr viel gebracht.

Ich hoffe es hilft vielleicht jemandem.

 

Postet doch eure Erfahrungen mit diesen Einstellungen, ob es etwas gebracht hat.

 

Gruss

 

PC: i73770K (OC 4.2), 16GB Ram, GTX 660 Ti Top (2GB-Vram), MSI Z77 Mpower

Xplane 10.22

 

 

Edit: Falls ihr noch mehr Frames wollt, dann deaktiviert "draw per Pixel lightning". Das bringt einiges und gilt für mit und ohne HDR.

Die Vram Kompression könnt ihr natürlich einschalten. Ich brauche es einfach nicht, da ich mit meinem Vram momentan noch zurecht komme. Ohne Kompression sind die Flugzeugtexturen (Cockpit) etwas besser.

Fullscreen Resolution sollte eigentlich eingeschaltet sein.....ist ein Fehler von mir. Habe den Fullscreen Modus deaktiviert um die Bilder zu erstellen.....normalerweise ist es an.

 

 

X-Plane-Settings ohne HDR.zip

X-Plane-Settings HDR.zip

clouds.zip

P.S Die Dateien sind nun neu eigefügt. Viel Spass! ACHTUNG: Die Clouds sind nur kompatibel ab V1.36.....denke das sollte aber kein Problem sein.

Share this post


Link to post
Share on other sites

Interessant. Ich habe bis auf die Overclocked CPU das gleiche Setup.

Versuche mal Morgen deine Einstellungen.

Aber mit HDR kann ich auch jetzt schon mit locker 35 frames fliegen. Wolken sind bei mir Skymaxx.

Share this post


Link to post
Share on other sites

Tolle Arbeit, danke. Ich habe mit deinen Einstellungen rumgespielt und tatsächlich auch noch mehr rausholen können. Die Framerate schwankt jetzt zwischen 29 fps am Boden auf einem Flughafen und um die 48 fps in der Luft. Also immer noch in etwa gleich wie vorher, aber ich habe Schattenberechnung, World Details und anderes wieder auf maximum, Wolken auf 60%. Das ganze sogar mit den tollen HD-Daten von Alpilotx (wieso eigentlich noch eine V 2.0, ist ja schon perfekt :-) ).

Share this post


Link to post
Share on other sites

Ich hab es ausprobiert, die Last der Grafikkarte aber noch ein wenig verstärkt (GTX 770), und muss sagen: Super, ich bleibe dabei. Ich freue mich über circa 8 bis 10 FPS, die die Maßnahme gebracht hat.

Eine kleine Anmerkung zu den Einstellungen des Antialising und anisotropischen Filterung: Die Einstellung in X-Plane und im Control Panel von NVidia sind bei mir je identisch.

Herzlichen Dank nochmal,

besten Gruß

Dirk

Share this post


Link to post
Share on other sites

Hallo SteveX,

danke für deine Mühe. Hat sich echt gelohnt, bin total begeistert. Super sache, kann ich nur empfehlen.

Share this post


Link to post
Share on other sites

Hallo zusammen

Danke für all die positiven Feedbacks....das freut mich sehr ;-)

Dachte ich muss dieser XPlane Community auch mal was zurück geben. Habe von euch ja auch oft gute Infos in anderen Beiträgen erhalten.

Noch eine andere Anmerkung, die vielleicht komisch klingt.

Habe in all diesen Tests folgendes festgestellt:

Wenn Xplane schon mal gestartet wurde und ihr danach an den Nvidia Einstellungen rum fummelt, kann es sein dass ihr nicht die volle Leistung habt.

Erst nach einem Neustart des Computers habt ihr dann plötzlich mehr Frames als vorhher.

Komisch....ich kanns leider nicht erklähren, habs aber oft festgestellt.

Gruss

Share this post


Link to post
Share on other sites

Erst nach einem Neustart des Computers habt ihr dann plötzlich mehr Frames als vorhher.

Komisch....ich kanns leider nicht erklähren, habs aber oft festgestellt.

Das ist relativ normal. Bestimmte FUnktionen bzw. in diesen Fall wohl Shaderinitialisierungen müssen an einer bestimmten Stelle im Ablauf aufgesetzt werden, bevor andere Funktionen aufsetzen dürfen. Dieses komplexe Rollback kann sehr aufwendig sein, wehalb man in solchen Fällen häufig kein echtes Rollback durchführt oder bestimmte Werte während des Betriebs einfach nicht neu liest.

Share this post


Link to post
Share on other sites

Insbesondere die reduzierte Wolkenauflösung hat einen großen Effekt. Das hatte ich eine Weile mal bei mir genutzt, aber mittlerweile bin ich davon wieder abgekommen; es sah dann doch arg pixelig und v.a. detailarm aus, wenn man am Rand der Wolken entlang flog :)

Share this post


Link to post
Share on other sites

Ich habe jetzt deine Settings (mit HDR) ein paar Tage getestet. Ich habe ja genau das gleiche Hardwaresetup wie du, jedoch meine CPU nicht Overclocked.

Frames:

vielleicht 5 mehr

Eindruck:

Sim läuft flüssig, leider sind die Texturen verschwommen. Kam durch das Setting der Texture Qualität auf "Hohe Leistung" in der Nvidia Systemsteuerung. Habe wieder auf Qualität geschaltet und schon waren die 5 Frames weg.

Ich denke das durch die anderen Wolkentexturen (klein 256x256) und die geringe Textureauflösung der Framesprung zu Stande kommt. Dann kann man auch die Objektdichte und Sichtweite erhöhen.

Share this post


Link to post
Share on other sites

Oh, danke für die Wolken... Ich werd das gleich mal testen... Seit dem ich die C208B fliege radiere ich doch arg am Rand der Performace entlang. Der Flieger ist halt doch recht Detailreich. Es geht zwar, aber über grossen Städten falle ich unter 20 FPS...

Das mit den Nvidia-Settings teste ich auch gleich mal.

Mit dem Fenstermodus hab ich keinerlei Probleme da ich eine Nvidia Quadro hab, die dafür ausgelegt ist. Bei mir laufen alle Anwendungen in Fenstern... Die Gamerkarten haben damit einige Probleme da die FPS einbrechen sobald mehr als ein Fenster berechnet werden muss.

Fein, hab ich wieder was zum "spielen"... griiins.gif

Liebe Grüsse

Ly

Edit: Hab jetzt über Hamburg knapp 21 FPS, vorher waren es 15-16... Komischerweise ist bei mir X-Plane mit HD Rendering schneller als ohne. Muss ich nicht verstehen... Ich habe meine Settings, was Entfernung und Details angeht, so gelassen und nur mit den Filtern gespielt... Und ich hab mal Texturkompression angemacht, auch wenn ich das mit 4 GB Grafikspeicher eigentlich nicht brauche. Wollte eigentlich den Detailunterschied austesten, hab aber kaum einen festgestellt. Aber ich hab mehr FPS mit Kompression... War ich vorher nur mit den lowdetail Wolken bei 18-19 FPS, sprangen die FPS mit Texturkompression über die 20 FPS Grenze... So kann ich es lassen... Danke nochmal.

Share this post


Link to post
Share on other sites
Guest

Auf Wunsch wiedereröffnet.

Gruß Heinz

Share this post


Link to post
Share on other sites

Hallo,

ist es machbar die Zip dateien noch einmal zu bekommen da ich zu diesem zeitpunkt noch kein Xplane hatte!!!!!???

 

Mfg

Oliver

Danke Heinz das du dieses Topic noch mal geöffnet hast!!!!

 

Gruß

Oliver

Share this post


Link to post
Share on other sites

Hallo Cartman2012

 

vielen dank ich glaube das sieht gut aus nach dem ersten Anschauen genau das was ich suchte!!!!!!!

Werde Morgen mal das ausprobieren, heute schaff ich das nicht mehr.

 

Mfg

Oliver

Share this post


Link to post
Share on other sites

Hallo,

wollte wie im YouTube Video mal FXAA anschalten im nvidia Kontrollpanel. Aber er lässt mich keine Anderungen vornehmen, auch nicht wenn ich es als Admin starte. Habt ihr ne Idee ?

LG Quaxfehler.thumb.PNG.6c7b885fda0bc2d84c177d6

Share this post


Link to post
Share on other sites

Das ist ein definitiv ein NVIDIA Treiber Bug. Da hilft nur Treiber deinstallieren, alles Settings löschen und noch mal den Treiber neu installieren. 

War bei mir auch so und das einzige was geholfen hat ist die Neuinstallation des Treibers. In einigen Foren schreiben betroffene
User das sie die Installation mehrmals machen mussten bis es wieder funktioniert hat. Bei mir aber hat eine Treiber Neuinstallation ausgereicht.

P.S:  Deine NVIDIA Settings kannst du dir ja vorher abspeichern und dann wieder laden. Ich mach das mit dem nvidiaInspector

Share this post


Link to post
Share on other sites
Guest

Die Dateien habe ich neu eigefügt. Viel Spass

Gruss

Vielen Dank, SteveX. Das hilft mir sehr weiter.

Aus unerklärlichen Gründen lagen bei mir die Frames plötzlich im Keller. Teils unter 20. Und so eine schlechte Maschine hab ich doch nicht!? Ich will ja nicht X-Plane 10.40bx die Schuld geben. Aber aufgefallen ist mir dies nach der Installation der Beta-Version von V10.40. Könnte aber auch Zufall sein. Denn gleichzeitig habe ich diverse Freeware-Szenerien mit entsprechenden Libraries hinzugefügt. Jetzt, mittels Angaben von SteveX bin ich wenigstens wieder um die plus/minus 30 Frames. Neu hinzugekommen sind seit der Version 10.40B Ruckler bzw. Stopper während des Fliegens. 

Beste Grüsse, ryma

Share this post


Link to post
Share on other sites

×
×
  • Create New...