Jump to content
Sign in to follow this  
g2loq

help rookie on ATR 42..cannot fly over 100 IAS!!

Recommended Posts

Hello everybody,

I've just got Eurowings and I'm trying to fly with ATR 42-300. After take off I'm not able to fly over 100 Kts (torque at 90%, and prop rpm at 100% :x ). I really don't understand, everything seems ok but apparently not!

Thanks for your help (anybody in french can help me :?: ).

Share this post


Link to post
Share on other sites

thanks Skydvdan, but unfortunately this is not the reason. I put flap up immediately after take off but the speed is decreasing to 80kts and I scratch the plane systematically. Is it a hardware issue ? or someting missing on the procedure?

thks

Share this post


Link to post
Share on other sites

I was just kidding. Could it maybe have something to do with the pitch of the props? Also, is that 100kts also in straight and level flight?

Share this post


Link to post
Share on other sites

Check your weight. Open up the config program and make sure its acceptable. Also, check your fuel when loading in FS. If youre overweight, it will say it.

This happened to me for a good while before I figured out the problem, so I reckon its the same thing :)

Share this post


Link to post
Share on other sites

Thank you very much everybody for your help. I'm gonna try. I guess solution is coming from the overweight.

eid6265, if you don't open the config program you should not have any passenger, isn't it?

Share this post


Link to post
Share on other sites

Hello Eid6265, the overweight was the reason :P

thanks very much, I need lot of hours of pratice now (I'm coming from beechcraft king air 350).

Just one question : is it normal to trim a lot to stabilize the plane?

again thanks for your help

Share this post


Link to post
Share on other sites

Glad to see you have it working now :)

Yes, sometimes the aircraft needs a bit of trim, but it should not require an awful amount.

Cheers,

Daryl

Share this post


Link to post
Share on other sites
Hello Eid6265, the overweight was the reason :P

thanks very much, I need lot of hours of pratice now (I'm coming from beechcraft king air 350).

Just one question : is it normal to trim a lot to stabilize the plane?

again thanks for your help

That depends of course a bit on the balance. If the load is spread well over the aircraft you will not need any trim and will fly very economically, but if you put all your load in the tail of the aircraft you will need a lot of nose down trim and that will cause a lot of drag.

Btw, you choose a perfect aircraft to step up to larger aircraft.

Share this post


Link to post
Share on other sites

Hello guys,

After lot of trials I'm always forced to trim a lot in order to compensate the huge pitch of my plane (more than 25 degres). I specify that my plane is empty (no passenger, no freight, and fuel at 40%). I've attached pic just to show you the level of the trim. Is it really normal to trim like this or something wrong?

Waiting your helpful comments.

bye

Share this post


Link to post
Share on other sites
Hello guys,

After lot of trials I'm always forced to trim a lot in order to compensate the huge pitch of my plane (more than 25 degres). I specify that my plane is empty (no passenger, no freight, and fuel at 40%). I've attached pic just to show you the level of the trim. Is it really normal to trim like this or something wrong?

Waiting your helpful comments.

bye

Could be a problem with the joystick. Could you let the aircraft fly level on AP with the joystick disabled? In FS the AP will always use the trim to keep altitude so it will show if there is a problem.

Share this post


Link to post
Share on other sites

Hello Mathjiskok,

I've tried with AP and it's the same; it's means it's trim down also to compensate, moreover when I'm just opening the plane the trim is already down without any action on it :evil:

I don't think it's coming from my joystick cause i don't face the problem with FS2004 planes.

Should I re-install ATR42? maybe it's coming from the physical properties of the atr42 file.?

6 months back somebody posted the same issue on the forum but no reply.

thanks to help if possible.

Share this post


Link to post
Share on other sites
Hello Mathjiskok,

I've tried with AP and it's the same; it's means it's trim down also to compensate, moreover when I'm just opening the plane the trim is already down without any action on it :evil:

I don't think it's coming from my joystick cause i don't face the problem with FS2004 planes.

Should I re-install ATR42? maybe it's coming from the physical properties of the atr42 file.?

6 months back somebody posted the same issue on the forum but no reply.

thanks to help if possible.

That's very strange, any aircraft will load with the trim setting of the SIM it is not possible to set the trim of an aircraft in the aircraft files. I suggest you load the standard Meigs flight and then change to the ATR, I am sure you will see the trim in same setting as the Cessna has.

If it is not, there is some control input that is changing it, this can you (but it is not), the joystick settings or the Autopilot.

Share this post


Link to post
Share on other sites

Hello, it's stranger now! I've taken off on meigs with cessna and trim was 5.9 degres :!: after I took atr42 on meigs and pitch was neutral. Anyway it's not changing the fact that i still have trim down to compensate the huge climb!

I'm thinking to re-install the plane.

I will let you now in two weeks time. tomorrow i will fly (as passenger only :cry: ) to your nice country for work.

bye

Share this post


Link to post
Share on other sites
Hello, it's stranger now! I've taken off on meigs with cessna and trim was 5.9 degres :!: after I took atr42 on meigs and pitch was neutral. Anyway it's not changing the fact that i still have trim down to compensate the huge climb!

I'm thinking to re-install the plane.

I will let you now in two weeks time. tomorrow i will fly (as passenger only :cry: ) to your nice country for work.

bye

I am now more and more sure it's your stick. Again, the advise, try without the stick.

Share this post


Link to post
Share on other sites

You're right. I tried without my joystick and no problem for the trim.

What I don't understand is my Saitek Cyborg Evo works perfectly well with the FS9 aircrafts.

there is any conflict known between the Saitek and the ATR42?

I don't see any solution as I'm not ready to buy a new joystick only to fly with the ATR.

Thanks

Share this post


Link to post
Share on other sites
You're right. I tried without my joystick and no problem for the trim.

What I don't understand is my Saitek Cyborg Evo works perfectly well with the FS9 aircrafts.

there is any conflict known between the Saitek and the ATR42?

I don't see any solution as I'm not ready to buy a new joystick only to fly with the ATR.

Thanks

There is no known conflict up to this moment. But I am also very surprised there is a problem. The trim functions are the same as far as I can tell between default aircraft and the ATR. Really a suprising problem.

Few questions,

- Are you using any special joystick drivers, software, special assignments of joystick keys?

- Are you sure all sliders and rotating controls on your joystick are in neutral position when you have the problem?

- Did you try to recalibrate the stick?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...