Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
JKH

Unable to install (run) CumulusX

Recommended Posts

Hi,

I have downloaded CumulusX and WinchX, however I can't make any of them working. When I run either .exe I immediatly get a "The program has stopped working" error. I've tried running them as administrator and in compitability mode with both Vista and XP SP3 without success.

I'm running Windows 7, 64 bit.

Any ideas?

Thanks in advance!

  • Upvote 1

Share this post


Link to post
Share on other sites

I have FSX Deluxe Gold so I guess that's ACC, (however I don't think that has anything to do with the problem, as I'm not able to run the .exe files at all?)

Share this post


Link to post
Share on other sites

I have FSX Deluxe Gold so I guess that's ACC

Yes you have, but only if you went through the second install step during which SP1 and ACC will be installed. By default you'll get only FSX vanilla. You can check by looking for the P51 or F-18 in you aircraft collection. If they are missing you're still at the RTM level. You have to look at on the disk to find the acceleration setup.

CumulusX! relies on a library version contained in SP2 and ACC. Without it will crash upon startup.

best regards,

Peter

Share this post


Link to post
Share on other sites

Yes you have, but only if you went through the second install step during which SP1 and ACC will be installed. By default you'll get only FSX vanilla. You can check by looking for the P51 or F-18 in you aircraft collection. If they are missing you're still at the RTM level. You have to look at on the disk to find the acceleration setup.

CumulusX! relies on a library version contained in SP2 and ACC. Without it will crash upon startup.

best regards,

Peter

I did indeed have Acceleration installed, then. Now, I've tried removing Acceleration and replacing it with SP1+SP2, but when I launch CumulusX (A freshly downloaded version) the problem is the same.

Edit: And now I've removed SP2 again and re-installed Acceleration - same result.

Edit2: Could it have anything to do with the fact that I do not have FSX installed in the default position (F:\MSFS) ?

Share this post


Link to post
Share on other sites

Edit: And now I've removed SP2 again and re-installed Acceleration - same result.

That should have re-installed the library in any case.

Edit2: Could it have anything to do with the fact that I do not have FSX installed in the default position (F:\MSFS) ?

That that shouldn't matter.

Did you install CumulusX1.8 first and then 1.8.1 patch, or does the error message occur already during install?

Could you post a screenshot of the error message?

best regards,

Peter

Share this post


Link to post
Share on other sites

1: I download the zipped version 1.8

2: Unzip

3: I run the batch file. The cmd opens and launches the exe.

4: The exe immediatly stops working, giving the following error message:

cux18err.png

CumulusX! 1.8.0 has stopped working

Windows is searching for a solution...

[Cancel]

5: The error message closes after a few seconds and nothing more happens

So I never actually get any UI from the exe, just the cmd and then the error message.

Share this post


Link to post
Share on other sites

Hi Jonathan,

let's try this, to rule out a basic problem with FSX installation:

Go to the directory with the unzipped archive, navigate to this subfolder:

Modules\CumulusX!

and double-click CumulusX.exe. This starts CumulusX! in user mode, without attempt to integrate into the FSX directory structure and setting up for autostarting with FSX.

Please report the result.

best regards,

Peter

Edit: You may also try the attached "HelloWorld" to verify your Dotnet Environment is working.

HelloWorld.zip

Share this post


Link to post
Share on other sites

Same result

Edit:

Edit: You may also try the attached "HelloWorld" to verify your Dotnet Environment is working.

HelloWorld.zip

Supposing the result should be a pop up window with the text "Hello World" then it seems to work just fine.

Share this post


Link to post
Share on other sites

Hi Jonathan,

unless you have some other addon using the Simconnect.dll and which is working properly, it seems that you have a broken FSX installation. Did you have an FSX install previously to Gold? The only way to recover (to my knowledge) is the following procedure:

Uninstall FSX completely.

Navigate to C:\Windows\winsxs

Search for *flightsim*

You should not find anything, but it may take while until complete as this directory is not indexed.

However in your case you may find remaining files from FSX even after the complete uninstall:

Up to three subdirectories:

[x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297]

[x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20]

[x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568]

And those files in the subdirectory "manifests":

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297.cat

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297.manifest

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20.cat

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20.manifest

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568.cat

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568.manifest

Delete the three simconnect subdirectories and the six files as above. Do not delete the entire subdirectory "manifest". Reinstall FSX and ACC again, then install CumulusX!.

Well, this work-around is risky. If you delete any other files than exactly those you may end up with re-installing your PC entirely.

best regards,

Peter

Share this post


Link to post
Share on other sites

Hate re-installing FS, but if you think that's the only solution, I guess I'll have to play around with that. Thanks for the help :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...