Jump to content
Joshua Che.

My Alternative to Aerosoft FBW v0.8f2 - NO FSUIPC

Recommended Posts

I thought the airsimtech joystick software already include a FBW Module? If you don't know what 'LH1711 callouts" is then just try running the patcher again with FSX closed.

Regards,

Joshua Che.

Hi!

Airsimtech has the FBW only for the PRO software included, not for the advanced one.

I'll try the workaround with the patcher again,

thanks!

Christoph

Share this post


Link to post
Share on other sites
Hi! Airsimtech has the FBW only for the PRO software included, not for the advanced one. I'll try the workaround with the patcher again, thanks! Christoph

Sorry for the late reply as my exams are still going on.

If airsimtech does not have FBW, why are you using it? :huh:

I am sure if you assign it to Default FSX controls it should work.

Nonetheless, hopefully FBW v0.9 will fix it with use of FSUIPC.

Regards,

Joshua Che.

Little 'o' update:

FBW v0.9 still progressing well. After inserting a pid controller, The aircraft pitch slightly downwards when the FBW kick in at 50ft like the real aircraft!.

Share this post


Link to post
Share on other sites

Hi!

I must use the joystock software because this is the base for the function of the airsimtech server. For this reason I have to deactivate the joysticks in the FSX menu.

Thanks, Christoph

Share this post


Link to post
Share on other sites

Excellent !! thank you so much... this is now the Airbus I was waiting for !

only one little thing : I find the bank angle protection not as good as on the Wilco one....

best regards

Greg

Share this post


Link to post
Share on other sites
Hi! I must use the joystock software because this is the base for the function of the airsimtech server. For this reason I have to deactivate the joysticks in the FSX menu. Thanks, Christoph

Let me put it bluntly. Choose either FBW protection or your home cockpit. it is not possible to have Bank protection when a software is interfering with my code. I will see if there's a workaround. For now, you have to use it without protections.

Excellent !! thank you so much... this is now the Airbus I was waiting for ! only one little thing : I find the bank angle protection not as good as on the Wilco one.... best regards Greg

FBW V0.9 should be better.

Thanks a lot.. How is v0.9 progessing?

Slowly but still progressing as i am stil having exams till next week.

Hi, I fly the A320 in Brazil and if you need I can test this FBW. thanks in advance.

Check your PM.

Share this post


Link to post
Share on other sites

Thanks for doing this. I had given up on this aircraft due to the flawed FBW modelling. I can now land it properly and it's back out my virtual hanger.

Share this post


Link to post
Share on other sites
Thanks for doing this. I had given up on this aircraft due to the flawed FBW modelling. I can now land it properly and it's back out my virtual hanger.

Thanks !

EDIT: w00t ! Major Breakthrough in the FBW v0.9 all is good for now. Lots more to do because it is a recode.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello Joshua, I love your FBW, and I only recently found this great modification. I don't have any problems with it, but one thing kinda bugs me with your patch installed. When I select the Airbus X it automatically turns "autorudder" on in the realism settings. I have a joystick, and rudder pedals so I like to have autorudder off (controls rudder and allows me to steer on the ground with the joystick). When taxing to the runway if I move the joystick, the plane turns left and right obviously because autorudder is turned on. Once I have started the session in fsx, I can go in and turn autorudder off, and it will stay off until the next time. I want it off, but it always comes back on when I select the Airbus X to fly with. If I use another plane it stays off, so I know it must be this mod causing it to automatically come on. I will say that having autorudder off doesn't affect your FBW while in flight, it still acts the same as when its on, so you think could change this so its off by default using your mod? It is a great mod and makes this airplane alot more enjoyable to fly. Keep up the great work! :)

-nIcK

Share this post


Link to post
Share on other sites
Hello Joshua, I love your FBW, and I only recently found this great modification. I don't have any problems with it, but one thing kinda bugs me with your patch installed. When I select the Airbus X it automatically turns "autorudder" on in the realism settings. I have a joystick, and rudder pedals so I like to have autorudder off (controls rudder and allows me to steer on the ground with the joystick). When taxing to the runway if I move the joystick, the plane turns left and right obviously because autorudder is turned on. Once I have started the session in fsx, I can go in and turn autorudder off, and it will stay off until the next time. I want it off, but it always comes back on when I select the Airbus X to fly with. If I use another plane it stays off, so I know it must be this mod causing it to automatically come on. I will say that having autorudder off doesn't affect your FBW while in flight, it still acts the same as when its on, so you think could change this so its off by default using your mod? It is a great mod and makes this airplane alot more enjoyable to fly. Keep up the great work! :) -nIcK

The autorudder is forced on for Auto coordination (Coordinated turns) for FBW although it does not work very well. It also work as a yaw dumper. Removing it essentially removes the rudder from the FBW.

Regards,

Joshua Che.

Share this post


Link to post
Share on other sites

Guys,

I have decided to cancel FBW v0.9 as Airbus X V2 should fix this. I do not see the need to continue the FBW. On top of that, the time taken for this has hit my studies real hard so I am spending the holiday brushing up my studies and hope that Airbus X V2 will fully model the FBW.

Regards,

Joshua Che.

Share this post


Link to post
Share on other sites

BTW, the current version works fine, but little problem. A321 - Perfect autoland!

A320 autoland: Not so good.. It doesnt flare.. I come about 150 knots down and it says LAND in PFD, when in 10-30 ft, the FLARE comes to PFD, so the plane doesnt start flaring early, but A321 does flare early so it does smooth autoland.. But A320 does not have time to flare. Can you fix this?

Share this post


Link to post
Share on other sites

There are 4 versions should i install only the last one?(F2)

Share this post


Link to post
Share on other sites
There are 4 versions should i install only the last one?(F2)

Yes. It is the latest and the most stable.

Share this post


Link to post
Share on other sites
Hey, are you able to repair A320 autoland, it doesnt have time to flare, A321 lands OK.

Sorry for the late reply. I will look at it when I am free. Apparently I have lost my source files for the v0.8f2 but I will make a incremental patch that installs on top of it.

Share this post


Link to post
Share on other sites

Guys,

This project is indefinitely suspended. I am helping with the Airbus Extended and it seems to be no time for this project.

Share this post


Link to post
Share on other sites

Well, your knowledge will help in proper FBW development for Extended version, thanks for what you did so far!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...