Jump to content
Sign in to follow this  
NaviAtHeart

Discus X & SP2 problems,

Recommended Posts

Hello, I'm new to aerosoft forums, and I've been having a difficult situation that I can't figure out.

As you know, Cumulusx! and WinchX don't work without SP2. I currently have FSX Deluxe and I downloaded Discus X, and it worked all right.

Installed SP1, no problem. But CumulusX! & WinchX!, no avail.

Installed SP2, got what I wanted, they both worked all right. I have Win7 and I ran both of them through administrator.

But, when I selected the Discus X(B,BT,BM), the 3D model that is spinning DOESN'T SPIN, then, a window popps up checking for errors in FSX, and then, it changes to "Windows can't figure out the problem and needs to close".

I tried re-installing DiscusX, didn't solved it. Re-installed the WHOLE FSX, and worked my way up again, still the same...

Is there any help? I seriously need a self launcher!

Share this post


Link to post
Share on other sites

Hmm, in another topic you said, the flight dynamics are ok, so the problem is solved?

The Discus needs also SP2. So first install FSX, then SP1 then SP2 then Acc (If you have it) then the Discus.

Bests Joachim

Share this post


Link to post
Share on other sites

Hmm, in another topic you said, the flight dynamics are ok, so the problem is solved?

The Discus needs also SP2. So first install FSX, then SP1 then SP2 then Acc (If you have it) then the Discus.

Bests Joachim

Joachim, I have done that. And 3-4 times, same results. As if Discus X is allergic to SP2 or something.....

I might try acceleration this time, I forgot...

And no, when I was talking about flight dynamics, that was flying it in FSX and SP1, but doesn't work in SP2....

Share this post


Link to post
Share on other sites

Thats really strange. The Discus was made for SP2. Maybe your SP2 version is corrupt? Try to download it again, or try acc. (Install SP2 before!!! it is needed even if Acc contains it)

Bests Joachim

Share this post


Link to post
Share on other sites

I might try acceleration this time, I forgot...

Prior to installing Acc, uninstall SP2....

Share this post


Link to post
Share on other sites

Just for an update, it did no good. I installed acceleration, then Discus X, but still hangs up and shuts down... :angry:

That's it, I give up! I'm gonna buy a real Discus second-handed!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...