Recently we have seen a lot of codes used to unlock our products being offered for discounted prices. Almost all of them are bought using stolen credit cards. These codes will all be blocked by our systems and you will have to try to get your money back from the seller, we are unable to assist in these matters. Do be very careful when you see a deal that is almost too good to be true, it probably is too good to be true.

Jump to content
sawt

FSX stops working as soon as I attempt to load Discus glider

Recommended Posts

Okay, we we got a new idea. Could be the ASC sound module...

If you rename the ASC.DLL in the panel folders shown below to something like ASC.thiscouldbecausingtheproblemsIamhaving (okay ASC.DL! will also do) and insert the version attached to this post and report back.

FSXmain folderSimObjectsAirplanesAerosoft_DiscusBpanel

FSXmain folderSimObjectsAirplanesAerosoft_DiscusBMpanel

FSXmain folderSimObjectsAirplanesAerosoft_DiscusBTpanel

Did anybody try the new ASC? I did not see any feedback to this. Could be the people who tried it got there problems sorted and are now flying byt we still like to know.

ASC.zip

Share this post


Link to post

The sounds are in the plane, every swithc and so on is such a ASC sound.

If you gon into a side slip, there are even 9 sounds that are played.

This are the sounds.

Joachim

Share this post


Link to post

As yet, noone else seems to share my particular Discus problem, so this may be useful. After a frustrating weekend trying to make the aircraft function, I believe I've identified the cause.

I encountered multiple CTDs - on aerotow with the B, on trying to erect a BM or BT engine, start an engine, operate switches,even simply move my cursor toward Winch X in the addon menu. [i never clicked it] Every time, the error message referred to Winch X.

Clue No. 1: from the beginning, as soon as the Discus appeared on my screen, I heard a motor running. Not an aircraft engine, but what my memory of gliding days identified as probably a winch. Clue No.2: exiting FSX, I noticed that there was a Winch X tag in the taskbar. I'm no expert, but could it be that Winch X ws somehow starting up automatically with FSX?

OK, only one obvious solution: I deleted all the many Winch X files scattered through my system. Result: my Discus now functions perfectly. To a one-time Discus pilot, it's wonderfully realistic in handling and sounds and thermal behaviour. I've just flown a 50km xcountry, with with the aid of 10kt default thermals. Great!

But I'm not so happy that an expensive aircraft only functions with a key function disabled.

Share this post


Link to post

As yet, noone else seems to share my particular Discus problem, so this may be useful. After a frustrating weekend trying to make the aircraft function, I believe I've identified the cause.

I encountered multiple CTDs - on aerotow with the B, on trying to erect a BM or BT engine, start an engine, operate switches,even simply move my cursor toward Winch X in the addon menu. [i never clicked it] Every time, the error message referred to Winch X.

Clue No. 1: from the beginning, as soon as the Discus appeared on my screen, I heard a motor running. Not an aircraft engine, but what my memory of gliding days identified as probably a winch. Clue No.2: exiting FSX, I noticed that there was a Winch X tag in the taskbar. I'm no expert, but could it be that Winch X ws somehow starting up automatically with FSX?

OK, only one obvious solution: I deleted all the many Winch X files scattered through my system. Result: my Discus now functions perfectly. To a one-time Discus pilot, it's wonderfully realistic in handling and sounds and thermal behaviour. I've just flown a 50km xcountry, with with the aid of 10kt default thermals. Great!

But I'm not so happy that an expensive aircraft only functions with a key function disabled.

As far as I am aware there was no reports of CTD's within the Beta relating to WinchX. The only stipulation with WinchX is that you need a minimum of 20fps. Some systems will do a neat launch on less.

On installing WinchX then it adds an entry in exe.dll, if this is the case when you fire up FSX it will load WinchX. Two remodies to this is either 1. delete the entry in exe.dll or 2. on startup just close WinchX if it's not needed.

No doubt others will chirp in on this one also, but, I can only inform you as to what I gathered from the Beta.

Share this post


Link to post

We like to see a few screenshots of the crashed system (so any error message).... as soon as possible please.

Share this post


Link to post

I've deleted all files from WinchX but the Problem is still there.

I have Vista 32bit and the review Copy, maybe this is important.

:(

Share this post


Link to post

I've deleted all files from WinchX but the Problem is still there.

I have Vista 32bit and the review Copy, maybe this is important.

:(

You also have CumulusX running?

Share this post


Link to post

You also have CumulusX running?

Is it also contained in the glider? Because i didn't download it.

Did anybody try the new ASC? I did not see any feedback to this. Could be the people who tried it got there problems sorted and are now flying byt we still like to know.

This also didn't work. :(

Share this post


Link to post

It crashes on my computer as well here are my answers to them :P

1) where do you have FSX installed = default /program files path

2) what windows are you using? = Windows XP

3) are you logged on with administrator rights? Yes

4) did you changed anything regarding User Account Control (UAC) on your system? No?

Hope this helps.

Share this post


Link to post

I got another tip for you.

All people with CTDs, please delete CUMULUSX!

It CAN be that there is something wrong in communication between the C4 and CumulusX!

None of these programs are bad or something. But they work together and one guy found out that he didn't get the CTDs anymore when cumulus is deinstalled.

Yes, even if it works with other planes.

As I said, it is not this program alone. (If at all)

Bests Joachim

Share this post


Link to post

I've had it, Mathis. Yesterday the wretched thing worked fine after deleting Winch X. Today, hopeless. Starter button = CTD. I've run out of patience with a product which appears to have been prematurely released.

post-4204-125234185226_thumb.jpgpost-4204-125234227337_thumb.jpg

E6850/GTX 260/8 mb RAM

I never thought that Aerosoft, of all people, would let me down. I believe I am entitled to a refund, or at the very least a credit note for use when this aircraft grows up.

Regards

Peter Browne

Share this post


Link to post

Hi there

I face the same problem as all the other guys.

Entering the cockpit CTD with the default "Flight Simulator funktioniert nicht mehr" Errormessage.

And even more funny, like the ones tned to be not believed my simulator also worked real fine yesterday ( I posted the thread with the textures showing through and had no CTD at that time) and today i never get it to work anymore.

I too have CumulusX 1.5 installed yesterday after some frustrating non thermal flights. In Kiel-Holtenau i never made it back to the airfield and drowned in the Kieler Förde with no updraft at all.

System: Core 2 Duo 8500, GTX 285, 4GB Ram

Windows 7 RC 64bit (all updates installed by windows update)

UAC turned OFF (of course!)

Admin rights YES, only account on the system

CTD happened every now and then before but not this often and not fixed to the point regarding one special plane or place.

I hope you find a solution fast.

Share this post


Link to post

Well i did one thing: I started the "standardflug" and landed the glider (air creation default FS) plane savely at Friday harbour.

Saveed as a new standardflug and started from there.

Load Discus aircraft; START winchX and up i go with no CTD.

Only problem I face the last two days is i never have ANY upwinds at all.

I changed weather from Clear Sky to good weather conditions to download actual weather via Internet...nothing. No updraft in ten flights. All were about 5 minutes long and ended in stranded/crashed plane while landing anywhere in the "pampa".

Even CumulusX made no difference! How dio i genereate upwinds in FS? Do i need Active Sky Advanced to creat weather that works?

Don't know what to do. This way soaring isn't much fun at all!

I do have to admit, i am no r/l sailplane pilot. I never learned to do that. Maybe it's me doing it just wrong in a way.

Some explanations?

Waiting for an answer, Mario.

Share this post


Link to post
I've had it, Mathis. Yesterday the wretched thing worked fine after deleting Winch X. Today, hopeless. Starter button = CTD. I've run out of patience with a product which appears to have been prematurely released.

Peter,

This product is all but prematurely released

As you can see, a fraction of people who bought the discus have problems. How can WE know, during developement, that YOU will have a problem?

We sorted all things, we knew out, and that VERY well and precise, and you call it "prematurely released".

This is cool, especially because you don't seems wanting to work with us, to sort the issue out.

I never thought that Aerosoft, of all people, would let me down. I believe I am entitled to a refund, or at the very least a credit note for use when this aircraft grows up.

I am working all the weekend, and the whole day now, to solve this issue. I am work only, and ONLY on this issue! And even yus, who have NOTHING to do with aerosoft help me.

You say, we let you down?

WOW, very cool, too.

You even do not answe to my questions!

Again, is CumulusX! installed? Yes or no?

If yes, delete, try again, and report!

We all can't reproduce the issue. We need YOU to help us, that we can help you!

At least it is a problem with your system, not with ours.

We ensure, that the plane works on a clean OS, with a clean FS. And it does. We can't ensure more.

But we want to have...

I too have CumulusX 1.5 installed yesterday after some frustrating non thermal flights. In Kiel-Holtenau i never made it back to the airfield and drowned in the Kieler Förde with no updraft at all.

Please U too, UNINSTALL cumuluss. We must know if it causes a bad reaction with the C4.

Joachim

EDIT. Please deactivate your "b21_vario.dll" for a test, too.

(modules\b21_vario\b21_vario.dll)

rename it to b21_vario.dllmaybefault or something)

It controlles the sound of the C4.

You'll have a uncompensated vario then, but this is only a test.

As soon as we found the issue we can start solving it.

Share this post


Link to post

Please U too, UNINSTALL cumuluss. We must know if it causes a bad reaction with the C4.

Joachim

I'm on it. as you see in my last post, i have no CTD anymore when starting from "standardflug" and loading airplane and airport after that.

like in old FS2004 days, some planes (like the Digital Aviation Cheyenne) reacted VER VERY sensual on starting them direktly from the opening screen in FS.

Bitte, Joachim, lass dich nicht ärgern!

Ich kenne diese Leute nur zu gut, die nur zuhause sitzen und meckern, meckern, meckern....aber nichts tun wollen.

Ich habe selbst mit Kunden zu tun und bin auch manchmal bis abends spät noch im Büro und arbeite am WE nur damit die Leute zufrieden sind. und wenn dann alles gut ist, bekommt der Chef ne Falsche Champagner und ich eine rein, warum das so lange gedauert hat und ob ich mir nicht ne neue Stelle suchen möchte. Ich müsse ja hier nicht arbeiten....

Lass dich nicht ärgern!

Wir finden eine Lösung!

Haben es mit allen anderen Sachen geschafft, dann auch hier!

So, ich UNINSTALLiere erstmal CumulusX.

Melde mich dann wieder.

Liebe Grüße aus der Heimat, Mario.

  • Upvote 1

Share this post


Link to post

I got another tip for you.

All people with CTDs, please delete CUMULUSX!

It CAN be that there is something wrong in communication between the C4 and CumulusX!

None of these programs are bad or something. But they work together and one guy found out that he didn't get the CTDs anymore when cumulus is deinstalled.

Yes, even if it works with other planes.

As I said, it is not this program alone. (If at all)

Bests Joachim

I don't think so, because i've got the same issue ad I haven't installed CumulusX.

By the way: A friend of me has got the same issue, and he has got Vista 32bit, too. So i think the glider has a problem with all system softwares (Windows XP, too).

I deinstalled and installed the FSX again to see if it works now, i will report as soon as possible. Hope we can fix the problem ;)

I have to say this in german:

Hey Joachim,

Ich werde mich jetzt auch hinsetzen und testen und ausprobieren, villeicht finden wir ja eine Lösung.

Ich werde versuchen, so gut wie möglich zu helfen, denn der Flieger ist einfach klasse, da habt ihr super Arbeit geleistet!

Mal schauen was die Neuinstallation so bringt. Und bitte beschränkt euch beim Suchen des Fehlers nicht auf Vista 64bit, denn ich kenne jetzt schon mehrere Leute (mich eingeschlossen) , bei denen der Glider auf Vista 32 bit und sogar auf XP nicht funktioniert.

Share this post


Link to post

I can imagine how frustrating these CTDs must be...but I have to say that I've not experienced any problems. Here's what I've got installed and where:

First my computer specs:

Asus P5QC MB

Q9550 Core 2 CPU oc 3.4 GHz

4 GB OCZ PC2 6400 DDR2 RAM

BFG GeForce 275 GTX (stock speeds), 182.50 driver

Corsair 850HX PSU

1 WD Raptor X 150 GB SATA HDD (dedicated for FSX)

2 Seagate 320 GB SATA HDDs

1 Seagate 1 TB HDD (C: drive)

SoundBlaster X-Fi XtremeGamer Fatal1ty Pro

Pioneer DVR-111D DVD-RW PATA

Lite-On LH-20A1S DVD-RW SATA

NEC MultiSync 90GX 19" LCD

Win Vista Home Premium (64 bit)

I've got FSX (Deluxe and Acceleration) on its own drive and I've disabled UAC; I have a primary Administrator account in the OS, which is Vista 64-bit.

I'm flying the Discus with both Winch X and Cumulus X 1.5 installed and running...no crashes (yet) and lots of lift when weather conditions and time of day are right.

I offer this in the hope that it's useful information...I'm having a blast with this sailplane.

Share this post


Link to post

I hate to say this, but UNINSTALLING cumulusX didn't change a bit.

I also have CTD with starting from "Standardflug" and then changing the airplane/airport, so this didn't solve any, either.

I enter the plane, look around for clouds and zack, CTD with no warning but the "Microsoft Flugsimulator funktioniert nicht mehr" Textbox searching for solutions...lol, as if MS ever had any solutions at the ready :rolleyes:

So, i will be trying some things tomorrow, as you seem to be off duty now...it's late and everybody needs some "Feierabend"!

20:00 is by far late enough to quit working for the day.

Better luck tomorrow and don't let it get to you!

Mario.

Share this post


Link to post

Thanks Mario,

Even if it didn't help to solve the issue, it helps us to sort out things.

Can't make "Feierabend" until I go to bed. In fact some of my people start working at 8pm my time. ;-)

Share this post


Link to post

Ah i see.

A workaholic or simply the frustration not being able to fix things in a wink...

..ok, sir. i have some hot coffee, let's do some together.

I s there anything i can try to help you? Otherwise i would go off and watch TOP GUN :lol:

Share this post


Link to post

I hate to say this, but UNINSTALLING cumulusX didn't change a bit.

I also have CTD with starting from "Standardflug" and then changing the airplane/airport, so this didn't solve any, either.

I enter the plane, look around for clouds and zack, CTD with no warning .......

Mario.

Hi Mario,

I'm thinking of getting this problem fixed by trying a more structured way of testing where it goes wrong.

What you could do to help the boys is see if you can repeate the CTD when you do exactly the same as you described before. Same change in airplane/airport same action afterwards. In those situations, do the CTD take place at the same moment every time ?

When you can reproduce a same situation where the CTD's appear every time again, we (that is the profi's and us users) can start looking what causes the problem by changing one possible cause at the time and see if the CTD is dissapeared.

Bert

Share this post


Link to post

go off, watchin top gun ;-)

No idea to let you test something at the moment, trying things myselve

Thanks anyway

Share this post


Link to post

Hi Mario,

I'm thinking of getting this problem fixed by trying a more structured way of testing where it goes wrong.

What you could do to help the boys is see if you can repeate the CTD when you do exactly the same as you described before. Same change in airplane/airport same action afterwards. In those situations, do the CTD take place at the same moment every time ?

When you can reproduce a same situation where the CTD's appear every time again, we (that is the profi's and us users) can start looking what causes the problem by changing one possible cause at the time and see if the CTD is dissapeared.

Bert

I tried to get anotheer CTD but unfortunately, i didn't have one in five flights... :rolleyes:

Well, i did the Tutorial flight #7 with the default sailplane and the termics worked just fine.

Getting to Minden-Tahoma in a flight again and all termics were gone. i had to download the weather again and change termic view to schematic to turn them back on. After that i flew several minutes and tried again...no CTD.

Sorry, i can't halp you for now.

Mario.

Share this post


Link to post

I can also confirm it isn't cumulus X. My friend with a system that's almost exactly the same as mine doesn't have Cumulus X installed and he's still getting the CTD's. I've not had the time to try it myself, but it is definitely happening on systems without it installed.

Share this post


Link to post

Joachim

Thanks for that.

The CTD seems to have resolved itself due to me being more familair with the glider. I was trying to start the engine when it had been stowed and that seemed to be the issue.

Thanks again for the assistance.

Regards

PeterH

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...