Jump to content
B21

Soar Dg808s Version 3 Available For Free Download

Recommended Posts

The new version (V3) of the DG808S, replacing prior versions, is now available:

click here for download

The new version includes

* everything in SOAR DG V2

* a roll-up of the recent updates (Flap and Spoiler sounds, TrimWizard)

* bug fixes to the instruments

* a German readme and alternate aircraft.cfg

* a new mission - the actual 2008 USA 18m Nationals Day 1 Task (373km near Mifflin).

all in a single simple install package...

Credits: Bert de Bruin, Ian Forster-Lewis, Peter Luerkens, Microsoft for the original DG808S, Douglas S. Dawson for sound module.

Share this post


Link to post
Share on other sites
The new version (V3) of the DG808S, replacing prior versions, is now available:

click here for download

The new version includes

* everything in SOAR DG V2

* a roll-up of the recent updates (Flap and Spoiler sounds, TrimWizard)

* bug fixes to the instruments

* a German readme and alternate aircraft.cfg

* a new mission - the actual 2008 USA 18m Nationals Day 1 Task (373km near Mifflin).

all in a single simple install package...

Credits: Bert de Bruin, Ian Forster-Lewis, Peter Luerkens, Microsoft for the original DG808S, Douglas S. Dawson for sound module.

I am having problems with the "Soar DG808s". I have downloaded it several times and re-installed even more. Between five and eight minutes into a mission, where I have replaced the old DG808 with the "Soar DG808", My frame rates begin to fall and end up having to kill the program. (or in the Mifflin Mission with the Soar DG808 the same holds true.) My FPS are 30 to 50, when I fly the old DG808 or the ASH 25.

Any suggestions would be greatly appreciated.

SlaminSam

Share this post


Link to post
Share on other sites

hmmm tricky - I don't think anyone else has reported any issue like this. The SOAR DG808S V3 is actually made up of a number of components and you might try disabling various bits to see if your problem goes away, e.g. just replace panel.cfg with the one from the original so you have the V3 performance but not the instruments. Forgive me but I'm a bit dubious that it's the DG808S because there's not much in it that would be framerate-related. If you fly FSX in windowed mode you could have task manager running in another window, click the processes tab, sort by cpu utilisation, and see if there are any other processes using up the CPU. If you run the mission with 'allow changes', and switch aircraft (to anything, e.g. cessna) when the problem occurs, does the framerate go back up? Or what about if you run the same mission from the get-go with another aircraft (i.e. 'allow changes' and 'change aircraft' right at the start of the mission) does the problem still happen?

Ian

Share this post


Link to post
Share on other sites
hmmm tricky - I don't think anyone else has reported any issue like this. The SOAR DG808S V3 is actually made up of a number of components and you might try disabling various bits to see if your problem goes away, e.g. just replace panel.cfg with the one from the original so you have the V3 performance but not the instruments. Forgive me but I'm a bit dubious that it's the DG808S because there's not much in it that would be framerate-related. If you fly FSX in windowed mode you could have task manager running in another window, click the processes tab, sort by cpu utilisation, and see if there are any other processes using up the CPU. If you run the mission with 'allow changes', and switch aircraft (to anything, e.g. cessna) when the problem occurs, does the framerate go back up? Or what about if you run the same mission from the get-go with another aircraft (i.e. 'allow changes' and 'change aircraft' right at the start of the mission) does the problem still happen?

Ian

Ian

After flying the Indonesia Mission, I was very upset with ground textures. I started to search for scenery files for Indonesia but I found so many other sceneries I just started downloading them, some are huge. I also found a repaint of the DG808S by LightHorse. So whatever I did was related to those items. However that being said, my problem now resides with FSX & the "Soar DG808".

My 1st step was to run FSX in windowed mode with Task Manager running. I saw that FSX is using both processors and maxing out the CPU and besides CumulusX jumping to the top occasionally, I saw nothing out of the ordinary.

My second step was to change the aircraft back to the original DG808 and the frame rates when back up to about where I thought they should be and I finished the mission using the old DG808. In this case, it was Austria #4. Not convinced it was the Soar DG808 I flew the Day 1 mission with the Soar DG808. At about 7:30 into the mission my FPS had dropped to about 15FPS. I switched to the Old DG808 and the frame rates when back up to the 35-45FPS range. I flew the old DG808 to about 12 minutes or so after getting settled on the ridge going back to turn point #2, switched back to the Soar dg808 and about 30 seconds later the frame rates dropped to .5FPS switched to then the ASH 25 and FPS went back up again flew it past turn point #2. The task Manager showed nothing but FSX & CumulusX using any processing power.

My 3rd Step, I shut off CumulusX and no changes, meaning that the same results occured again. It is not CumulusX or Sim_probe.

My 4th Step was to download a new version of Soar DG808 and install. I tried this several times 1st was a copy over the old files, Second time was to delete old files then replace and the 3rd time was possibly a hidden file was present so I cleared the Folder and started new with a new folder.

The fact remains that I downloaded and installed something I shouldn't have without knowing the result. Right now my Mom is visiting from Washington State and it will have to wait until next week sometime to figure it out. I plan on removing the scenery files I downloaded and the repainted DG808. If those do not work then I plan on looking at the "Trim Wizard" and the sound files for more clues. Any suggestions are greatly appreciated.

Thank you for the Soar DG808. I love this plane and I will make it work again. However I will invest in FSGenisis for my scenery upgrade instead of those other Free Scenery files. It should save a lot of headaches down the road if I am running the same as you other guys. Wish me luck.

Thanks

SlaminSam

Share this post


Link to post
Share on other sites

I downloaded the Lighthorse repaint also and added it to the SOAR DG808S. But to make it work I had to do some adjustments to the flightsim.x section of the aircraft.cfg, other than suggested in the readme that comes with the Lighthorse-download.

I flew it for about 20 minutes in free flight and didn't notice any drop of framerates.

My flightsim.x secton for the Lighthorse now looks like this (the bolded lines are the ones I changed):

[fltsim.1]

title=DG808S_Lighthorse

sim=virtualsoaring

model=

panel=virtualsoaring

sound=

texture=FVL

kb_checklists=DG808S_check

kb_reference=DG808S_ref

atc_id=N609FVL

ui_manufacturer="DG FlugzeugbauFVL"

ui_type="DG-808S"

ui_variation=" LighthorseFVL"

ui_typerole="Glider"

ui_createdby="Lighthorse"

description="The DG-808S Competition is a lightweight, high-performance sailplane constructed with composite materials. It features a sophisticated water ballast system that allows the pilot to tailor wing loading to prevailing weather conditions. In weak thermals, the large surface area of the sailplane’s 59-foot (18-meter) wingspan makes for high lift and good climb performance without ballast. In heavier weather, the DG-808S Competition’s combination of low weight and high strength allows it to take off at more than twice its empty weight with enough ballast to soar in strong thermals. In all conditions, its upswept winglets increase the sailplane’s already excellent glide ratio."

Hope this helps.

Bert

Share this post


Link to post
Share on other sites
I downloaded the Lighthorse repaint also and added it to the SOAR DG808S. But to make it work I had to do some adjustments to the flightsim.x section of the aircraft.cfg, other than suggested in the readme that comes with the Lighthorse-download.

I flew it for about 20 minutes in free flight and didn't notice any drop of framerates.

My flightsim.x secton for the Lighthorse now looks like this (the bolded lines are the ones I changed):

[fltsim.1]

title=DG808S_Lighthorse

sim=virtualsoaring

model=

panel=virtualsoaring

sound=

texture=FVL

kb_checklists=DG808S_check

kb_reference=DG808S_ref

atc_id=N609FVL

ui_manufacturer="DG FlugzeugbauFVL"

ui_type="DG-808S"

ui_variation=" LighthorseFVL"

ui_typerole="Glider"

ui_createdby="Lighthorse"

description="The DG-808S Competition is a lightweight, high-performance sailplane constructed with composite materials. It features a sophisticated water ballast system that allows the pilot to tailor wing loading to prevailing weather conditions. In weak thermals, the large surface area of the sailplane's 59-foot (18-meter) wingspan makes for high lift and good climb performance without ballast. In heavier weather, the DG-808S Competition's combination of low weight and high strength allows it to take off at more than twice its empty weight with enough ballast to soar in strong thermals. In all conditions, its upswept winglets increase the sailplane's already excellent glide ratio."

Hope this helps.

Bert

Bert

Thank you very much. I will use the same format as you have listed above. Then this part will be assure of being correct. I used a different method. I renamed the original "T" files and copied in the Lighthorse "T" files with the old name.

Sam

Share this post


Link to post
Share on other sites

I notice that several pilots flying the new Hilltop Hop Day 1 mission using the SoarDG are experiencing framerate difficulties and there are several current posts related to this on the site "flightsimulatorxmissions.com."

The thing that confuses me on this issue is that I (and others) have been flying the Soar DG for some time now without any framerate problems at all and believe me I would notice it (4yr old single core machine and only a 6600gt gpu) Got me foxed!

http://www.flightsimulatorxmissions.com/mo...84&start=15

Jeff

Share this post


Link to post
Share on other sites
I notice that several pilots flying the new Hilltop Hop Day 1 mission using the SoarDG are experiencing framerate difficulties and there are several current posts related to this on the site "flightsimulatorxmissions.com."

The thing that confuses me on this issue is that I (and others) have been flying the Soar DG for some time now without any framerate problems at all and believe me I would notice it (4yr old single core machine and only a 6600gt gpu) Got me foxed!

http://www.flightsimulatorxmissions.com/mo...84&start=15

Jeff

Jeff

Thank you for the new mission!! I enjoyed it and found my problem with the "Soar DG808". What I found was that if I "commented out" three lines in the panel.cfg file it works again.

It now looks like this

[VCockpit01]

file=..\..\DG808S\panel\DG808s_Panel_Gauges_2.bmp

size_mm=256,256

pixel_size=256,256

texture=$DG808s_Panel_2

background_color=0,0,0

gauge00=..\..\DG808S\panel\DG808S!asi, 10, 13, 103, 104

gauge01=b21_vario_v2!variometer, 14, 152, 90, 90

gauge02=..\..\DG808S\panel\DG808S!altimeter, 127, 140, 115, 115

gauge03=..\..\DG808S\panel\DG808S!nav_display, 130, 5, 121, 122

//gauge04=dsd_fsx_xml_sound3!sound, 0,0,,, .\SimObjects\Airplanes\DG808S_SOAR\panel.virtualsoaring\DSD_DG808S.ini

//gauge05=.!DGSounds, 127, 140, 115, 115

//gauge06=.!TrimWizard, 0,0

I really think I don't need to "comment out" TrimWizard but I haven't tried it yet to know. I am guessing that the sound is interfereing with the radio or voice in the setup under sounds, Windows Sound Devices or user interface sounds. I just know that I am going to post a good score for the "HillTop Hop".

Thanks hodge for pointing me in the right direction.

Sam

Share this post


Link to post
Share on other sites

Glad you got things sorted out Sam, thank Spud for the Hilltop Hop mission, he's working on Day 2 at the moment. I am ready to give the new version of Day 1 a go. I notice posts from "Slammin Samuel" having flown the mission, I presume thats yourself?

Share this post


Link to post
Share on other sites

Hodge

Yes, My email address is SlaminSamuel@????.???. Maybe I could have recorded a better time if I wasn't watching my FPS all the time but shoulda, coulda, woulda No excuses just results. Your time was very time, I might add.

SlaminSam

Share this post


Link to post
Share on other sites

I was beta testing Hilltop Day 2 and then - yep I've now got framerate drop issues. What was your final verdict on this Sam, which specific lines do I delete, seems odd that Ive flown quite a bit and then load Day 2 and there it is??

Jeff

Share this post


Link to post
Share on other sites

Jeff

1st try to disable guage4 in the in the [Vcockpit01] section. I just stuck two "//" infront of the line. That should do it for now. I think the conflict is coming from multiplayer sound choices or defaults. until I can narrow in further that is all I can give you.

//gauge04=dsd_fsx_xml_sound3!sound, 0,0,,, .\SimObjects\Airplanes\DG808S_SOAR\panel.virtualsoaring\DSD_DG808S.ini

//gauge05=.!DGSounds, 127, 140, 115, 115

Thanks

Sam

Share this post


Link to post
Share on other sites

First post here! Just downloaded version 3 of the Soar DG808 and I have to say I am impressed. You guys did an amazing job. I can already tell that this is going to be my new favorite to fly.

I spent the last 20 mins on the ground just pushing buttons and seeing what they do!

Share this post


Link to post
Share on other sites

KSUPilot

Welcome, If you are a "Mouser" set the elevator trim to about 3.7%, Negitive or down. This allows you enough down elevator to exceed 120kts.

Happy to have you.

SlaminSamuel

Share this post


Link to post
Share on other sites

Oh MAN!!! SORRY KSUpilot, I read this post yesterday and didn't even give you a welcome. So, WELCOME! and, May your SOARing be always satisfied here!

Scott

Share this post


Link to post
Share on other sites

Thanks! I am pretty sure the Soar DG808 and the many other add ons will fulfill all of my soaring needs until I can get the cash to fly for real.

Share this post


Link to post
Share on other sites

I downloaded the Lighthorse repaint also and added it to the SOAR DG808S. But to make it work I had to do some adjustments to the flightsim.x section of the aircraft.cfg, other than suggested in the readme that comes with the Lighthorse-download.

I flew it for about 20 minutes in free flight and didn't notice any drop of framerates.

My flightsim.x secton for the Lighthorse now looks like this (the bolded lines are the ones I changed):

[fltsim.1]

title=DG808S_Lighthorse

sim=virtualsoaring

model=

panel=virtualsoaring

sound=

texture=FVL

kb_checklists=DG808S_check

kb_reference=DG808S_ref

atc_id=N609FVL

ui_manufacturer="DG FlugzeugbauFVL"

ui_type="DG-808S"

ui_variation=" LighthorseFVL"

ui_typerole="Glider"

ui_createdby="Lighthorse"

description="The DG-808S Competition is a lightweight, high-performance sailplane constructed with composite materials. It features a sophisticated water ballast system that allows the pilot to tailor wing loading to prevailing weather conditions. In weak thermals, the large surface area of the sailplane's 59-foot (18-meter) wingspan makes for high lift and good climb performance without ballast. In heavier weather, the DG-808S Competition's combination of low weight and high strength allows it to take off at more than twice its empty weight with enough ballast to soar in strong thermals. In all conditions, its upswept winglets increase the sailplane's already excellent glide ratio."

Hope this helps.

Bert

Hi

I have been out for some time with illness but will be

returning soon. I have noticed a few changes.

On the above, I have just downloaded v3, should I do a new repaint or will it be OK.

I took note of the changes you made. I will have to refresh my memory some,

I cant seem to find my original files. I am in the process of re installing FSX SDK.

Hopefully there here somewhere.

As health improves I will be creating new skins.

Also has anyone seen a Masking template for the new Discus X

It would sure save me time from making one from scratch.

Ken

Share this post


Link to post
Share on other sites

Hi Ken,

On the above, I have just downloaded v3, should I do a new repaint or will it be OK.

I would bother, because nobody ever complained about framerates related to the lighthorse since then.

Bert

Share this post


Link to post
Share on other sites

Hi Ken,

I would bother, because nobody ever complained about framerates related to the lighthorse since then.

Bert

OK Thanks

I know I had no problem but that was a while back.

Ken

Share this post


Link to post
Share on other sites

I have some questions re the SOAR DG808;

What speed should I be using for max glide and what speed is the best for thermals ? The FSX checklist speeds seem seem very low.

Also, what is the little red indicator in the winter Vario for ?

Share this post


Link to post
Share on other sites

What speed should I be using for max glide

No water: 50-55 knots

Full of water: maybe 70 knots

what speed is the best for thermals ?

Slow enough to reduce your sink rate, quick enough that you still have full effective control of the glider. Technically you want to be at 'min sink' speed, which is slower than 'best glide'.

No water: maybe 50 knots or a bit less if you can control it

Full of water: try and keep it below 60 - low 50's would be better but a real glider full of water flops around like a dying fish when circling at 50 knots.

what is the little red indicator in the winter Vario for ?

LOLZ that is something I put in there during the long development in the early days of producing 'compensated' variometers in FSX.

The main vario needle in the SOAR DG808S is displaying 'total energy' compensated climb/sink rates which all real gliders use, calculated in the XMLvario gauge code. The 'little red indicator' is actually displaying the standard FSX 'VARIOMETER RATE' value, which was originally going to be Microsoft's computed total-energy vario reading but they gave up on it when FSX was first shipped, and in the meantime 'VARIOMETER RATE' actually displays your pure rate of climb - this is fairly useless when thermalling because of the influence of 'stick thermals' on the vario reading, but is actually sensible for climb rate on tow. In the following years Microsoft failed to improve the 'VARIOMETER RATE' calculation, but Peter Luerkens introduced a total-energy mod as standard in CumulusX, which manipulates the value of 'VARIOMETER RATE' so it is total-energy compensated, magically giving automatic TE compensation to the many gliders (including the stock DG808S) that simply move their vario needles with 'VARIOMETER RATE'. So if you know what you're looking at, you can see this behaviour in the 'little red indicator'. But feel free to ignore it...

B21

Share this post


Link to post
Share on other sites

I've encountered, on two occasions now, with this aircraft, some erratic elevator trim behaviour. Maybe it's too little data to point a finger, but here goes:

This happened first time I tried the aircraft, immediately on takeoff, and the second time it happened 15 minutes into another flight, the forward stick pressure required to maintain speed suddenly goes way up, and I'm holding the stick almost full forward. My elevator trim, which is on a rotary, shows wild twitching of the cockpit trim lever when I rotate the knob, but always ends up stuck at the full rearward position when I stop rotating it. In Windows Control Panel, the rotary shows no sign of erratic movement, but is smooth as silk.

Anyone else encounter this issue?

Could it be caused by the "Trim Wizard"?

Share this post


Link to post
Share on other sites

The DG808S hasn't got any code in it that manipulates the trim value, so the issue is very unlikely to be related to the aircraft. The trim changing with the operation of the control is handled by standard FSX.

Anyone else encounter this issue?

not me

Could it be caused by the "Trim Wizard"?

sounds possible. If you have a repeatable issue, turn off trimwizard and see if it fixes it...

B21

Share this post


Link to post
Share on other sites

The DG808S hasn't got any code in it that manipulates the trim value, so the issue is very unlikely to be related to the aircraft. The trim changing with the operation of the control is handled by standard FSX.

...turn off trimwizard and see if it fixes it...

I was thinking I may have inadvertently hit the apply brakes key, thereby activating the TrimWizard.

What I did after, was delete all the controller assignments for brakes. Probably the more scientific approach would be to try deliberately activating the Trim Wizard, and see if I can recreate the issue.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...