Jump to content

Gau, Es Steht Nicht Genügend Arbeitsspeicher Zur Verfügung


Fraboh
 Share

Recommended Posts

Hi,

habe schon öfters während des Fluges die FSX-Fehlermeldung erhalten:

Es steht nicht genügend Arbeitsspeicher zu Verfügung, um die Anwendung fortzusetzen.

Kannst nur auf OK drücken und der FSX schmeiert ab. Heute 2 mal, bei 2 Flügen.

Passiert manchmal ca. 10 Minuten nach Abheben, manchmal auch erst nach einer Stunde, natürlich kurz vorm Landen.

Will es nicht der Piper Cheyenne anlasten, ist mir auch mit anderen Fliegern passiert.

Will auch Aerosoft dafür nicht verantwortlich machen!

Passiert aber regelmäßig mit Add-On Fliegern; bei den Mickeysoft-Default-Fliegern nioch nicht gehabt.

Ist so ziemlich der GAU, den man haben kann *find* Werde in Zukunft, den task-manager mitlaufen lassen.

Ich habe 4 GB RAM, daß da der Speicher ausgeht, halte ich, gelinde gesagt, für quatsch.

Grüßle Frank

Link to comment
Share on other sites

Hallo Frank,

deine Probleme, auch die in anderen Threads, schließen auf ein OOM Speicherleck. Hat mit der Verwaltung des virtuellen Speichers von Windows und der Öffnung der >2 GB Grenze seit FSX SP2 zu tun.

Kurzum: Dein FSX bläht sich durch Addons dermaßen auf, dass die 2 GB, die Windows für ihn standardmäßig zur Verfügung stellt, irgendwann überschritten wird.

Abhilfe schafft nur der Eintrag "UserVa" in der boot.ini(XP) oder bcedit(Vista).

Such mal im Netz nach FSX OOM- da wirst Du zahlreiche Lösungsverschläge erhalten.

Gruß

Udo

Link to comment
Share on other sites

Hätte ich eigentlich fast selbst drauf kommen können.

Aber gut, daß wi drüber gesprochen haben :)

Gibt dazu einen Mircosoft Hotfix KB940105.

Wenn ich den allerdings installieren möchte, wird

mir gesagt, daß dieser Fix für mein System nicht zulässig ist.

Habe dann über die Konsole (cmd.exe, als Administrator ausführen) folgende Zeile eingegeben:

BCDEDIT /set increaseuserva 3072

Mal schauen, ob es klappt.

Danke Udo!

Grüßle, Frank

Link to comment
Share on other sites

Hallo Fraboh,

auch ich habe mich mit diesem ärgerlichen Problem befassen müssen. der Hotfix KB940105 hat damit nichts zu tun, das war ein Bug welcher die Grafikkarte (bzw dessen Speicher) betroffen hat. Wenn Du schon Vista hast, und das SP1 installiert, dann ist dieser Hotfix schon installiert.

Es gibt im Netz diese ganzen vielen Ansatzwege zur Lösung, bei mir hat keiner davon geholfen. Udo hat es schon richtig erklärt was da passiert, aber diese Massnahmen die ich probiert habe helfen nicht. Weder unter XP noch unter Vista. Das einzigste was wirklich wirkt ist ein Vista 64! Dann sind die Probleme adé.

Auch die 64bit Version von Windows XP hat sich nicht als tauglich erwiesen.

Link to comment
Share on other sites

So wie ich das Verstanden habe gibt man dem Betreibsystem (wobei der Rechner 4 Gigabyte eingebaut hat) die Möglichkeit, bis zu 3 Gigabyte zu verwalten.

1024 MB * 3 = 3072 MB

Das erste Gigabyte verbraucht das Betriebsystem an sich schon für Treiber, das GUI usw.

Aber diese Lösung hat bei mir nicht funktioniert. Etwa 800 MB sind belegt, wenn ich mein Betriebsystem starte. Wenn der FSX z.B dann ca. 1200 MB im Speicher hatte, konnte ich mit dem crash rechnen. Alles was über 2 Gigabyte hinausgeht ist dann kritisch.

Es soll wohl Mainbards geben, wo man noch eine Einstellung vornehmen kann um auch für ein 32 Bit Betriebsystem mehr als 2 Gigabyte verwalten zu können. Meines hat so eine Funktion leider nicht.

Aber die Vista 64, die hat die Lösung gebracht ;)

Link to comment
Share on other sites

Hi,

erst mal, hat nicht geholfen.

64-Bit geht nicht, weil mein Prozesser x86 ist. (Obwohl I-Net sagt, kann auch 64-Bit, muß mich da erkundigen, scheint die vernünftigste Alternative zu sein)

@f-bird:

1. Windows 'Start#-Button klicken

2. in der Textbox'Suche starten' 'cmd' eintippen

3. Rechtsklick auf 'cmd.exe'

4. 'Als Adminstrator ausführen' aufwählen

5. Sicherheitsabfrage bestätigen durch 'Fortsetzen'

6. Im Konsolenfenster 'BCDEDIT /set increaseuserva 3072' eintippen (ohne die Apostrophs)

Hat bei mir aber nicht geholfen, muß da noch ein wenig weitersuchen.

Grüßle, Frank

Link to comment
Share on other sites

Einen guten Workaround für das out of memory Problem gibt es im Flightxpress Forum (Suche Funktion). Die 32 bit Systeme (windows) können normalerweise jedem Prozess nur 2 Gigabyte zuweisen, mit dem set VA ... (Virtueller Adressraum)Befehl kann man einem Prozess dann 3 Gigabyte zuweisen, vorausgesetzt der Prozess (FSX mit SP ) unterstüzt die Adresserweiterung (FSX mit SP ja !!!). Es kann dann aber Probleme geben, denn der Kernel Adressraum (Grafikkartentreiber ...) wird auf 1 Gigabyte beschränkt(Rechner startet nicht als worst case) . In diesen Fällen kann man auch User VA 2900 setzen oder kleiner.

Die bessere Lösung die Ich gewählt habe, ist eine parallele Installation von Vista 32 Bit/64 Bit. Vista 64 Bit und FS X + Addons habe Ich auf einer Zweiten Festplatte installiert (FS X Aktivierung eventuell (Sprachcomputer) erforderlich), abgesehen vom Betriebssysten und dem Virenscanner sind sonst keine weiteren Programme installiert (alle Arbeitsprogramme in der 32 Bit version), werden also auch nicht gestartet.

Beim Booten des PCs kann ich dann die Vista Version auswählen (Vista eigener Bootmannager,das ganze geht auch mit XP (XP aber zuerst installieren).

Vista 64 Bit kann 4 Gigabyte jedem Prozess zuweisen, und das OOM Problem ist bei meinem Rechner behoben, funktioniert wunderbar.

Vorraussetzungen für erfolgreichen Umstieg (Um 4 oder mehr Gigabyte komplett nutzen zu können):

Mainboard: Funktionierende Memory Remapping Option (Nennen Mainboardhersteller auch anders) (Handbuch, Mainboardforum..), falls im Bios keine Option sichtbar ist, kann es auch sein das Memory Remapping immer eingeschaltet ist (z.B. P 35..Gigabyte Serie).

Prozessor: 64 bit support, alle halbwegs aktuellen Prozessoren von AMD und Intel haben diese (siehe intel.de oder amd.de).

Fraboh: Ich glaube nicht dass dein Prozessor keinen 64 Bit support bietet, denn deine installierten Add Ons würden sonst gar nicht spielbar laufen. Eventuell verwechselst du dass mit der Eignung für Virtuelle Maschinen.

Und natürlich ein 64 Bit Betriebssystem =Vista 64 Bit (XP 64 nicht empfehlenswert) und 4 oder mehr Gigabyte Arbeitsspeicher (am besten baugleiche 2 Gigabyte Module)

Noch ein Tip für Fraboh und die Leidensgenossen: Die erste Abhilfe lautet Einstellungen runterdrehen (Weniger Objekte = weniger Speicherbedarf), den OOM Bug hatte Ich erst als Ich bei meinem neuen Rechner,als Ich die Einstellungsregler (Grafik,Szenerie) nach rechts gezogen habe. Bei meinem Notebook (mittlere Einstellungen Auflösung auf 1024x764 eingestellt ) hatte Ich dieses Problem nie (dieselben Addons).

Vile Grüße an alle und noch einen schönen Sonntag

Thomas

Link to comment
Share on other sites

Hallo Thomas,

kann mir auch nicht vorstellen, daß meine CPU keine 64-Bit kann.

Zumindest sagt die Intel-Page, er kann.

Denke das gesündeste ist, den 64-Bit Update zu machen, soll ja nicht die Welt kosten.

Bin dann nur gespannt, welche anderen Programme dann nicht mehr laufen.

Freue mich schon auf die Neu-Installation von allem, hehe.

Kurze Frage dazu:

Laufen 32-Bit Anwendungen auch auf 64-Bit Betriebsystemen oder kann ich da dann neue Probleme erwarten?

Grüßle, Fraboh

Link to comment
Share on other sites

Ich hatte das Problem auch auf meinem System (4 Gb Speicher). Habe nach langem forschen das hier gefunden und seitdem läuft es bei mir einwandfrei !

[bufferPools]

PoolSize=3500000

So in die FSX cfg eingeben und mal probieren, wenns nicht geht einfach wieder löschen.

Viel Glück :D

Link to comment
Share on other sites

ich kauf mir ja morgen 64-Bit ein.

Hab da auch keinen bock mehr drauf!

Auf keine halbscharigen abhilfen, die eh nicht funktionieren.

Freue mich nur nicht auf die Neu-Installation von allem.

Aber mehr mein Problem.

Grüßle Frank *ein bier zu viel*

Link to comment
Share on other sites

Leider ist 64 bit auch nicht das Allheilmittel. Der FSX ist ein 32 bit Programm, dass sich dann in einer 64 bit Umgebung befindet. Damit hast du die 32 bit Begrenzung immer noch nicht beseitigt. Dazu müsste der FSX ebenfalls ein 64 bit Programm sein.

Richtig ist, dass ein 64 bit Betriebssystem nicht an der 4 GB Hürde scheitert; richtig ist aber auch, dass einige Mainbords und deren Chipsätze daran scheitern.

Das erklärt auch das Phänomen, dass bei manchen der FSX unter Vista64 nicht abstürzt, bei anderen aber schon.

Das sind einfach Hürden, die Windows hier aufstellt und die ganze X86 Umgebung. Als Windows NT entstand, waren Speichergrößen jenseits der 2 GB absolute Utopie, damals war es nicht absehbar, dass Speicher so schnell wächst und so günstig wird. Win2000 und XP sind ja direkte Ableger von NT, schlagen sich also auch noch mit der Begrenzung in User und Kernel rum. Ebenso die aktuellen x86 Prozessoren, die ja native 32 bit Prozessoren mit einer angedockten 64 bit Erweiterung sind, also keine reinen 64 bit Prozessoren wie z.B. Itanium, PowerPC oder Cell.

Zum Problem mit der Umgehung der 2 GB Grenze:

Die Variable "UserVa" umgeht die zwar, macht das Betriebssystem dann aber auch instabiler, so dass im Schlimmsten Fall die abgestürzte Software das ganze BS in den Keller zieht.

Noch dazu kommt, dass das VRAM der Graka in den virtuellen Speicher gemappt wird, der je nach VRAM Größe dann nicht mehr genug virtuellen Speicher zur Verfügung hat.

Phil Taylor(ACES) empfiehlt deshalb die Variable nicht auf 3072 sondern eher auf 2560 zu setzen. So habe ich es bei mir auch und keine OOM´s mehr.

So kommt es eben auch, dass Anwender Probleme haben, andere wiederum nicht. Das sind eben die Nachteile einer offenen PC Architektur, die es für Soft und Hardwareentwickler so schwer macht und immer mehr Spieleentwickler zu den Konsolen treibt.

Gruß

Udo

Link to comment
Share on other sites

Die 4GB-Beschränkung liegt eher am Betriebssystem, als an den Prozessoren - die können schon seit dem Pentium Pro mehr als 4GB Speicher adressieren.

Das 32bit-Betriebssystem kann halt nicht mehr als 4GB verwalten. Davon gehen bekanntlich noch einige Adressbereiche für Komponenten etc. ab und von daher ist es eben auch sinnvoll, einem Prozess nur einen Teil der zur Verfügung stehenden rund 3GB Arbeitsspeicher zur verfügung zu stellen.

Nun, wie dem auch sei.

Den Eintrag hängt man unter XP hinter den Booteintrag des Betriebssystems. Zu finden in der Systemsteuerung unter System dann zum dritten Reiter klicken und dort im ersten drittel des Fensters die Bootoptionen aufrufen und den Eintrag einfach hinten dran hängen.

Meist steht dort schon was, also kannst Du Dich daran orientieren.

Link to comment
Share on other sites

Für F-Bird und sein Vista 32 Bit

Achtung !!!!: Negative mögliche Auswirkungen wie oben beschrieben (Hardwareabhängig). Im schlimmsten Fall startet der Rechner nicht mehr :angry: ,, es gibt dann eine Lösung, am Besten du googlelst den Befehl "bcedit /set IncreaseUserVA 3072", bevor du das nachfolgende ausführst. Für den Anfang würde Ich zb. ...2560 statt 3072 eingeben, das Risiko von Nebenwirkungen ist dann deutlich niedriger (Dann FSX auf OOMs testen) . Ein Systemwiederherstellungspunkt sollte am Besten auch gesetzt werden.

Aus diesen Gründen (Ich brauch den Rechner auch fürs Studium und nicht nur für FS) habe ich gleich die Vista 64 Bit und 32 Bit Variante gewählt.

Start-> Alle Programme-> Zubehör-> auf "Eingabeaufforderung" rechtsklicken-> "Als Administrator ausführen" anklicken-> "Zulassen" anklicken.

In das schwarze Fenster, das sich jetzt öffnet, folgendes eingeben:

bcdedit /set IncreaseUserVA 3072 (oder besser erstmal .... VA 2560,... 2900)

Mit "Enter" bestätigen.

Anschließend Rechner neustarten (sonst werden die Änderungen nicht übernommen) und fertig

Rückgängig machen (geht naturlich nur so einfach falls Windows auch startet): Wie Oben aber stattdessen bcdedit /set IncreaseUserVA 2048 in die Eingabeaufforderung eintippen und den Rechner neustarten.

Viele Grüsse Thomas

Link to comment
Share on other sites

... aber es gibt einen Haken....

Bei mir hat dieser Befehl ursprünglich sehr geholfen, keine Probleme mehr. Nach Installation diverser Addons, z.B. VFR West und Nord, MAF, habe ich meine Grafikeinstellungen ultra hoch geschraubt, Dichte extrem, Radius sehr hoch usw.... Mein System gab das bzgl. der fps her (Quadcore, Geforce 9800 GX2, 4 GB). Aber dann traten wieder die Fehler auf mit Speicher voll. Habe die Grafikeinstellungen etwas runtergeschraubt, jetzt scheint alles wieder zu funktionieren!

Link to comment
Share on other sites

  • 8 months later...

hallo zusammen,

mir hat in den obigen ausführungen ein bisschen der bezug zu den "guten, stabil laufenden XP-systemen (32-Bit)" gefehlt.

da ich seit neuestem ebenfalls OOMs habe, ausschließlich in new york mit fsdt´s kjfk und manhattan x sowie 80% woai-traffic, suchte ich nach einer lösung.

für die xp-nutzer unter uns, gilt das gleiche, wie oben beschrieben.

nur, dass wir laut c´t keinen command in die eingabeaufforderung schreiben,

sondern die boot.ini verändern müssen. dazu rechte maustaste auf arbeitsplatz -- erweitert -- starten und wiederherstellen -- bearbeiten.

in dem folgenden editor hinter die zeile: "multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect"

(kann auch abweichend aussehen) ein " /3GB" setzen.

das wars. speichern und neustarten.

gruß,

sören

EDIT: vergesst dieses tipp. bei mir lief anschließend gar nichts mehr in new york. nur noch flimmern und wilde scenery fragmente.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...