Sign in to follow this  
jeff64

Problem Aes

Recommended Posts

I've just installed AES 1.9.5a on my pc running under Vista and FS9.

It's the first installation on this computer.

When I launch AES Help, I got the following message

"AES has detected a SCENERY.CFG in the virtual store ! This can generate problems with sceneries"

When I launch FS9, AES is not installed in the scenery library.

AES is installed with administrator right, and aes help is running with administrator rights.

I've read in the 1.9.5a new features that problem should be solved, but I've got this message.

Any idea ?

Thank you

Share this post


Link to post
Share on other sites

Hi,

the big problem is, that you have 1.) Vista (ok, not so big problem, but the reason) and 2.) that you FS is installed below c:\Program files (mega big problem):

All Programs you install below c:\Program Files are protected by Vistas and all changes this Programs will write to disk in this directories will be stored in the "Vitual Store", but not at the correct location under c:\Program Files.

When you run a installer (like AES) he is running in Admin Mode (not only logged in as Admin) and will write all in C:\Program files ..., also the SCENERY.CFG. But you FS is not reading this file, it's reading the SCENERY.CFG in the Virtual Store, which was generated, when you add/change the last scenery entry manually, but there no AES is included.

To solve the problem: Open the FS Main Directory in the Explorer, then you find a "Compatibility Files" in the headline. When you click there, you see the files saved in the Virtual Store. One of this file should be the SCENERY.CFG, mark this to move (not copy), you back to the privous directory (should be the FS Main Dir on C:...) and past this file (overwrite the SCENERY.CFG there). Then Start AESHELP and you should get the message, that AES is not in the Library, press YES to solve this.

Then Start FS and AES should be active.

To solve this problem (and any others regaring the Vista Protection), don't install the FS into c:\program files, make a C:\FS9 or better if possible a D:\FS9 Directory and install the FS there, then you don't get problems in future.

Share this post


Link to post
Share on other sites

I will try this.

I guess it is for this reason why when I made some changes in the aircraft.cfg of an aircraft in C:\FS9\Aircraft\ the change isn't percepted by FS.

He looks into the aircraft.cfg in the virtual store;)

Share this post


Link to post
Share on other sites

Correct. One option is, to copy all files from the virtual store back to C:.. and then set the Icon of the FS to run allways in Admin Mode. When the FS is running in Admin Mode, all files are also read/written direct to C:\...

Share this post


Link to post
Share on other sites

Thanks for all of your help because I had the same problem but now it is solved when I moved my FS folder like this c:\Flight Simulator 9! Thanks once again! :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this