Jump to content

Speed brake arm doesn't move when quadrant axis is moved


pierre fsx
 Share

Recommended Posts

Hi,

I am using the PFC quadrant serial com connection(see picture) with the Airbus 318-321 (PRO) so I have no choice of using FSUIPC6 to calibrate my device in P3D 5.2. My Cirrus II device is not visible to window and P3D. I use a DLL from Pete Dowson .

1440838958_2jetquadrant2021-08-30171302.thumb.png.132f1cd1de07105e9fb29807a0b140f8.png

I was able to create a profile in FSUIPC that works. When I move my arm on my throttle I can arm and disarm the ground spoiler, that is the small zone I defined at the top. Then if I move my arm further down after the arm label and look at the plane from outside, I can see the speed brake deploying, so the axis is working fine.  Also I can see on the ECAM F/CTL page when I move my quadrant spoiler arm in the second zone that the speed brake are deployed. (see picture)

313190069_AirbusMCDU2021-09-01125917.thumb.png.3b377c95f0e8355ec820ab2412b205d0.png

 

But if I look at the speed brake arm from inside the cockpit, I can see that it pop up when I arm the ground spoiler and it pop down when I leave the arming  zone. But the speed brake arm doesn't move up and down when I deploy the speed brake. No animation movement what so ever.

 

I have tried the same profile setup in the A330 and the arm does move up and down when I move my quadrant arm to deploy the speed brake.

 

So I wonder why is it working in the A330 and not in the a318-321 family? All the other axis are working fine.

 

Anyone that have an explanations is more then welcome.

 

Pierre Nantel

Link to comment
Share on other sites

I have similar problem. Speedbrakes extend/retract mapped into joystick button. Speedbrakes working, but virtual cocpit lever don't move. If I moved it with mouse, it's working. Working before normally, don't know if it's P3D5 or A318/321 behind this problem?

P3D5 latest version

A318/321 latest version

 

 

 

 

Speedbrakes.jpg

Speedbrakes II.jpg

Link to comment
Share on other sites

  • Aerosoft
25 minutes ago, MikaV said:

I have similar problem. Speedbrakes extend/retract mapped into joystick button. Speedbrakes working, but virtual cocpit lever don't move. If I moved it with mouse, it's working. Working before normally, don't know if it's P3D5 or A318/321 behind this problem?

P3D5 latest version

A318/321 latest version

 

 

 

 

Speedbrakes.jpg

Speedbrakes II.jpg


Hi MikaV,
 

There is also a keyboard binfding for the spoilers in the screenshot you sent.
Does the lever work when controlled with the keyboard or is the behavior identical to the joystick ?

 

Thank you.

 

Link to comment
Share on other sites

Hi SimWare,

 

I find it funny that it works perfectly using the A330. For me, it means that my assignment in P3D 5.2 and my profile in FSUIPC6 are correct. Is the coding for the speed break arm the same for the A318-21 and the A330. 

 

Pierre Nantel

Link to comment
Share on other sites

4 hours ago, SimWare said:


Hi MikaV,
 

There is also a keyboard binfding for the spoilers in the screenshot you sent.
Does the lever work when controlled with the keyboard or is the behavior identical to the joystick ?

 

Thank you.

 

 

Yes it's working before. When I map some control example joystick button, it appears next to the keyboard bind. The lever into cocpit don't move from keyboard or button (tested removing keyboard binding). 

Link to comment
Share on other sites

2 hours ago, SimWare said:

Hi MikaV,

 

So, the lever never moves unless actuated by the mouse.

But the spoiler surfaces on the wings deploy with the mouse, keyboard and joystick. Right ?

 

Thank you.

 

Right! and there is no text "speed brakes" in upper ecam like before.

Link to comment
Share on other sites

  • 1 month later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...