Jump to content

Generated files in "packages\aerosoft-crj"


ACSoft
 Share

Recommended Posts

On the occasion of the last MSFS performance update, I have removed the directory "packages\aerosoft-crj", in the meaning to have a clean restart with CRJ's aircrafts. So, I expected a long first start, as mentioned in tips display, during loading, but I was surprised that the loading was not very long and when I checked in directory "packages", I found a newly generated "aerosoft-crj", but WITHOUT any generated ".dll", ".lib", ".pdb" files inside. Only the sub-directory "work" was generated. with all usual files inside.

 

Does it mean perhaps, that these generated files are not more required/generated with the last 1.0.5 CRJ aircrafts and/or with the last MSFS update, or this mean there is a problem ?

 

For your information, I can load perfectly both CRJ aircrafts versions, but I hadn't the time yet, to try to fly with them (just an cold & dark loading at gate).

 

Thanks in forward for your help.

Link to comment
Share on other sites

  • Aerosoft

Hello ACSoft,

Are you by any chance using the Steam version of MSFS? If so the Packages folder location was moved under [removed wrong path]. If you deleted the aerosoft-crj from the old location, this would have no effect at all, like you have described.

E: Strikethrough misinformation due to a mixup between different versions.

Link to comment
Share on other sites

Yes, I am using the Steam and no, I am not looking in a wrong place.

 

My full path is: "...\AppData\Roaming\Microsoft Flight Simulator\Packages". I don't have any "KITTYHAWK" directory in my "Roaming" location !!!

 

If you read more carefully my initial message, I say there that after having suppressed "aerosoft-crj" in the correct location and launched a flight with a CRJ aircraft,  "I found a newly generated "aerosoft-crj", but WITHOUT any generated ".dll", ".lib", ".pdb" files inside", which obviously prove that I am looking in the correct location.

 

I would really like to known if what I have described precisely: the generation of a new "aerosoft-crj" directory, with no generated files inside and only the sub-directory "work" is normal or not.

 

Thanks in forward to let me know and tell me what shall I do in case it is abnormal. For your information, I made, of course, a backup of the initial "aerosoft-crj". So I would be able to revert my CRJ installation to the state before MSFS update 5.

 

 

PS: Is maybe this strange behavior linked with the actual MSFS update 5 problem CRJ aircrafts encounter ?

Link to comment
Share on other sites

  • Aerosoft

I apologise. I accidentally mixed the folders between different versions.
 

1 hour ago, ACSoft said:

I would really like to known if what I have described precisely: the generation of a new "aerosoft-crj" directory, with no generated files inside and only the sub-directory "work" is normal or not.


This depends where the CRJ has been purchased. If the CRJ is purchased from the marketplace the m files are no longer generated. So in this case this would be normal. If the CRJ has been purchased elsewhere like Aerosoft store, this would not be normal.

Link to comment
Share on other sites

I purchased the CRJ from the marketplace in March.

 

So you say it is normal. OK, but why it wasn't the case (no files generated) since the beginning ? Does it mean you changed the code in last update 1.0.5 ? Why this depend on the provenance of the purchase ? This totally amazing to my eyes ?!?

 

I found via the official MSFS forum a thread about a problem with actual last MSFS update 5.

https://forums.flightsimulator.com/t/make-aerosoft-crj-flyable-again/431991

Which include a pdf file link for a solution:

https://forum.aerosoft.com/applications/core/interface/file/attachment.php?id=164654&key=b2a0d92ae3102692429528ba24bda791

 

And coincidentally, this workaround say we must delete all these generated files and then activate the "Fast WASM Compilation" mode and run a flight with a CRJ. I tried this by curiosity, but still no files generated. In this case, what is doing this workaround ?

 

Sorry to say but all this is really a big mess and I would love to read some clarifications.

 

Thanks in forward.

 

PS:

 By the way, I just found this workaround also mentioned here:

 

Link to comment
Share on other sites

  • Aerosoft
12 minutes ago, ACSoft said:

So you say it is normal. OK, but why it wasn't the case (no files generated) since the beginning ? Does it mean you changed the code in last update 1.0.5 ? Why this depend on the provenance of the purchase ? This totally amazing to my eyes ?!?


You are correct. Initially the m files got generated but later MSFS updated it so that they would not generate anymore on the marketplace version. This is beyond our control and has nothing to do with our code.

Unfortunately, I think you have to wait for the 1.0.6 update to be released. You can read the official statement about the sitautaion from Mathijs here:
 

 

Link to comment
Share on other sites

Ok, Secondator, thank-you very much for all your explanations.

 

I think that now, all is clear in my mind and I will wait for the solution to come.

 

Regards.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...