Jump to content

Transponder number 2 doesn't work


Nicco54
 Share

Recommended Posts

3 hours ago, Nicco54 said:

I just noticed that ATC will not get a radar contact if you use transponder number 2.
I had to switch to number 1 for it to work.

Which ATC?  I found that when you change the Active TXPDR unit

image.png.c941965883c8acccabc0cd2931a6925f.png

that it actually copies the Code from the 2nd RTU and puts it into the Simconnect Var for TXPDR 1 ... When you switch back to TXPDR 1 on ATC SEL it changes it back again to What is in the RTU 1 for a code....

Link to comment
Share on other sites

1 minute ago, LesOReilly said:

Which ATC?  I found that when you change the Active TXPDR unit

image.png.c941965883c8acccabc0cd2931a6925f.png

that it actually copies the Code from the 2nd RTU and puts it into the Simconnect Var for TXPDR 1 ... When you switch back to TXPDR 1 on ATC SEL it changes it back again to What is in the RTU 1 for a code....

 

I had the correct transponder code set in both number 1 and number 2 but seeing as I fly on the F/O side I had the transponder switch set to ATC 2, yet air traffic control asked me to check my transponder. I switch to number 1 and it worked.

Link to comment
Share on other sites

Just now, Nicco54 said:

 

I had the correct transponder code set in both number 1 and number 2 but seeing as I fly on the F/O side I had the transponder switch set to ATC 2, yet air traffic control asked me to check my transponder. I switch to number 1 and it worked.

Which ATC?  VATSIM via vPilot?  Was it the code or the Mode C they were having the issue with?...  I Have had to build scripts that track the LVARs of the CRJ to update the Sim Vars that Vatsim/vPilot uses...  However the one that seemed to work automatically for me was how it was not actually using the MSFS Transponder Code : 2 but rather would copy that value into MSFS Transponder Code : 1 .....

Link to comment
Share on other sites

11 minutes ago, LesOReilly said:

Which ATC?  VATSIM via vPilot?  Was it the code or the Mode C they were having the issue with?...  I Have had to build scripts that track the LVARs of the CRJ to update the Sim Vars that Vatsim/vPilot uses...  However the one that seemed to work automatically for me was how it was not actually using the MSFS Transponder Code : 2 but rather would copy that value into MSFS Transponder Code : 1 .....


Neither, default MSFS ATC

Link to comment
Share on other sites

On 6/3/2021 at 11:32 AM, Nicco54 said:


Neither, default MSFS ATC

So I ran the Data Monitor with all of the sim Variables with regards to Transponder to see what it is doing... (v1.0.5 MSFS Store Edition - I fell like we need to have this as part of our Bio now due the different bugs vs Store editions hahah)

 

When you enable TXPDR 2 via the ATC SEL Menu it puts MSFS:Transponder State:1 into Standby (value = 1) it never changes MSFS:Transponder State:2 (Value =1 so in Standby)...  In Addition to that the CRJ does put the TXPDR 2 CODE into the Sim Var for TXPDR 1's Code....  But as you can tell both are now still in standby...

 

So it is like 2 things here :) ... One is that they are not using the Sim Vars for TXPDR 2 at all..... Then when they are "turning on 2" and coping the Code into Channel 1 Variable but they are not setting the Transponder State of 1 to be in Reporting....

 

 

 

 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...