Jump to content

CRJ700 randomly not ready at start-up


pilota57
 Share

Recommended Posts

Hi, I have been using the CRJ700 with satisfaction from day one.


In latest days I have been experiencing this anomaly:
Loading the CRJ in cold & dark as usual, the aircraft appears as shown in the image: panel lights on but no interaction is possible. Clicking on the tablet does not turn on it and no effect by clicking the switches (eg battery). It is possible to move in the cabin also it is not freezed.

I go out to the main menu, reselect the airport and the departure position, the livery and on return sometimes the CRJ is ok with the possibility of turning on the tablet and all systems working.

This solution is random in giving me the working plane.

In the Community folder I only have the CRJ files and no other livery.

Any suggestions ? Thanks
 

crj fault.jpg

Link to comment
Share on other sites

I had exactly the same issue - all panel lights on but nothing works and cannot turn on efb! I was at OPMR and despite closing and reloading msfs several times, still the same problem at OPMR. I then changed to another airport and all was fine again.  Could this be an issue at certain airports? Would be good to hear from Aerosoft as this does seem to be a bug.  For the record I had nothing in my community folder apart from the crj.

Link to comment
Share on other sites

  • Root Admin
4 hours ago, pilota57 said:

In latest days I have been experiencing this anomaly:

 

But we have not changed any code for the last weeks. If this is something happening the last few days it simply has to be caused by something else.

Link to comment
Share on other sites

14 hours ago, Mathijs Kok said:

 

But we have not changed any code for the last weeks. If this is something happening the last few days it simply has to be caused by something else.


This is sure but what could have happened?

Normally I make "flights" to and from Italian or Austrian and Swiss airports and the problem seems independent of the airport.
 

For example now: MSFS started, LIPZ (Venice) selected from a cold & dark parking lot as set.

CRJ700 aircraft already selected at start-up appears as in the image: cabin lights on and no possibility of interaction.
 

Ok, I go back to the main menu (no MSFS restart), reselect the starting point, click on the CRJ700 at the top left, I choose it again from the aircraft list and confirm the livery.

Return and the cabin is ok: cold & dark, battery on and click on the tablet; fully operational.
 

I don't know if it helps but I noticed this behavior after the WU4 update (1.15.10.0).
 

For information: I only use CRJ standard liveries, especially Lufthansa (Alitalia is about 20 years near to bankrupt, and I pay !!!) or other standard liveries and no scenery mods in use.
 

For the rest, the CRJ700 behaves perfectly, not considering the small known problems.
 

I hope this info can help Debug.

Bye

Link to comment
Share on other sites

  • CRJ Forum Moderator

I tried spawning at OPMR and LIPZ with no problems.

 

If the aircraft starts doing something unexpected, it would be a good idea to reset the initialization files as detailed here:

As noted, if you do this, the aircraft will take several minutes to load the first time you select it after doing the above procedure.

Link to comment
Share on other sites

38 minutes ago, JRBarrett said:

I tried spawning at OPMR and LIPZ with no problems.

 

If the aircraft starts doing something unexpected, it would be a good idea to reset the initialization files as detailed here:

As noted, if you do this, the aircraft will take several minutes to load the first time you select it after doing the above procedure.

Hi, thanks for attention.

Only one info: following the reset instructions and deleting the files will also reset throttle detents, joystick, pedals configs and cabin views settings ?

In any case I could take note of the actual settings.

Thank You

Link to comment
Share on other sites

  • CRJ Forum Moderator
1 hour ago, pilota57 said:

Hi, thanks for attention.

Only one info: following the reset instructions and deleting the files will also reset throttle detents, joystick, pedals configs and cabin views settings ?

In any case I could take note of the actual settings.

Thank You

Those settings are stored elsewhere and should not change with a reset of the “m” files.

Link to comment
Share on other sites

35 minutes ago, JRBarrett said:

Those settings are stored elsewhere and should not change with a reset of the “m” files.

Thanks @JRBarrett.
Ok I deleted the " m " files and after three CRJ loading tests it seems now it's ok: CRJ is correctly cold & dark loaded.

Now I'd like to know from CRJ Developers when and the reason the new files in Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\aerosoft-crj will be created.

As You can see in attached image there is old folder situation and actually folder situation.

Thanks for Your support.

folder packages - crj.jpg

Link to comment
Share on other sites

I’d like to add I’ve experienced this too last night. By default I’ve set the CRJ to start in a ‘turnaround’ state, and I was starting from LFRS. 

 

I wouldn’t be able to pinpoint what has changed recently about either MSFS or the CRJ that causes this, I’ve never seen it happen before.

 

Exiting and restarting MSFS (and my flight) fixed it for me.

Link to comment
Share on other sites

  • CRJ Forum Moderator
6 hours ago, pilota57 said:

Thanks @JRBarrett.
Ok I deleted the " m " files and after three CRJ loading tests it seems now it's ok: CRJ is correctly cold & dark loaded.

Now I'd like to know from CRJ Developers when and the reason the new files in Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\aerosoft-crj will be created.

As You can see in attached image there is old folder situation and actually folder situation.

Thanks for Your support.

folder packages - crj.jpg

The files are the compiled executable DLL and support files. They are created by a complier built into the sim from the base WASM files. They are created on first installation of the CRJ, or anytime the files are out of date or do not exist. That is why erasing them triggers a rebuild of the files. Since all of the core functionality of the CRJ is contained in the DLL file, if it becomes corrupted, it might lead to strange behavior or aircraft systems not working correctly.

 

The files are also re-created when the CRJ is updated, or when the sim itself is updated, such as when WU4 was released and again when the hotfix for WU4 was released a couple of weeks later.

  • Upvote 1
Link to comment
Share on other sites

7 hours ago, JRBarrett said:

I file sono la DLL eseguibile compilata ei file di supporto. Sono creati da un compilatore integrato nella simulazione dai file WASM di base. Vengono creati alla prima installazione di CRJ o ogni volta che i file non sono aggiornati o non esistono. Questo è il motivo per cui la loro cancellazione attiva una ricostruzione dei file. Poiché tutte le funzionalità di base del CRJ sono contenute nel file DLL, se viene danneggiato, potrebbe causare uno strano comportamento o il malfunzionamento dei sistemi dei velivoli.

 

I file vengono anche ricreati quando il CRJ viene aggiornato o quando la simulazione stessa viene aggiornata, come quando è stato rilasciato WU4 e di nuovo quando è stato rilasciato l'hotfix per WU4 un paio di settimane dopo.

Morning update: unfortunately this morning the problem came back: cabin lights on and nothing to do with the tablet.

Later I will delete the "m ..." files again.


Yesterday afternoon, after deleting this file, CRJ works fine.


I verified that nothing is changed in folder ... \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ LocalState \ packages \ aerosoft-crj.


Any suggestions are appreciated.


Hello

Link to comment
Share on other sites

1 hour ago, pilota57 said:

Morning update: unfortunately this morning the problem came back: cabin lights on and nothing to do with the tablet.

Later I will delete the "m ..." files again.


Yesterday afternoon, after deleting this file, CRJ works fine.


I verified that nothing is changed in folder ... \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ LocalState \ packages \ aerosoft-crj.


Any suggestions are appreciated.


Hello

Ok, files deleted again and CRJ it's ok after loading.

No problem for deleting files each time except the long time to wait before next first CRJ load.

If possible, please, investigate.

Bye

Link to comment
Share on other sites

4 hours ago, pilota57 said:

Ok, files deleted again and CRJ it's ok after loading.

No problem for deleting files each time except the long time to wait before next first CRJ load.

If possible, please, investigate.

Bye

Ok,
new three CRJ restarts are correctly working.
One think: occasionally the action "Return to desktop" does not close MSFS, it remains in a "suspended" state and I close via CTRL-ALT-CANC >> Activity Manager and terminate MSFS.
Could be that in this way the "m..." files will be damaged ?
Mah

Link to comment
Share on other sites

  • CRJ Forum Moderator
43 minutes ago, pilota57 said:

Ok,
new three CRJ restarts are correctly working.
One think: occasionally the action "Return to desktop" does not close MSFS, it remains in a "suspended" state and I close via CTRL-ALT-CANC >> Activity Manager and terminate MSFS.
Could be that in this way the "m..." files will be damaged ?
Mah

Possibly. I don’t think anyone on the test team has seen this particular problem, but I have read other reports that some users do not get a clean shutdown of MSFS when exiting the sim. I don’t know if this would cause any corruption of the “m” files, but it might cause other configuration files used by the CRJ to not save properly. For instance, there is a separate config file which stores all of the various options that can be set in the EFB - perhaps something is affecting that if MSFS does not fully shut down on exit.

Link to comment
Share on other sites

4 hours ago, JRBarrett said:

Possibly. I don’t think anyone on the test team has seen this particular problem, but I have read other reports that some users do not get a clean shutdown of MSFS when exiting the sim. I don’t know if this would cause any corruption of the “m” files, but it might cause other configuration files used by the CRJ to not save properly. For instance, there is a separate config file which stores all of the various options that can be set in the EFB - perhaps something is affecting that if MSFS does not fully shut down on exit.

Ok, mysteries of science and technology.
He will try to delete those files only on the occasion of MSFS crashes.
Thank you

Link to comment
Share on other sites

Jumping on this one. This happens to me as well but I'd say it's been there for quite a while. It seems to be random i.e. it can happen at any airport be it an added scenery or default, any weather, any time of the day. What fixes it is to go back to the main menu and reload flight. There is no need to restart MSFS. You will save 5 good minutes by not doing it.

Link to comment
Share on other sites

This happens to me every like three flights and the fix is to go back to loading the flight and start it again and not the sim, I think it has something to do with the way you exited the flight before but not sure, when I started closing the flight to the status I want to start it later on I think it's gone but this could be a coincident of course. 

Link to comment
Share on other sites

I never restart the whole sim

Often going back at airport and plane selection solve.

But is randomly

Does not matter if the Community is empty or full (i use addon-linkee in order to optimize mods used by the sim)

Bye

Link to comment
Share on other sites

I can confirm this issue. Appears randomly as described above. When this happens I only need to go back to the main menu and load the flight once again. 

Its independent of airport. 

Link to comment
Share on other sites

21 hours ago, Roberto0435 said:

I had the same problem only when I launched the wrong version of my Aviaworx FMC.

 

Maybe one of your addons?

It randomly happends with or without addons.
I also have Aviaworks for CDU managment via tablet but this doesn matter.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...