Jump to content

Electrical systems are all on, but the ATC radio will not work in MSFS 2020.


Recommended Posts

Screenshot shows that my power is on and active, all my COMs are set, and my systems are all working, but when I select the ATC from the toolbar in order to listen to ATIS, I still get the "Radio Off" message in MSFS 2020 in the CRJ-700.

I have been using the checklist by JayDee at Flightsim.to (https://flightsim.to/file/10718/crj-700-checklist-procedures-jds(v0.4)) and have pre-loaded my flight plan using a .pln file that I created at SimBrief.com, using the load/save option in the World Map.

image.thumb.png.73bfd5b44672648c9c6fa9606fe55ce7.png

Link to post
Share on other sites
8 hours ago, LesOReilly said:

Make sure you are listening to the Com

 

image.png.99a24252c94b9c8d8703c54655a4fda4.png

Hi Les - I double checked and the panel is set exactly as you showed. I cannot imagine what is wrong - I switched to the 787 and the comms worked fine. It seems to be a problem specifically with the CRJ.

 

Link to post
Share on other sites
15 hours ago, Dan Huffman said:

Hi Les - I double checked and the panel is set exactly as you showed. I cannot imagine what is wrong - I switched to the 787 and the comms worked fine. It seems to be a problem specifically with the CRJ.

 

What does your overhead panel look like in this state?

Link to post
Share on other sites

Hello, I do have the same issue with the Cesna, and all the numbers are blinking :( on this one. When I am trying with Robin cap 10, same message after few minutes and the radio is off even if the button is on.

Link to post
Share on other sites

OK, problem solved!

I had a couple guys in the Facebook MSFS 2020 VR forum suggest that I might have some switches on my Honeycomb Alpha or Bravo still mapped to BAT, ALT or other switches. This proved to be the case!

I deleted all the unused button mappings for the Alpha and Bravo rocker switches and light switches, and made sure that the magnetos/key starter switches were also unmapped just to be safe. Then, when I applied the new settings and loaded up the CRJ, everything worked like a charm!

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • Deputy Sheriffs

Thanks for sharing what you did to resolve this, Dan.

 

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

Link to post
Share on other sites
  • Herman locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...