Jump to content

MSFS Does not launch after clean PC software install


Recommended Posts

I purchased the DVD box set of MSFS 2020 deluxe from you when it was released.

 

I have now performed a full clean rebuild of software on my PC and wanted to reinstall MSFS 2020 onto an SSD other than my system disk SSD where it was installed before.

 

My first attempt was to install MSFS from the 10 DVDs not sure if I had to do this.

 

I installed core MSFS to

C:\Users\xxxxxxxxx\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe. But installed MSFS content to a larger SSD drive 😧

 

This all went OK and I went into MS Store and MSFS was showing as I had purchased it back in August 2020 so I clicked install and it downloaded core 1.6GB and seemed to install OK.

 

My problem is when I run MSFS 2020 (as administrator) it begins to launch but then hangs leaving just a blank black screan. When windowed MSFS 2020 app is showing version 1.15.8.0 the latest version but it never gets to the point where its check for updates as I would expect.

 

I then completely removed MSFS and DVD content using Settings/Apps Add/Removed.

 

My second attempt was to skip installing content from the 10 DVDs. Instead I just went straight into MS Store and installed MSFS from there. Again the download and the install went OK but I get the same issue It starts to launch but hangs after a couple of seconds.

 

Would appreciate any advice on this issue and clarification of of the steps I should carrying when reinstalling the box set version I am assuming this is nothing to do with installing MSFS ion a different disk

 

Thanks in advance

Link to comment
Share on other sites

  • Administrator

Hi @marki

 

Have you already tried the steps here? https://flightsimulator.zendesk.com/hc/en-us/articles/360015999539-Stuck-on-the-blue-bar-TBM-loading-screen-loading-stops

 

If you haven't, I'd recommend giving them a try since it generally covers most startup issues. In terms of the steps you took to reinstall, they're just fine and shouldn't cause any issues.

Link to comment
Share on other sites

Thank you Tom  I am almost there. 

 

Did another clean install of MSFS and ended up with the same issue. Then went through the steps in the link you posted and the Powershell command is what got me past the black screen. Had to log into XBox_Live account again but after that the full download started. It took for hours but MSFS launched OK after download.

 

However  when I try  and launch MSFS from start menu I get the same black screen issue. As it stands I can only launch MSFS using the powershell command. Any ideas on this? 

 

But thanks again for getting me this close

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...