Jump to content

Squawk does not work on vatsim?


Recommended Posts

I'm not entirely sure if this is an aerosoft problem or a mfs2020 problem, But when connecting to vatsim. i set up the flight and everything aswell as tcas, But for the controller it never shows that i am squawking... 

Link to comment
Share on other sites

just to clarify, I've seen multiple other people i know have a similar issue with only this aircraft, To my knowledge i set up the tcas correctly, and had edward the pilot show me one time but still get this issue 

  • Like 1
Link to comment
Share on other sites

On your RDU, is the squawk code showing in green or white? If it is still in white, then you may need to select Transponder 1 (or 2) using the switch next to the standby radio.

 

Here's a link for the same aircraft, just in another subforum here with a photo of where to find the selector: https://forum.aerosoft.com/index.php?/topic/125625-transponder-tara/

Link to comment
Share on other sites

Yes, I am aware about that. I've done a few following checklists and a few not. I will go and test it now thanks. I believe that may be it but im not sure, I've seen it before on the checklist but wasnt sure what it was.

Link to comment
Share on other sites

I've confirmed that changing the ATC switch in the Aerosoft CRJ does not trigger the particular SimConnect variable that vPilot uses to automatically trigger Mode C. That means that, for right now, you will manually need to enable Mode C in vPilot. The CRJ does set the squawk code in the correct SimConnect variable, so the code is communicated correctly, but not the transponder state.

 

In my own integration, I've made a small button for myself that automatically sets the SimConnect transponder state to Mode C whenever I engage the ATC switch in the CRJ, but that doesn't respect the unexposed ALT setting inside the RTU.

 

For Aerosoft, in order to make this work, whenever ATC 1 or 2 are active, you need to update the TRANSPONDER STATE:1 variable to 4 (if Mode C), 3 (if not Mode C), and 1 (if in standby).

 

There is currently no SimConnect variable that indicates "IDENT" has been pushed, so vPilot can't recognize when you push that button in the sim. So, if asked to IDENT, you'll still need to do that from vPilot.

  • Like 2
Link to comment
Share on other sites

  • 1 month later...
On 3/19/2021 at 3:06 PM, Marcus Griep said:

I've confirmed that changing the ATC switch in the Aerosoft CRJ does not trigger the particular SimConnect variable that vPilot uses to automatically trigger Mode C. That means that, for right now, you will manually need to enable Mode C in vPilot. The CRJ does set the squawk code in the correct SimConnect variable, so the code is communicated correctly, but not the transponder state.

 

In my own integration, I've made a small button for myself that automatically sets the SimConnect transponder state to Mode C whenever I engage the ATC switch in the CRJ, but that doesn't respect the unexposed ALT setting inside the RTU.

 

For Aerosoft, in order to make this work, whenever ATC 1 or 2 are active, you need to update the TRANSPONDER STATE:1 variable to 4 (if Mode C), 3 (if not Mode C), and 1 (if in standby).

 

There is currently no SimConnect variable that indicates "IDENT" has been pushed, so vPilot can't recognize when you push that button in the sim. So, if asked to IDENT, you'll still need to do that from vPilot.

How did you do this?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...