Jump to content

CRJ causes CTD but only if I try to load from a ramp/gate


Thx1137
 Share

Recommended Posts

I suspect this is an Asobo issue. In real life there plenty of passenger jets such as 737s park at the gates I'm using but in MSFS the plane gets seriously close to the air-bridges and sometimes intersects air-bridges.

 

At YSCB:

RAMP 28 - GA Medium - CTD.

RAMP 16 - GA Medium - Works fine.

Start on runway - Works fine.

 

I suspect that the aircraft is causing a CTD because part of its geometry is intersecting a building or air-bridge. The issue is quite annoying because this happens in a *lot* of gates and ramps that medium size aircraft park at for real and it takes forever for MSFS to reload. This also happens at the EDLP. I've just downloaded your freeware version so I'm about to try that.

 

I'll also note that other aircraft I have simply appear partially embedded in the structures in this case, though I don't know if all aircraft allow it. I mostly fly little GA...

 

I turned failure and damage modes off in the assistance menu and removed all other addons. It still CTDs.

 

It would be great if someone can confirm the above at the very least.

 

I've installed EDLP. Gate 6 HEAVY at EDLP causes a CTD too. As does trying to load the tutorial from the main map.

 

CTDs normally happen when the progress bar is about a few centimeters from the right side of the screen. MSFS logging sucks.

Link to comment
Share on other sites

  • Developer

This is weird. I know that loading on the runway is different from loading on the apron. But differences between gates and/or ramp positions? I  don't have any explanation for this right now, to be honest.

Is there any pattern? Like "positions closer to the runway work and those further away from the runway crash"?

Link to comment
Share on other sites

I don't know Hans. As I say it looks like the ramp/gate size has something to do with it but then I just used Gate 6 which is supposed to be a HEAVY at EDLP and it CTDed.

 

Maybe what I'm getting is just intermittent CTDs. At the moment I load in maybe 1 in 8 times. Certainly no better than that. I'll try using RAMP 16 at YSCB a few times to see how it goes. Sigh.

 

But I would like someone else to at least try YSCB ramp 28.

 

Of course this is the only aircraft I've had it with but I really only fly the Carenados.

Link to comment
Share on other sites

Should I have m* files in C:\Users\Steven\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Community\aerosoft-crj ?

There aren't any but when the plane loads it seems OK. Not that I've managed to do more than play with the APU and battery yet...

Link to comment
Share on other sites

Edit, I do have the m* files. I didn't realize they were in LocalState\packages\aerosoft-crj

 

As another note. The sim can crash at any time from the very start of the progress bar to near the end. If I put my programming hat on, it seems like some random bit of memory is getting stomped on.

 

And YSCB RAMP 16 - *always* works fine for me. I've tried a bunch of positions at (your freeware) EDLP and not one of them will so so far.

Link to comment
Share on other sites

I have no problems if I start at YSCB RAMP 16, I've loaded there 6 times without a CTD. Other ramps/gaes cause a CTD 100% of the time. Runways sometimes work, sometimes CTD.

 

I just noticed an odd thing in MSFS. When the screen is completely black I can see random pixels firing on my monitor. It only happens in MSFS and starts from the MSFS startup screen to in-game. They are hard to notice because it it just once pixel every now and again but I never notice them before.  Tomorrow I'll confirm they still appear with the CRJ removed. I'll also update my drivers. I only updated a couple of weeks OK so they aren't old.

 

* I've updated every thing I can so Windows and the Store apps are all up to date. I'm running out of ideas.

* I run as admin

* I'm not running anything but the sim

* No mods in the community folder

* No problems with any of the Carenado aircraft that I fly very very regularly.

* No overclocking

* I'm a programmer so I know not to fiddle with things I shouldn't. (page files, services, etc). I'll take reliability over maybe an extra 2fps any day.

 

It sounds like a tough one.

Link to comment
Share on other sites

  • Root Admin

The Carenado aircraft are all done in HTML/JavaScript and not C++. So that does not indicate a lot. 

 

Hans is discussing these things with Asosbo. As it all runs in a sandbox there is very little option for us to debug things. Simply no access. And as we are simply unable to recreate it and many thousands of users do not have this we have to find what is different on your system. As a programmer you will know how difficult that can be. Certainly without good logfiles etc.

Link to comment
Share on other sites

10 hours ago, Mathijs Kok said:

The Carenado aircraft are all done in HTML/JavaScript and not C++. So that does not indicate a lot. 

 

Hans is discussing these things with Asosbo. As it all runs in a sandbox there is very little option for us to debug things. Simply no access. And as we are simply unable to recreate it and many thousands of users do not have this we have to find what is different on your system. As a programmer you will know how difficult that can be. Certainly without good logfiles etc.

 

Yeah, that's why I said I thought this would be Asobo. 🙂 To me that is an unacceptable situation for you guys, but I guess you are the guinea pigs for the rest of the "complex addon" industry!

 

I've not had anyone confirm if the two ramps at YSCB do the same for them as they do for me which is rather annoying because if YSCB RAMP 28 gives others the same issue 100% of the time like me, it would have to be a great hint! Reproducibility is key!

Link to comment
Share on other sites

@Mathijs Kok Sorry to ping directly...

I have a definite change in behaviour. It now only crashes on starting a second flight.

 

Things I've changed:

1. Updated/reinstalled the Nvidia drivers. The "old" ones were only up to a month anyway. I did this because of those random little pixel firings my monitor was having when loading and playing the game (only visible on a 100% black screen).

2. Added process exclusions in Windows Defender for FlightSimulator.exe and the other two XBox exes. (Based on another person saying this fixed their CTDs)

3. Removed my Virple stick and plugged in my Alpha yoke.

 

I've repeated each of these scenarios 3 times each. So far it is 100% consistent. Which is a lot better than before.

 

Scenario One

1. Load CRJ at YSCB (any gate/ramp) - it works

2. Exit to main menu

3. Load CRJ at YSCB (any gate/ramp, even the same as step #1) - it CTDs as soon as I hit the fly button, every time.

 

On one test I waited several minutes between steps 2 and 3 to see if something needed time to uninitialize. It didn't help.

 

Scenario Two (yay?)

1. Load CRJ at YSCB (any gate/ramp) - it works

2. Exit to main menu

3. Load the C182 - It works.

4. Exit to main menu.

5. Load CRJ at YSCB (any gate/ramp) - it works 

 

Observations

* There seems to be more than one cause for the CTDs.

* The original CTD was 100% reproducible but it would CTD at different times from pressing Fly to the progress bar almost fully loaded. (it never CTDed when the aircraft loaded)

* The new CTD always happens on pressing Fly, usually the progress bar hasn't even come up yet. If it has come up, it takes less than 1 second to CTD.

* So weird...

 

Event Log Entry and DxDiag (Doh, should have done this first)

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x6040b793
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x6040b793
Exception code: 0xc0000005
Fault offset: 0x000000000188bf77
Faulting process id: 0x2e18
Faulting application start time: 0x01d71b9908c4312a
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 433dbc63-1573-4681-a89e-f6cd81097168
Faulting package full name: Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe

Faulting package-relative application ID: App

DxDiag.txt

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...