Jump to content

SIM keeps crashing trying to load the CRJ


PhntmV2
 Share

Recommended Posts

 

vor 1 hour , Hans Hartmann sagte:

This is a different problem. It's not related to the topic of this thread.

 

If you can, please send me your flightplan and what your last FMS-related action (for example a direct to) was before it occured.

Start with CRJ500 at EDDN on Gate 2

Starts but extremely slow, not possible to interact with the CRJ systems, so it was not possible to do anything, and so no flightplan was active.
I started the CRJ several times before and mostly it frozens directly after starting the flight, it was not possible to do anything, sometimes I have a CTD.

 

DxDiag.txt mymsinfo.txt

  • Upvote 1
Link to comment
Share on other sites

9 hours ago, jsolomon said:

Thanks for your attention to this issue.

 

Unfortunately, it does seem like there is something inherently unstable about this aircraft in the current environment.

I have FS 2020 installed through Microsoft Store on secondary SSD, and CRJ downloaded from Aerosoft.

 

First time I loaded up CRJ-700, at Flightbeam KPDX gate (no flight plan), initial loading went fine. Then I picked ready to Taxi via EFB to check out instruments. Was looking around, checking out ~30fps frame rates with Xbox game bar. All seemed okay. Then I went to traffic settings, tweaked some things, sim crashed. I did not have any other intensive or RAM hungry programs running, like browsers etc. Computer freshly restarted.

 

Ok, then I tried to load the plane again, sim crashed.

 

Then I removed the CRJ installation via Windows add/remove programs menu, but it did not get rid of AppData folders (you should probably fix that). So I deleted those manually.

Restarted sim, made sure all was well without CRJ.

Reinstalled CRJ, saw a tip here to load from airborne. Did that near barebones Kelowna, loaded okay, flew for a minute, loaded CRJ 500 same way, and AppData populated fine with 8 files. But a couple minutes later, SIM crashed.

 

Ok so I removed all add ons from community and all non MS/Asobo add ons and subfolders from official folder. Did not make any difference.

 

Still the only reliable start I can get now is through developer mode, switching from A320 neo. I also turned off "Load Modules Asynchronously."

So I tried loading CRJ 700 at Asobo KSFO. Did EFB -> ready to taxi again. Started a pushback. Right when pushback was about to be finished, sim crashed.

 

So yeah, the CRJ is unstable, for whatever reason.

No problems with any other add ons (in the past I have had one scenery conflict solved through community folder pruning, here makes no difference), but the CRJ keeps crashing no matter what I do.

Whether it crashes immediately when trying to load at airport, after 2 minutes in air, or after 5+ minutes after switching from A320, I am unable to fly the plane.

 

I also excepted FS 2020 process from Windows Defender.

 

Computer is i7-9700, RTX 2080 Super, 16 GB of RAM (RAM usage seems well within limits, however, and running at 1440p not 4K).

Windows 10 Home 19042.867, latest Nvidia drivers.

Nothing overclocked.

Performance is fine until sim crashes.

 

At default Kelowna, ready to taxi.

RAM usage at 64-68%
CPU 28-35%

GPU 64-76%

VRAM 69-70%

FPS 34-35, no stutters.

 

Then after 6 min with totally steady performance, crash. Odd!


 

 

 

Me too. When you implement the flight plan or a DIR to, and some ILS landing patterns it just freezes, freezes the whole game sometimes or just the aircraft. :(

Link to comment
Share on other sites

On 3/16/2021 at 10:31 PM, Hans Hartmann said:

Depends. If he has a Steam version of MSFS, it's Roaming, not Local.

Oh crap, a lesson in not getting involved unless you know what you're talking about 😊

Link to comment
Share on other sites

vor 3 Stunden , Hans Hartmann sagte:

You should never use the aircraft selector. It causes issues with the aircraft initialization. I stopped using it quite early in the development process.

 

To everybody who gets these CTDs while the "m"-files are created, do you use any anti-virus software other than Windows Defender? And if yes, which one? We're getting closer to finding out what happens, but don't know yet why. The kind of error is one where AV software is possibly the culprit (I'm not saying it is. It's just possible!), so we would like to know what you use. Thank you!

I dont have any AV software besides the standard windows defender. I have 8 m files now (by spawning the aircraft with dev mode), and the 3D file is gone. But the sim still crashes.

Link to comment
Share on other sites

So yesterday evening I decided to reinstall the sim. I left my PC on over night. I have about 20mbit/s. The download is now stuck at 94,29GB (151,26GB total). It doesnt loop but it just stopped there, even though my connection is still going. Does someone know what to do?

Link to comment
Share on other sites

  • Root Admin
1 minute ago, PhntmV2 said:

So yesterday evening I decided to reinstall the sim. I left my PC on over night. I have about 20mbit/s. The download is now stuck at 94,29GB (151,26GB total). It doesnt loop but it just stopped there, even though my connection is still going. Does someone know what to do?

 

Check the guidies here: https://flightsimulator.zendesk.com/hc/en-us/categories/360001769531-Microsoft-Flight-Simulator

  • Thanks 1
Link to comment
Share on other sites

The info as requested:

I have the m files created and can load CRJ without any problem using the “load of a default aircraft first” trick.

 

My Anti virus is Kaspersky Anti-Virus (KAV). Anyway all this process of m files creation and crj loading never flagged any AV task neither windows firewall.

Link to comment
Share on other sites

Hello! I have this problem as well. Downloaded the file from the Aerosoft site and installed it. Started MSFS, selected aircraft and airport. Shortly before the end of the first loading of the CRJ, MSFS crashes. I have also emptied the complete community folder except Aerosoft CRJ and performed the administrator start without VC, no change. But i can´t find any m-files.

Best regards

Link to comment
Share on other sites

So, new behaviour over here. After firing up the simulator I can start a flight with the CRJ without crashing to the desktop (without having to load a default plane first). Did start at the gate without engines running (London City). Performed all the startup tasks, taxied out and managed to take-off. A few minutes into the flight however, CTD....

Link to comment
Share on other sites

Like so many others I am having the CTD, as well. I have tried various situations and combinations to either determine the cause or mitigate the issue without success. What is occurring for me is this: 

 

1. Nothing I do corrects the problem.

2. It appears that, as long as I do not try to fly, the plane will sit there indefinitely without crashing. As soon as I try to fly... crash... over and over and over.

3. Given #2, that leads me to believe that all of the antivirus conversation is likely moot.

4. I am unwilling to spend additional time ripping apart my sim and system that works for every other MSFS aircraft model just to try to fix this model that doesn't work for me yet seems to work for others, but not everyone; I paid like everyone for a finished product and am not a developer.

 

So, with that said, as Aerosoft has developed this product and is selling it, regardless of whether it is a sim issue or model issue, it is Aerosoft's issue and Aerosoft needs to fix it. Now. Right now. This has gone on for far too long and I would not recommend this purchase to anyone at this point until this issue is resolved for everyone.

 

This needs to be Aerosoft Priority #1 until resolved.

  • Like 1
  • Downvote 6
Link to comment
Share on other sites

10 hours ago, jsolomon said:

 

This worked for me, but with default A320. I uninstalled CRJ, wiped AppData.

Started sim not in developer mode, not in admin mode this time, loaded A320 at KMEM ramp 30. Interestingly took a long while to load A320 and during this time actually these 4 CRJ files were built in AppData!

 

m8cac1771_0.cache

m8cac1771_0.dll

m8cac1771_0.lib

m8cac1771_0.pdb

 

Almost like the A320 is a proxy for the CRJ. Weird.

 

Anyway, then I was able to exit and load CRJ 700 at KMEM, tried same thing A320 then CRJ 700 at KDFW, and finally Aerosoft Paderborn (figure it should work there after all). Then I flew for a while around Paderborn.

 

However, loading CRJ 700 without loading A320 first, CRJ crashes. 

 

Just to follow up. I loaded the A320 and then the CRJ 550, took some time and created the other 4 files (as I expected).

Flew from Paderborn over EDDF at 35,000 and descended to EDSB using HDG, ALT and V/S (although my instruments froze as I was messing with MCDU trying to set up an approach, pretty sure that was just random bug).

Link to comment
Share on other sites

  • Root Admin
1 hour ago, thelynx said:

Like so many others I am having the CTD, as well. I have tried various situations and combinations to either determine the cause or mitigate the issue without success. What is occurring for me is this: 

 

1. Nothing I do corrects the problem.

2. It appears that, as long as I do not try to fly, the plane will sit there indefinitely without crashing. As soon as I try to fly... crash... over and over and over.

3. Given #2, that leads me to believe that all of the antivirus conversation is likely moot.

4. I am unwilling to spend additional time ripping apart my sim and system that works for every other MSFS aircraft model just to try to fix this model that doesn't work for me yet seems to work for others, but not everyone; I paid like everyone for a finished product and am not a developer.

 

So, with that said, as Aerosoft has developed this product and is selling it, regardless of whether it is a sim issue or model issue, it is Aerosoft's issue and Aerosoft needs to fix it. Now. Right now. This has gone on for far too long and I would not recommend this purchase to anyone at this point until this issue is resolved for everyone.

 

This needs to be Aerosoft Priority #1 until resolved.

 

 

It is our first priority, of course. However as we have explained many times now, it is more or less out of our hands.  We need the assistance from Asobo to solve it. They have a good idea what the problem is, just not how it gets triggered. But they are getting there,

 

We have even less ideas who it happens on a handful of systems. As it all runs in the MSFS sandbox, basically the sim should be 100% the same for everybody. I know it is frustrating to see that thousands of people can run it and you not. https://forum.aerosoft.com/index.php?/forum/1088-videos-reviews-articles/

 

I have been the project manager for over 100 aircraft add-ons and we always had a number of people with issues like this. Highly annoying, certainly if the number is small (and to be honest, it really is , we have 34 listed upon thousands upon thousands of sales) and the problem  is not something we can solve easily. And there are always customers like you who lose their patience, do not accept our explanations and feel the need to write bold.  Of course it does not change anything, but if it is needed to vent your frustration that's okay for me. 

 

To directly reply to you, we can't solve this now, not right now.  Nobody can.  If you find this unacceptable, do contact us on support@aerosoft.com. 

 

----------

 

in the mean time, just to show that the products simply works fin

  • Like 4
  • Thanks 1
  • Upvote 3
Link to comment
Share on other sites

  • Developer

So, news... I was asked by Asobo if you could collect some crash dumps for them to increase the chances of tracking down this issue.

Attached you find a registry editor script. This script enables the collection of crashdumps in a user-defined folder.

The content of the script looks like this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps]
"CustomDumpFlags"=dword:00000000
"DumpCount"=dword:0000000a
"DumpType"=dword:00000002
"DumpFolder"="C:\\MyDumps"

You can open it with any text editor (but please not Word, Wordpad or something similar. The Windows Editor or Notepad++ are fine) to verify the content. If you wish to use a different folder or drive to store the crashdumps, feel free to edit the last line.

 

Once you're happy with the content, create the folder ("C:\MyDumps") and run the script by double-clicking it in Windows Explorer. You will receive a message that asks if you

 

If you experience a CTD and a crashdump file with a matching date and time appears, please upload it to some cloud drive service (Google Drive, Onedrive, Dropbox, Strato HiDrive or other major cloud services. Please not something fishy) and send me a download link via personal message. The crashdumps will not be kept by Aerosoft or Asobo and will be deleted immediately after the bug hunt is complete (they do not contain personal data, but still).

 

I thank everyone of you for you patience and cooperation. We are all very embarassed that this happens, and despite the fact that some think they need to point that out, it is already our #1 priority. Thank you.

 

Dumps.reg

  • Like 3
  • Thanks 1
  • Upvote 7
Link to comment
Share on other sites

Hey check it out.

 

Saw this comment on forums.flightsimulator.com 

 

 

"

2097_2.png

I’ve been flying with the AI online but rarely see any traffic and certainly none at airports. I really don’t like flying when the world is empty of traffic.
Now the CRJ is causing a problem. I switched to offline traffic and CTDs. Too many variables to find out why but I tried to load three different airports with the same result. Each time CTD before entering sim. I noticed that the AI was set to 100% so I reduced it to 50% thinking that maybe all gates were filled. Still the same problem. Switched back to online (but seriously missing :rage: )traffic. and the CRJ loads.

Would like to know why this is a problem…"

 

 

I switched my traffic from offline to online and I was able to load CRJ 700 directly after starting sim without first loading the A320!

 

So maybe that's a common denominator? Anyone else here using offline traffic for better density?

Link to comment
Share on other sites

I am using online AI Traffic

 

I am unable to use all the work arounds I used yesterday to get the CRJ loaded with Avionics on. Today no matter what trick I use it loads all dark.

Link to comment
Share on other sites

vor 18 Stunden , dotC sagte:

I think I might have found a solution. I did two things, so I don't know which is responsible. Your mileage may vary.

 

First, I deleted the Megapack Liveries that I had installed.

Second, I added anything to do with MSFS to the Windows defender exclusions list.

 

(edit: actually another thing I did was verify the files in steam, as I have the steam version of MSFS and accepted any downloads that it created in MSFS after.)

 

I don't know which of those things did the trick, but everything now works as intended, and I am able to use CRJ normally. 

So a little Update to this, this actually worked for me aswell.

I did every step this guy mentioned. Do note that when you verify the steam files, it might reinstall the complete sim. (150GB) It did that to me. So I was loading the sim download over night. Once it was finished I started up the sim, grabbed the CRJ into an airport and it loaded totally fine. I did a startup and takeoff with it, everything seemed good. Then I went back to the menu and loaded the other CRJ. That worked aswell. Of course the sim might crash later but I have a feeling that this is not going to happen. This is the first time I was able to load the CRJ without a CTD after starting the sim.

Link to comment
Share on other sites

  • Developer
3 hours ago, Hans Hartmann said:

So, news... I was asked by Asobo if you could collect some crash dumps for them to increase the chances of tracking down this issue.

Attached you find a registry editor script. This script enables the collection of crashdumps in a user-defined folder.

The content of the script looks like this:


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps]
"CustomDumpFlags"=dword:00000000
"DumpCount"=dword:0000000a
"DumpType"=dword:00000002
"DumpFolder"="C:\\MyDumps"

You can open it with any text editor (but please not Word, Wordpad or something similar. The Windows Editor or Notepad++ are fine) to verify the content. If you wish to use a different folder or drive to store the crashdumps, feel free to edit the last line.

 

Once you're happy with the content, create the folder ("C:\MyDumps") and run the script by double-clicking it in Windows Explorer. You will receive a message that asks if you

 

If you experience a CTD and a crashdump file with a matching date and time appears, please upload it to some cloud drive service (Google Drive, Onedrive, Dropbox, Strato HiDrive or other major cloud services. Please not something fishy) and send me a download link via personal message. The crashdumps will not be kept by Aerosoft or Asobo and will be deleted immediately after the bug hunt is complete (they do not contain personal data, but still).

 

I thank everyone of you for you patience and cooperation. We are all very embarassed that this happens, and despite the fact that some think they need to point that out, it is already our #1 priority. Thank you.

 

Dumps.reg 239 B · 8 downloads

 

Let me quote myself and lock this thread for a couple of hours, so everybody sees this post. I got one crashdump so far (use 7-zip to compress them. This reduces their size from about 9GB to less than 2GB) but I really could use some more. I'm going to reopen the thread later.

  • Thanks 3
Link to comment
Share on other sites

@Hans Hartmann

Hello Hans Hartmann,

 

my upload of a crash dump file is nearly complete, but I can't send you a personal message. I do not have the required 3 content items, whatever this means.

Could you please send me a personal message with your company email address or give me the rights to send personal messages, so I can send you the link to the crash dumb file?

 

Best regards

Link to comment
Share on other sites

Hi Hans,

 

I  don't have a dump file to send you cause for the most part I don't have CTDs. Although I have added your reg entries there. Just incase. I have all my m* files.

 

I have the dark cockpit issue where even the EFB cannot be turned on.

 

I am hoping both issues are related/same.

Link to comment
Share on other sites

8 hours ago, jsolomon said:

Hey check it out.

 

Saw this comment on forums.flightsimulator.com 

......

 

I switched my traffic from offline to online and I was able to load CRJ 700 directly after starting sim without first loading the A320!

 

So maybe that's a common denominator? Anyone else here using offline traffic for better density?

 

I actually had the GA density slider to 70 and offline traffic to on... tried to move all sliders including ground vehicles and fauna to 0, sett traffic variety from medium to low and turned all traffic off. Voila, the plane loads. It also loaded extremely quickly...I'd say less than two minutes. It did not start cold and dark, even though I'd selected a parking spot.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...