Jump to content

How to use the TCA throttle, the reverse levers and Starter buttons with Aerosoft Aibusses under P3Dv4/v5


SimWare
 Share

Recommended Posts

  • Aerosoft

How to use the TCA throttle, the reverse levers and Starter buttons
with Aerosoft Aibusses under P3Dv4/v5


This is not complicated at all but since the Airbus is a complex aircraft and P3D as well as the Thrustmaster TCA throttle offer A LOT of capabilities and features,

some basic configurations are required to be able to use the full possibilities of all these.

Once again, as a guideline, DO NOT rely on automatic assignments.
YOU are the pilot, so YOU decide what does what.
Also, no need to use the Thrustmaster tools or driver.

 

Here are the steps to configure your throttle with Aerosoft’s Airbusses under P3Dv4/v5.

This might look a bit long, but keep in mind you only have to do it once.
So take some time now. It will save a lot more later to do it right from the start.


STEP 1:

Start the Aerosoft Updater and make sure you have the latest update of your Aerosoft Airbus.
image.png

 

STEP 2 :
Start the Aerosoft Airbus configurator and check “Enable TCA Quadrant support”
This will activate the reversers management and allow Starter buttons access.

image.png
STEP 3:

Start P3D and load the Aerosoft Airbus of your choice.
Go to Options-Axis Assignments
Assign Engine 1 throttle Axis to the left lever (X Axis)
Assign Engine 2 throttle Axis to the right lever (Y Axis)
IMPORTANT : No need to manually assign any reverser function.
The Airbus Addon will automatically trigger the reversers when the levers get to the reversers zone.

image.png

 

IMPORTANT (again) : 
Make sure the sensitivity of the throttle axes is set to maximum (127) 

and the null zone to minimu (1)
image.png

STEP 4 :
Check ALL the axes assignments and delete any other Axis assignment.
For the throttle, only Engine throttle Axes 1 & 2 must be assigned.
This step is very important otherwise you may have conflicts with other controls

Such as Stick and Rudder.
image.png

STEP 5 :
We will now assign the starter, crank and Ignition switches.

image.jpeg
Go to Options-Key Assignments and make the following assignments :
 

ENGINE 1 Master switch on, BUTTON 3: "Hotas generic key (A0)"

ENGINE 1 Master switch off, BUTTON 3 ON RELEASE: "Hotas generic key (A1)"

ENGINE 2 Master switch on, BUTTON 4: "Hotas generic key (A2)"

ENGINE 2 Master switch off, BUTTON 4 ON RELEASE: "Hotas generic key (A3)"

ENGINE MODE switch in "CRANK" position, BUTTON 7: "Hotas generic key (A4)"

ENGINE MODE switch in "NORM" position, BUTTON 7 ON RELEASE: "Hotas generic key (A5)"

ENGINE MODE switch in "IGN/START" position, BUTTON 8: "Hotas generic key (A6)"
ENGINE MODE switch in "NORM" position, BUTTON 8 ON RELEASE: "Hotas generic key (A7)"

It should look like this :
image.png

Do not forget to check “Do action when key is released” when “ON RELEASE” is specified.
image.png

STEP 6:
Check ALL the buttons assignment and make sure no unwanted button is still assigned.
The TCA throttle has “Virtual buttons” These are buttons that are triggered by the throttle levers at different stages of the course. So movin the throttle will make like there were buttons pressed. If these buttons are automatically assigned in P3D, it may result in strange behaviors.
For instance in a change of view wich is of course weird.
So go and check all the button assignment .
See hereunder an example of unwanted View change automatic assignments :
---> In this example, you should delete Button 2 ang 9 assignments.

image.png


STEP 7 : Check it actually works (Video) 
image.png

 

NOTE REGARDING THE A330 REVERSERS SYSTEM VS. THE A318 -> A321 : 
The A330 only activates the reversers by pulling the reversers flaps.
The throttle has no portion below the IDLE position.
The IDLE position is therefore different on the A330 compared to the A318 -> A321.

A330  
image.png

 

A318 -> A321 :
image.png

 

 

  • Thanks 1
  • Upvote 2
Link to comment
Share on other sites

Jetzt fehlen nur noch die Zuweisungen für das TCA Add-on.

Auto Brake – Bremsklappen – Flaps

Ich hoffe, dass das Aerosoft-team bald die entsprechenden Anpassungen für den Airbus Prof. fertigstellt.

Danke für Deine Arbeit !

Gruß Helmut

Now only the assignments for the TCA add-on are missing.
Auto Brake - Airbrakes - Flaps
I hope that the Aerosoft-team will soon finish the corresponding adaptations for the Airbus Prof.
Thanks for your work !
Greetings Helmut

 

Link to comment
Share on other sites

I use P3D5.1 and I have done all the step of this topic and the Thrustmaster calibration procedure   but throttles don't go idle. They remain at Climb detent or directly to Reverse and it's not possible to calibrate throttles using Direct Input.

Where is the problem? 

 

TCA.png

Link to comment
Share on other sites

On 2/9/2021 at 1:52 PM, delc said:

I use P3D5.1 and I have done all the step of this topic and the Thrustmaster calibration procedure   but throttles don't go idle. They remain at Climb detent or directly to Reverse and it's not possible to calibrate throttles using Direct Input.

Where is the problem?

I bought my Airbus Quadrant yesterday and I am having the same issue on v4.5 HF3. Any help will be welcomed.

Link to comment
Share on other sites

18 hours ago, CS-TMT said:

Never mind. Figured it out. I had the virtual buttons disabled and I didn't know they should be enabled.

Where can i find it, i am having the same issue you had. 

 

nevermind mine is enabled and it still doesnt work, Aerosoft a330 updated to the latest version and TCA Quadrant support is enabled.

Link to comment
Share on other sites

My only issue right now is that the reverse thrust not always engages, though it seems to be related to the sim performance (FPS). On an airport with less "heavy" objects with >30fps, no issues at all, reverse always engages. On heavier sceneries or areas (MK Lisbon - my home airport, ORBX Chicago area) with 17-22fps, if I try to engage it while taxiing out it engaged, but after a circuit near the airport, when landing again, it doesn't engage, although the levers on the cockpit sit half way between idle rev and full rev, though the rev unlockers on the cockpit levers stay down 🤔

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
On 2/17/2021 at 1:28 AM, CS-TMT said:

My only issue right now is that the reverse thrust not always engages, though it seems to be related to the sim performance (FPS). On an airport with less "heavy" objects with >30fps, no issues at all, reverse always engages. On heavier sceneries or areas (MK Lisbon - my home airport, ORBX Chicago area) with 17-22fps, if I try to engage it while taxiing out it engaged, but after a circuit near the airport, when landing again, it doesn't engage, although the levers on the cockpit sit half way between idle rev and full rev, though the rev unlockers on the cockpit levers stay down 🤔

Goodday,

 

I have exactly the same behaviour in my sim (P3d/v4.5 with latest HF) as desrcribed above.

Can someone tell me if this is indeed FPS related or can it be something else.......

 

Many thanks for clarification

  • Like 1
Link to comment
Share on other sites

As long as your FPS don't drop below 20fps, you're safe regarding reverse activation. Been doing some flights and have had no issues at all with FPS above 20.

Link to comment
Share on other sites

  • 2 weeks later...

I also had quite a few problems with the correct positions on the throttle quadrant (Aerosoft Busses in P3d v4.5 and v5.1).
I suddenly found out that if you disconnect the quadrant for a moment, disconnect the USB-C plug at the back of the quadrant and reconnect, everything suddenly works as it should ...

It's just a tip ....

 

Good Luck!

 

Hans

Link to comment
Share on other sites

I have followed all the instructions above, however my throttles don't engage with the 'climb' indent or the 'idle' indent and only go to 'idle' if i go to reverse thrust, which means I don't get any reverse thrust. Please can someone advise ?

 

Thanks.

Martin Littlemore

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...

Hi captains:

 

My issue is that after properly assigned all the buttons and only the two axis (throttle 1 and 2) as per the instructions, only the lever for the ENG 2 works. It perfectly match with all detents but only lever two. The ENG Master switches and ING Mode switch also works fine. Any suggestion?? Thanks in advance. 

Link to comment
Share on other sites

  • 2 months later...

 

On 2/17/2021 at 3:28 AM, CS-TMT said:

My only issue right now is that the reverse thrust not always engages, though it seems to be related to the sim performance (FPS). On an airport with less "heavy" objects with >30fps, no issues at all, reverse always engages. On heavier sceneries or areas (MK Lisbon - my home airport, ORBX Chicago area) with 17-22fps, if I try to engage it while taxiing out it engaged, but after a circuit near the airport, when landing again, it doesn't engage, although the levers on the cockpit sit half way between idle rev and full rev, though the rev unlockers on the cockpit levers stay down 🤔

 

Hi, pilots! 

 

I have the same issue with TCA throttle and A320 professional. FPS about 30. It there any solution?

Link to comment
Share on other sites

On 5/3/2021 at 4:12 PM, Roary said:

I have followed all the instructions above, however my throttles don't engage with the 'climb' indent or the 'idle' indent and only go to 'idle' if i go to reverse thrust, which means I don't get any reverse thrust. Please can someone advise ?

 

Thanks.

Martin Littlemore

Have you found any solution? 

Link to comment
Share on other sites

Hi Alex,

 

No, I got it to work briefly and this was more through perseverance and re-doing the stages over and over again, then it all just went back to the previous way with no reverse and the indents all wrong, very frustrating. I actually bought the FS Labs A320X and got the TCA throttles to work no problem, (there is an option within FS Labs A320X to set the indents), I would recommend the FS Labs A320 it is brilliant and works well with the throttles. The Aerosoft Airbus just doesn't work or is very temprimental for some reason

Link to comment
Share on other sites

48 minutes ago, Roary said:

Hi Alex,

 

No, I got it to work briefly and this was more through perseverance and re-doing the stages over and over again, then it all just went back to the previous way with no reverse and the indents all wrong, very frustrating. I actually bought the FS Labs A320X and got the TCA throttles to work no problem, (there is an option within FS Labs A320X to set the indents), I would recommend the FS Labs A320 it is brilliant and works well with the throttles. The Aerosoft Airbus just doesn't work or is very temprimental for some reason

I have similar situation - i have reverse, CL, FLEX and TOGA, but nothing more - when i put thrust to idle, in the aircraft it's positioned to CL.  Very frustrating.   Thanks for recommendation, i'll try FSLabs in case of no solution in few days.

Link to comment
Share on other sites

  • 4 weeks later...

for the brakes and gear I did in key assignments

 

brakes(set parking)   button20

brakes(set parking) buuton 20 on relaese

landing gear (extend/retract         button21

landing gear (extend/retract         button21 on release

its works fine You have only set before start addon AC the levers in the right position it works for every AC in p3d4

I try`d with auto brake  and rudder trim but that wont work .

 

 

  • Thanks 1
Link to comment
Share on other sites

  • Aerosoft

Dear Wildeboer,

 

The rudder trim works, but the button does not visually move.
The readings do however.
Please see the video hereunder. It also show the assignments in the beginning.
 


Best regards.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...