Jump to content

PFPX Performance Very Slow


Recommended Posts

I've had this problem for a long time now but it's just got so irritating now that I wanted to post something to see if there is a resolution.  As far as I can see the application is working (I'm using v2.03) but it's incredibly slow to use, really it's unusable how it is.  For example loading and selecting the Flight tab, my wait time before it's available is over 30 seconds (this is not an exaggeration).  If I click another tab then back to the flight tab, again the wait time is very, very long.  Opening the route database takes well over 1 minute.  Checking (which I remember used to be very quick) on routes in the database now takes on average 1 second per route, again something that I remember this machine wizzing through in the past.  I frequently get the PFPX window greyed out with "Not Responding" showing at the top, this can last over a minute at times, it almost always comes back but it's just making it so difficult to use I'm about ready to give up with it entirely (which I'd rather not do as it has been my planner of choice for a long time).

 

I've tired re-installing, I've tried to install the distribution file in "support files" but Windows (10 Pro fully patched as of today) tells me "Setup Failed" as another version of this product is already installed. 

 

Any ideas on how to sort this out?

 

Thanks

 

Craig

 

Link to comment
Share on other sites

Hello Craig,

 

As version 2.04 was recently released try another clean install.

 

De-activate the license in the configuration/general tab, PFPX will close.

 

Backup your entire C:\Users\Public\Documents\PFPX Data folder.

 

Uninstall PFPX via the Programs link.

 

From Windows control panel locate and uninstall any Microsoft Visual C++ 2015, 2017 and 2015-2019 entries and reboot.

 

Download and install the latest 2015-2019 vcredist available HERE , both x86 and x64

 

Download and install PFPX v2.04 from FlightsimSoft

 

Run PFPX and activate the license.

 

If you need to restore your old data either copy back back that required or delete replace the Data Folder with that you backed up.

 

Depending upon your security software consider excluding PFPX.

Link to comment
Share on other sites

It's hard to tell whether or not the steps taken here have made an improvement or not.  I think I can trace the problem to the size of my fleet (which is probably unusually large).  If I remove all the aircraft performance is fine, even with the extra templates.  If I put them back, performance slows quite a lot.

 

My fleet (quite embarrasingly) is around 1300 separate reg's....

Link to comment
Share on other sites

Unsure at the moment, it's just nice to have all the registrations there, plus you can set things like actual PAX values and so on, giving you a more representative payload.  Simbrief is faster but it doesn't do performance calcualtions for say the 747 all in one, so for me it's less useful and of course less capable.  If something could be done to the code to accelerate this that would be good.  Happy to provide the devs my fleet data to save them the hassle of creating one.

 

I use STKP too, and contribute to that (patreon).  Again fleet management on that with large fleets can be painful. 

 

Cheers

 

Craig

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...