Jump to content

Recommended Posts

So having finally received my new PC, to which I had only added Office 365 and restarted a few times over a period of days checking for updates, I finally installed MSFS Premium from the DVD's.

 

I pointed the installer to an empty folder "MSFS" on the 2TB D drive SSD.  I followed the instructions for downloading content and entering the registration number from the card that came with the box.

 

Starting MSFS from either the windows menu or from within the XBOX app results in a black screen which has a progress symbol spinning in the bottom right corner for a few seconds that disappears.

 

There's lots of suggestions I've seen that relate to the steam and store versions (I'm not even sure what the DVD version is called), but at this point I'm still stuck with a black screen.

 

Fingers crossed someone can help.

 

Thanks.

Link to post
Share on other sites

I have it installed and still get these screens on occasion. For me, I just leave it there and wait for it to do whatever it is doing, eventually it will load. It has been a few minutes sometimes, and other times 10+ minutes. Wish I could offer a better answer, but that is my experience.

Link to post
Share on other sites
20 hours ago, themadgamer said:

I have it installed and still get these screens on occasion. For me, I just leave it there and wait for it to do whatever it is doing, eventually it will load. It has been a few minutes sometimes, and other times 10+ minutes. Wish I could offer a better answer, but that is my experience.

Thanks.  I've tried leaving it for 30 minutes with no joy.

 

Maybe supporting Aerosoft wasn't the smartest thing to do, given the silence.  All the suggested help I've found elsewhere refers to the MS Store or the Steam version, I wonder what the disk version is then?

Link to post
Share on other sites
  • Administrator

Hi,

 

Please also make sure to give the steps in the following guides a try:

https://flightsimulator.zendesk.com/hc/en-us/articles/360015999539

https://flightsimulator.zendesk.com/hc/en-us/articles/360015879160

 

4 hours ago, FighterFlight said:

Another interesting aspect would be where you installed it percisely. It could be that you split up some data on different drivers that would result in problems regarding the acess of specific data to run the program.

This should actually not be an issue with Microsoft Flight Simulator due to how the program works. If you install the physical application that is downloaded from the Microsoft Store to another drive, the simulator will still function, but, you will have to select the folder where the disc content is installed to when reaching the content manager. As such, it is possible to install the application on one drive, and then the simulator data on another.

Link to post
Share on other sites

Thanks for the suggestions, I'll give them a try and post back.

 

With regard to the location question.  The first disk gave me the option to chose and I pointed it to a folder called MSFS (who'd have guessed :-)) on drive D, a new and blank drive.  Entering the key/code at the end of the last disk and allowing MS to then install the rest all seemed to go without a problem.

 

Anyway, I'll post back after following the above tips.  Thanks.

Link to post
Share on other sites
  • 2 weeks later...
On 12/11/2020 at 12:53 PM, Tom A320 said:

Please run the following program and show its results here in this topic.

 

ASVersionInfo_1101.zip 14.75 kB · 4 downloads

Thanks Tom.  Does this help?

 

Hardware
--------
CPU Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz
GPU NVIDIA GeForce RTX 3080 (2560 x 1440 x 4294967296 colors)
GPU Driver 460.79
RAM 32GB @ 3200MHz

Microsoft Windows
-----------------
Windows 10 Post April 2020 (2004) Update / Version 10.0.19042 / 64-bit

User Profile and Document Folders
---------------------------------
User Profile Location:
Environment.GetFolderPath =        C:\Users\paulg
Volatile Environment\USERPROFILE = C:\Users\paulg

Documents Folder:
Environment.GetFolderPath = C:\Users\paulg\OneDrive\Documents
Shell Folders\Personal =    C:\Users\paulg\OneDrive\Documents


Microsoft .NET Framework 1.0 - 4.0
----------------------------------
.NET Framework DF
.NET Framework 4
.NET Framework 4.0

Microsoft .NET Framework 4.5+
-----------------------------
.NET Framework 4.7.2 or later (only latest version is shown)

Microsoft Flight Simulator (2020)
---------------------------------
Microsoft Flight Simulator (Windows Store Edition). Content located at: D:\Flight Simulator

Microsoft Flight Simulator X & Lockheed Martin Prepar3D
-------------------------------------------------------
Prepar3D v5.x (5.1.12.26829) found at: E:\P3D\
Prepar3D v4.x not installed
Prepar3D v3.x not installed
FSX Steam Edition not installed
FSX SP2/Acceleration not installed

X-Plane 10 & 11
---------------
X-Plane 11 not installed

X-Plane 10 not installed

Microsoft XAudio2
-----------------
XAudio2_9.dll found: 10.0.19041.1 (WinBuild.160101.0800)
XAudio2_8.dll found: 10.0.19041.1 (WinBuild.160101.0800)
XAudio2_7.dll found: 9.29 (DXSDK_JUN10.100602-0421)
XAudio2_6.dll found: 9.28 (DXSDK_FEB10.100204-0932)
XAudio2_5.dll found: 9.27 (DXSDK_AUG09.090904-1620)
XAudio2_4.dll found: 9.26 (DXSDK_MAR09.090316-1354)
XAudio2_3.dll found: 9.25 (DXSDK_NOV08.081027-0939)
XAudio2_2.dll found: 9.24 (DXSDK_AUG08.080731-0600)
XAudio2_1.dll found: 9.23 (DXSDK_JUN08.080530-1349)
XAudio2_0.dll found: 9.22 (DXSDK_MAR08.080305-1539)


Simconnect, SDKs and Visual C++ Redistributables
------------------------------------------------
Microsoft Visual C++ 2019 X64 Additional Runtime - 14.24.28127 - (Version Data: 14.24.28127.0)
Microsoft Visual C++ 2019 X64 Minimum Runtime - 14.24.28127 - (Version Data: 14.24.28127.0)
Microsoft Visual C++ 2019 X86 Additional Runtime - 14.24.28127 - (Version Data: 14.24.28127.0)
Microsoft Visual C++ 2019 X86 Minimum Runtime - 14.24.28127 - (Version Data: 14.24.28127.0)
Prepar3D v5 Academic Client - (Version Data: 5.1.12.0)
Prepar3D v5 Content - (Version Data: 5.1.12.0)
Prepar3D v5 Scenery - (Version Data: 5.1.12.0)
 

Link to post
Share on other sites
  • Deputy Sheriffs

Hi Paul,

 

a general comment on the output you sent: your documents folder is linked to OneDrive. This is known to be a root cause for many problems especially regarding flightsim products. Although I'm not sure, whether it is the cause for your problem with MFS, I highly recommend to unlink your documents folder from OneDrive.

 

Am I correct, that the installation itself worked, and the blck screen only appears when you start MFS?

Go to the Microsoft Store and make sure that you install the updates offered for the MFS.

  • Upvote 1
Link to post
Share on other sites

Thanks Otto.  Having uninstalled One Drive, when I run the AS tool, it still says the same thing

 

Windows 10 Post April 2020 (2004) Update / Version 10.0.19042 / 64-bit

User Profile and Document Folders
---------------------------------
User Profile Location:
Environment.GetFolderPath =        C:\Users\paulg
Volatile Environment\USERPROFILE = C:\Users\paulg

Documents Folder:
Environment.GetFolderPath = C:\Users\paulg\OneDrive\Documents
Shell Folders\Personal =    C:\Users\paulg\OneDrive\Documents

 

You're correct, the installation went OK and I've repeatedly checked for updates for everything.

 

The only thing to note could be that I didn't install the DVD's to the default C drive so I wonder if anyone has been able to do this.  I've seen a few comments elsewhere suggesting this should be done regardless, and for the subsequent download to then be directed to the other drive.

 

Cheers. 

Link to post
Share on other sites

Ok, I'm finding this to be a bit of a problem now and really wishing my kids hadn't bought me this at all.

 

In desperation, I've uninstalled MSFS.

 

I then installed from the DVD's to the default C drive and found I couldn't enter the product key as it says it's been used already.  I opened Xbox and it showed as owned and requiring the big download.

 

Now, starting from Xbox and everywhere else I can find MSFS mentioned..........I get the same black screen!

 

In case it helps, opening Task Manager shows MSFS has been running for 18 minutes and is using around 2% of CPU, 18mb of memory and there's no network activity.

 

It's not like I haven't got a bit of experience, but I'm now on the verge of asking how I get this refunded because, well to keep it polite, it doesn't work.  (Note, I very heavily edited my actual thoughts!)

 

 

Link to post
Share on other sites
  • Deputy Sheriffs

No need to completely uninstall OneDrive, just unlink the documents folder.

I myself installed MFS outside drive c without any problem.

And your Microsoft Store app is up to date and doesnt show any available updates?

 

Link to post
Share on other sites

Thanks for your thoughts.  Onedrive is back but now unlinked.

 

I've checked and checked that everything had been updated.

 

Looking in the Microsoft Store, I can see this listed 4 times?  The 2 with the exclamation ! mark then say "This product won't work on this device".  Clicking the "See system requirements" link does nothing.

ms store1.PNG

ms store2.PNG

Link to post
Share on other sites
  • Deputy Sheriffs

Hi Paul, indeed the MS Store is sometimes quite confusing. The exclamation mark and the comment "This product won't work on this device" is simply nonsense. It is shown because you already own the Premium (Deluxe) version. So MS should change this to something like "You own this product already". What happen when you click on "Launch"?

Link to post
Share on other sites
  • Deputy Sheriffs

What makes me wondering, you have more MFS entries under "All owned" then I can see in my store. What do you see when you clich an "Manage" next to MFS premium Deluxe?

Link to post
Share on other sites
  • Deputy Sheriffs
On 1/1/2021 at 10:55 AM, mopperle said:

What makes me wondering, you have more MFS entries under "All owned" then I can see in my store. What do you see when you clich an "Manage" next to MFS premium Deluxe?

Thanks.  I don't see anywhere that I can click that leads to "Manage".

 

Most of the problems I've seen in those links seem to relate to users that have previously been able to use this.  I have never got more than a black screen.  I tried the audio change but just end up with a PC that makes no sounds, as well as getting the MSFS black screen.

 

The one thing I did just read was a suggestion to log out of Xbox and the Store first.  I'll try that later.

Link to post
Share on other sites

OK, so I've also tried logging out of XBox and the Store, rebooting and launching from the desktop; same black screen.

 

I logged back into both and this time paid attention to the install that has the "Managed" button.  This opens this window.....and trying to launch from either of those results in.....yes, the black screen.

 

Screenshot 2021-01-05 151703.jpg

Link to post
Share on other sites

The one thing I did find that looks wrong, is this.  It shows the DVD content as 101GB, which I guess is probably correct.  But the other entry for Microsoft Flight Simulator 1.39GB has to be wrong?

Screenshot 2021-01-05 151457.jpg

Link to post
Share on other sites
  • Deputy Sheriffs
1 hour ago, Paul Golding said:

But the other entry for Microsoft Flight Simulator 1.39GB has to be wrong?

That's correct, I see the same here

What confuses me is the word "Preorder". No idea what it means.

Unfortunately I have no further idea, other then doing a complete uninstall and fresh install of MFS.

Link to post
Share on other sites

As I've already re-installed MSFS, and to the C drive, but it made no difference, I have to assume there's something wrong with Windows.  So, I'm just going to do a full clean install of Windows to ensure there's nothing left on the C drive and then let the various updates happen over a day or 2 and update drivers and Store apps etc.

 

Before installing Office, P3D or anything at all, I'll start with MSFS disk 1 and point it to a formatted clean D drive.

 

Any other thoughts?

Link to post
Share on other sites
  • 1 month later...

OK, I'm back.

 

I have re-installed Windows 10, checked the updates and am logged into the MS Store.

 

At this point, this is a ew PC with nothing on it aside from Windows 10; no added programs, not even Office.  The only thing I've done is to add the English (US) language.

 

I've gone to the MS Store and see this.

 

image.thumb.png.7f57db43f6ded97c113ed7fbd7deeee1.png

 

I've then installed the disks to the default location and back to the MS Store which looks the same and have clicked install, which then gives me the option to launch.

 

After around 15 seconds I see a full size windowed black screen for maybe 10 seconds that then becomes a full black screen i.e the small window border disappears.  I now have a rotating circle in the bottom right corner for 10 seconds and then...absolutely nothing 😞

 

I've restarted a few times and get the same result, no matter how long I leave the black screen showing.

 

It really shouldn't be this hard, should it?

 

I'm hoping someone that's way smarter than me can offer some help.  Please.

 

Below is the result of running the ASVersionInfo.exe

 

Hardware
--------
CPU Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz
GPU NVIDIA GeForce RTX 3080 (2560 x 1440 x 4294967296 colors)
GPU Driver 461.40
RAM 32GB @ 3200MHz

Microsoft Windows
-----------------
Windows 10 Post April 2020 (2004) Update / Version 10.0.19042 / 64-bit

User Profile and Document Folders
---------------------------------
User Profile Location:
Environment.GetFolderPath =        C:\Users\paulg
Volatile Environment\USERPROFILE = C:\Users\paulg

Documents Folder:
Environment.GetFolderPath = C:\Users\paulg\Documents
Shell Folders\Personal =    C:\Users\paulg\Documents


Microsoft .NET Framework 1.0 - 4.0
----------------------------------
.NET Framework DF
.NET Framework 4
.NET Framework 4.0

Microsoft .NET Framework 4.5+
-----------------------------
.NET Framework 4.7.2 or later (only latest version is shown)

Microsoft Flight Simulator (2020)
---------------------------------
Microsoft Flight Simulator (Windows Store Edition). Content located at: C:\Users\paulg\AppData\Local\MSFSPackages

Microsoft Flight Simulator X & Lockheed Martin Prepar3D
-------------------------------------------------------
Prepar3D v4.x not installed
Prepar3D v3.x not installed
FSX Steam Edition not installed
FSX SP2/Acceleration not installed

X-Plane 10 & 11
---------------
X-Plane 11 not installed

X-Plane 10 not installed

Microsoft XAudio2
-----------------
XAudio2_9.dll found: 10.0.19041.320 (WinBuild.160101.0800)
XAudio2_8.dll found: 10.0.19041.1 (WinBuild.160101.0800)
XAudio2_7.dll not found
XAudio2_6.dll not found
XAudio2_5.dll not found
XAudio2_4.dll not found
XAudio2_3.dll not found
XAudio2_2.dll not found
XAudio2_1.dll not found
XAudio2_0.dll not found


Simconnect, SDKs and Visual C++ Redistributables
------------------------------------------------
System.NullReferenceException: Object reference not set to an instance of an object.
   at ASVersionInfo.Mainwindow.GetRedistVersions()

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...