Jump to content

Microjumps of X axis with TCA Sidestick

Recommended Posts

Hey guys,


dont know if this happend to anybody else too but I recognized it also in the Small Busses now.

It did not happen at the beginning of the flight, but on appraoch and landing, the X axis wasnt working anymore.


I've attached a video of it.


I also tried to unplug and replug the Stick, but same result.

Reloading the whole sim solved the issue but the question is, what is causing this cause it is not happening on each flight.


Is that a Bus issue or an Sidestick issue :-S (I hope not that its broken :-S)


(Sorry for the big video, i have no idea how to reduce it...)



Link to post
Share on other sites

Hi Bernd,

I asked from one of our hardware specialists. Could you check the following

- Calibrate the device and display the raw values. They should not be below + 127 / -127 as this would be too low resolution that could introduce glitches.

- Check if the jumps are visible in the calibration utility after calibration

- Try it on simple default aircraft (prop cessna for example)

- Try to change the USB, or even the computer if possible.

- Check that no other controls are assigned to the elevators and ailerons

- If you have controls mapped through FSUIPC, disable those and use the P3D native control settings

- If possible you could also try it on XP11 or any other simulator if it's happening there.

Hopefully these steps help you to troubleshoot the issue. If not, Unfortunately I am out of ideas and unless someone comes up with a miracle solution here I would recommend contacting our support directly.

  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...