Jump to content
ProfessorMadman

Geneva Professional P3Dv5 SODE problem

Recommended Posts

19 hours ago, Andersm said:

Hi guys :) 

I am not completly sure this is the same problem that u are discussing. 
But in the end it is a problem with Geneva and SODE. 

I have all the gates in the airport, but when i try to move them they just move up in the air (see picture).

Everything is up t odate, so i don't really know what is going on ?

Any ideas ? 

 

2020-7-10_21-9-1-594.jpg

Hi Anders!

 

Among other things, this is what we are discussing yes. And no support is communicated as of now so I'm not entirely sure if it's being looked at or not. The almost unique feature of this airport are these old school satellites and being able to taxi from stand. What you can do is disable sode and use ctrl-J, but as those gates don't retract as much as the sode ones, you will wing-clip them on your taxi out. Not something you expect out of a 30€+ single runway, small airport addon developed by one of the biggest scenery developers out there. But still hopeful this is being looked at.

Share this post


Link to post
Share on other sites

We have seen the issue  on one of our machines and it is being checked out.

  • Like 3

Share this post


Link to post
Share on other sites

I also noticed the strange SODE Jetway behavior in Geneva, where the Jetways are moving up in the air, when they are selected via TAB+S.

 

Are there any updates regarding a possible fix?

 

Thanks

Share this post


Link to post
Share on other sites

Any news regarding the fix?

Geneva scenery destroyed my add-ons.cfg in p3d v5.

 

 

Share this post


Link to post
Share on other sites

Here is  a workaround for Geneva:

 

User should first deactivate the SODE jetways via the Geneva configuration tool.

 

After you did so please check if the folder

c:\ProgramData\12bPilot\SODE\LSGG_Jetways\

is deleted completely.

 

Also check the folder

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Scenery

if no AF2*.bgl for SODE is still activated:

AF2_LSGG_SODE.off

AF2_LSGG_SODE_OBJ.off

AF2_LSGG_Static_SODE.off

AF2_LSGG_Static_SODE_OBJ.off

 

Than replace the file

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Sode\SimObjects\LSGG_Jetways\sim.cfg

with the attached sim.cfg

 

Now you can reactivate SODE jetways via the Geneva configuration tool.

 

Share this post


Link to post
Share on other sites
13 hours ago, Airbus_Simmer said:

@Mathijs Kok Thanks for the workaround. It seems like you forgot to attach the mentioned sim.cfg.

 

oops

 

sim.zip

Share this post


Link to post
Share on other sites

@Mathijs Kok I performed the workaround as you described. However, the issue with the turned away SODE Jetways still occures as before.

 

I explicitly checked after performing the steps, that the file at "C:\ProgramData\12bPilot\SODE\SimObjects\LSGG_Jetways\sim.cfg" is the same as that, which you posted above.

Share this post


Link to post
Share on other sites
On 8/6/2020 at 11:33 AM, Mathijs Kok said:

Here is  a workaround for Geneva:

 

User should first deactivate the SODE jetways via the Geneva configuration tool.

 

After you did so please check if the folder

c:\ProgramData\12bPilot\SODE\LSGG_Jetways\

is deleted completely.

 

Also check the folder

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Scenery

if no AF2*.bgl for SODE is still activated:

AF2_LSGG_SODE.off

AF2_LSGG_SODE_OBJ.off

AF2_LSGG_Static_SODE.off

AF2_LSGG_Static_SODE_OBJ.off

 

Than replace the file

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Sode\SimObjects\LSGG_Jetways\sim.cfg

with the attached sim.cfg

 

Now you can reactivate SODE jetways via the Geneva configuration tool.

 

 

Followed the steps and even started and re-started flight simulator in between to no luck.

 

For beginners, I can add that the first instruction to make sure LSGG_Jetways is deleted - points to a faulty link, it should be

C:\ProgramData\12bPilot\SODE\SimObjects\LSGG_Jetways

 

Cheers,

 

Cristian

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello,

 

I checked the workaround posted by Mathijs again and it worked.

 

Deactivate the SODE jetways via the Geneva configuration tool

Check if the folder

c:\ProgramData\12bPilot\SODE\SimObjects\LSGG_Jetways\

is deleted completly

 

Check non of the SODE.bgl in the Sim files is active:

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Sode\SimObjects\LSGG_Jetways\sim.cfg

AF2_LSGG_SODE.off
AF2_LSGG_SODE_OBJ.off
AF2_LSGG_Static_SODE.off
AF2_LSGG_Static_SODE_OBJ.off

 

Restart P3Dv5.

Check that the default Jetways are visible in the scenery.

Exit P3D.

Replace the file

[Your P3D5 Add-ons Folder]\Aerosoft Geneva Professional V5\Sode\SimObjects\LSGG_Jetways\sim.cfg

with the attached sim.cfg

 

Launch the configuration tool again and activate SODE Jetways.

Restart P3D.

You should also ensure that SODE works properly in P3Dv5.

It needs the legacy SimConnect.DLL for FSX-SP2

SODE_SimConnect.thumb.jpg.dc4bbcc1dfe7a1f184d86b40e4fb5977.jpg

 

best regards.

sim.zip

Share this post


Link to post
Share on other sites

Now it works. The sim.cfg that you attached is different than the one that Mathijs attached, which is probably the very reason why the workaround didn't work before.

 

Before:

[General]
Category=Viewer
Module=default

 

After:

[General]
Category=Viewer
Module=SODE

 

Anyway, thanks to both of you! :)

Share this post


Link to post
Share on other sites
On 8/17/2020 at 2:24 PM, Guenter Zehnel said:

It needs the legacy SimConnect.DLL for FSX-SP2

until we install it,  SODE in LSGG will not work correctly ... hopefully in the future it (legacy SimConnect.DLL) won't be required.
we always have a working CTRL-J alternative  anyway.

Share this post


Link to post
Share on other sites

Still have the LSGG SODE Jetway problems both as described by Andersm above and also SODE Jetways not moving using GSX. SODE  is selected in the configuration screen.

 

I have uninstalled and reinstalled a couple of times, and also modified files as described by Guenter Zehnel above - no luck.

 

Simulator: P3D V5 HF2

GSX Level2

Windows 10 2004

Installer: AS_GENF-PROFESSIONAL_P3DV5_V2003.exe

 

Søren

 

Share this post


Link to post
Share on other sites
On 8/30/2020 at 1:36 PM, Søren Rasmussen said:

Still have the LSGG SODE Jetway problems both as described by Andersm above and also SODE Jetways not moving using GSX. SODE  is selected in the configuration screen.

 

I have uninstalled and reinstalled a couple of times, and also modified files as described by Guenter Zehnel above - no luck.

 

Simulator: P3D V5 HF2

GSX Level2

Windows 10 2004

Installer: AS_GENF-PROFESSIONAL_P3DV5_V2003.exe

 

Søren

 

 

Nobody????

Well, solved it the following way:

1) setting Jetways to be non-SODE (Ctrl-J) using the Aerosoft updater and fire up P3D setting the Airport to LSGG and Gate to e.g. 32

2) use GSX function 'Customize Parking Positions' (Menu>Add-Ons>GSX>Customize Parking Positions) and select all gates with Ctrl-J Jetways

3) Check the Jetway Exclude Radius box and leave the radius at 1m

4) Leave P3D and compile the generated exclude file (GSX Control Panel)

5) Fire up P3D again and go to LSGG e.g Gate 32

6) Now you have default GSX SODE Jetways and you can customize them (pr. gate) to the type you like - again using 'Customize Parking Positions' and select the Jetway tab. Change of SODE Jetway type has to be done pr gate

7) Don't use the Aerosoft updater to set SODE Jetways from now on - you'll probably spoil all your work

 

Søren

Share this post


Link to post
Share on other sites

Okay, It seems I am having the same problem with Genf on v5. I wonder if a fix will be provided with the updater or a new version released? I really don't want to do all these workarounds. I would like to have a normal working scenery as it was before.

Share this post


Link to post
Share on other sites
2 hours ago, Sunny Andonov said:

I would like to have a normal working scenery as it was before.

 

I agree with you, but until an update/fix is provided, the workaround above make it usable in the meantime - and it's not that difficult.

 

Søren

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...