Jump to content

AS Megaairport Frankfurt and ORBX


Recommended Posts

Dear fellow simmers,

 

recently I get an out-of-memory issue. When I start the sim, it won't load beyond "Loading auto-generated scenery" at dense airports, such as EDDF and EDDT. Hitting the 71% Loading of the sim, the RAM just runs full and the sim crashes to desktop.

First my specs:

  • AMD Ryzen 3800x
  • 32GB RAM
  • Geforce RTX 2080ti
  • Prepar3D v4.5 on Samsung EVO 970 M2
  • BitDefender AntiVir - Prepar3D-folder excluded
  • Windows 10 pro - System is clean: I only run it for simming. :)
  • Orbx products and AS products.

 

What has been tried so far:

  • I verified the Orbx products with the help of Orbx Central: no change.
  • I tried to deactived further add-on software, but it didn't do any good.
  • I tried to lower the graphic setting: no change.
  • I tried to deactivate Orbx Vectors: no change.
  • I tried to disable all ORBX products: no change.
  • Then, I checked the Windows Event log and came across the terrain.dll. -> Thus, I read the internet, backed-up my terrain.cfg and deleted it in order to have it rebuilt by prepar3d. That worked, so now I'm stuck with a working terrain.cfg which hasn't integrated any Orbx products and a terrain.cfg which has all the needed data but crashes the sim. I give you the two different terrain.cfg on request. Otherwise, the insertion point of ORBX is fine and all the related add-ons are supposed to work with Prepar3D v4.5.

 

Finally, P3D crashed even with Orbx Global Vectors disactivated. Thus, I restarted the system, enabled all Orbx products and deactivated Aerosoft and the system started without any trouble. I am facing similar issues with AS Berlin Tegel.

 

May you help me?

Thanks in advance

Xris

Link to post
Share on other sites

In this forum, I found a hint (see LSGG issue) and tried it. I set the AUTOGEN AND SCENERY DRAW DISTANCE to low. That did the trick. Even medium will CTD. Can you explain that?

Link to post
Share on other sites

There isn't really a detailed error message. P3D just crashes to desktop due to being out of memory. If I turn over the handling of the swap file to windows, the consumption of RAM adds up to 60+ GB and then it crashes to desktop.

Thus, I followed different pieces of advise and figured out that the low settings of AUTOGEN AND SCENERY DRAW DISTANCE do the trick. But, that doesn't seem to be a solution, but a workaround.

 

The only thing I can provide is the event log entry:

Name der fehlerhaften Anwendung: Prepar3D.exe, Version: 4.5.14.34698, Zeitstempel: 0x5e94b5c2
Name des fehlerhaften Moduls: terrain.dll, Version: 4.5.14.34698, Zeitstempel: 0x5e94b52d
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000009673
ID des fehlerhaften Prozesses: 0x3ce0
Startzeit der fehlerhaften Anwendung: 0x01d61b7c78b5b50e
Pfad der fehlerhaften Anwendung: G:\Program Files\Lockheed Martin\Prepar3D v4\Prepar3D.exe
Pfad des fehlerhaften Moduls: G:\Program Files\Lockheed Martin\Prepar3D v4\terrain.dll
Berichtskennung: 1810ad4b-aa30-444c-a9c5-df58f248f25e
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 

Unbenannt.jpg

Link to post
Share on other sites
  • Deputy Sheriffs

Ok, so you are using P3Dv4.5 with HF3. Maybe it got something to do with this. Cant check, as I do not use HF3, so maybe somebody else can jump in here.

Did it work before installing HF3?

Link to post
Share on other sites
  • Deputy Sheriffs
45 minutes ago, unicos said:

In this forum, I found a hint (see LSGG issue) and tried it. I set the AUTOGEN AND SCENERY DRAW DISTANCE to low. That did the trick. Even medium will CTD. Can you explain that?

 

Yep, I can.  In fact, see the following post and  you'll see that this is nothing new:  https://www.avsim.com/forums/topic/550800-terraindll-ctd-in-p3d44/?do=findComment&comment=3976280

 

When you installed P3Dv4.5 HF3, did you delete and reinstall the latest version of Content and Scenery?  If not, please do so as it's possible this will resolve the issue.  If that doesn't resolve the issue, then since it's terrain.dll causing the CTD then it's a 90% possibility that it's caused by ORBX (and it would not be the first time).  I would verify the ORBX installation and library files using  FTX Central  but only after installing the latest P3D Content and Scenery.

 

Additionally, there is room to question system specifications (settings too high for the existing settings, and that can indeed change from one version of the sim to another), so providing system specs would be helpful here.

 

 

 

Link to post
Share on other sites

Dave, thank you very much. Are you referencing to the "Content and Scenery.cfg".

 

My system is built on:

AMD Ryzen 3800x with Noctua :)

32GB RAM 3200Mhz

RTX 2080ti

Samung 970 Evo

clean install of Prepar3d v4.5 - no upgrade

 

anything missing?

 

EDIT: HF- Hotfix... aha... I just downloaded the installer and asume(d) HF3 was integrated, wasn't it?

 

Link to post
Share on other sites
  • Deputy Sheriffs
8 minutes ago, unicos said:

Dave, thank you very much. Are you referencing to the "Content and Scenery.cfg".

 

My system is built on:

AMD Ryzen 3800x with Noctua :)

32GB RAM 3200Mhz

RTX 2080ti

Samung 970 Evo

clean install of Prepar3d v4.5 - no upgrade

 

anything missing?

 

EDIT: HF- Hotfix... aha... I just downloaded the installer and asume(d) HF3 was integrated, wasn't it?

 

 

Actually, I'm talking about the P3D Scenery and Content components.  Today people still try to get away with installing only the P3D Client when they upgrade.  Please install all three P3D components.  If that doesn't resolve things or you have other issues then you may also want to back up your ProgramData\Lockheed Martin\P3Dv4.5\add-on.cfg file and then run the Delete Generating Files from the main P3D folder and restart P3D.

 

System specs look fine to me.

 

If someone can give me a route to fly (one that caused a CTD) I can make an attempt to reproduce this early in the coming week, but I think I already did this and didn't have a CTD, so hopefully the above will solve this. 

  • Upvote 1
Link to post
Share on other sites
  • I had the issue coming in from GCTS (Teneriffa South) to EDDF (Frankfurt) <- CTD approaching RWY 07R (5000') and on the routing ESNQ (Kiruna, Sweden) into EDDT (Berlin Tegel) <- approaching runway 08L(5000'). Beyond that I was unable to load P3D at EDDF (Frankfurt) ... Stand A20 + PMDG 772LR.
  • "Actually, I'm talking about the P3D Scenery and Content components.  Today people still try to get away with installing only the P3D Client when they upgrade.  Please install all three P3D components.  If that doesn't resolve things or you have other issues then you may also want to back up your ProgramData\Lockheed Martin\P3Dv4.5\add-on.cfg file and then run the Delete Generating Files from the main P3D folder and restart P3D." - What does that mean? I installed a vanilla P3D v4.5 without upgrading from e.g. P3D v4.0. I used the installer from P3D page. Did I miss something here?
Link to post
Share on other sites

"then you may also want to back up your ProgramData\Lockheed Martin\P3Dv4.5\add-on.cfg file and then run the Delete Generating Files from the main P3D folder and restart P3D. "

That worked, let's see how it it works having all the add-ons reinstalled.

Link to post
Share on other sites
  • Deputy Sheriffs
51 minutes ago, unicos said:

I had the issue coming in from GCTS (Teneriffa South) to EDDF (Frankfurt) <- CTD approaching RWY 07R (5000') and on the routing ESNQ (Kiruna, Sweden) into EDDT (Berlin Tegel) <- approaching runway 08L(5000'). Beyond that I was unable to load P3D at EDDF (Frankfurt) ... Stand A20 + PMDG 772LR.

 

That pretty well confirms it's the ORBX install causing this, however an ORBX validation, update or reinstall may fix.   You can tell for sure by having ORBX products installed outside the sim and added via the XML method, that way you can easily disable them and fly with default autogen - that will confirm it's ORBX.

 

I'll keep a look out for this occurring as well.

 

Best wishes everyone!

 

Link to post
Share on other sites
  • Administrator

You can make that setting within FTX Central, however please have a look into the manual or ORBX forums to find out the exact way. Keep in mind Aerosoft does not sell any ORBX products.

Link to post
Share on other sites
  • Deputy Sheriffs
5 hours ago, unicos said:

@Dave: May you give me an idea how I use the XML method. Is there a manual or how-to somewhere to be found?

 

Thanks for you help. :)

 

Yeah, in this case Emi is correct.  We don't provide support (how to's) for ORBX products, it's there code and they know it far better than we do.

 

Link to post
Share on other sites

Thank you anyway. I had the same issue arriving at the shores of Canada while flying the NAT. I decided to stop fixing things and instead rolled back a clean backup. Hope that will help. :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...