Jump to content

Es ist soweit, XP11.50b1 (BETA) ist da 😇😇


Flightrookie
 Share

Recommended Posts

Ich habe die Vulkan 1.2 Developer Beta Driver 442.88 installiert und habe damit ca. 5-10 fps mehr. Allerdings gestaltet sich das Laden des Programms sehr langwierig.

Vielleicht werde ich die normalen Treiber noch einmal demnächst ausprobieren.

 

Ich gehe aber mal davon aus, dass es noch viele Optimierungen geben wird, damit das ganze noch besser laufen wird.

 

Link to comment
Share on other sites

Edit: Jetzt auch mit Steam verfügbar.

 

Erster Eindruck.. ewige Ladezeiten auch nach mehrmaligem laden.

Fps Gewinn 2-3

Nach ca. 10-30 Sekunden Crash auf den Desktop ohne Fehlermeldung, letzter Eintrag der log.txt

0:02:58.813 E/GFX/VK: Memory heap 0 has overstepped its budget!
0:02:58.813 E/GFX/VK: Heap usage is 4201451520, heap budget is 3581201612
0:02:58.813 E/GFX/VK: Sitting at 53 deletions, the defragmenter is running!
0:02:58.879 E/GFX/VK: Notifying user that heap 0 has overstepped its budget
0:02:58.879 E/GFX/VK: Heap usage is 4201975808, heap budget is 3581201612

 

Klar Beta, aber der tolle fps Zuwachs scheint an mir vorbei zu gehen.

Wie User des Xplane Forums auf teils bis zu 50 fps mehr kommen ist mir rätselhaft, vll. soll man auch nicht alles glauben was so geschrieben wird ;)

Link to comment
Share on other sites

Den höchsten fps Zuwachs scheinen wohl Benutzer mit AMD Prozessoren zu verzeichnen.

Vram scheint wichtiger den je und die Ram Auslastung scheint niedriger zu sein.

Mit meiner "lächerlichen" 1050Ti mit 4GB Vram geht jedenfalls nichts in der Beta.

Die 30 Sekunden die ich etwa bis zum Crash habe wirkt aber trotz des nur minimalen fps Gewinns (wie gesagt, etwa 2-3) alles flüssiger weil keine Nachladeruckler mehr vorhanden sind.

Bringt allerdings nichts wenn Xplane sich dann verabschiedet weil die Vram nicht ausreichend sind.

 

Im übrigen sind die Bodentexturen total verwaschen, egal wie hoch man die Textur Settings stellt.

Man könnte ganz laienhaft gesprochen meinen mit Vulkan wird einfach die Texturqualität niedrig gehalten dafür aber alles in den Vram gepresst, es wirkt ein wenig wie eine Mogelpackung.

 

Damals wurde doch seitens Xplane erzählt das einer der Vorteile von Vulkan sein soll das vorallem ältere PCs besser laufen sollen, so wie ich das feedback aus dem Xplane Forum interpretiere scheinen aber vorallem ansich schon schnelle PCs und PCs mit AMD Prozessoren besser zu laufen, wer an sich schon leistungstechnisch grenzwertig in Xplane unterwegs war, scheint Vulkan entweder garnicht oder nur ohne Vorteil (in Sachen Texturqualität sogar nachteilig) nutzen zu können.

Vielleicht liegts aber wirklich an der Beta und kann noch deutlich optimiert werden, aber der Ersteindruck ist gegenüber den Erwartungen die man mit einem älteren PC hatte erstmal katastrophal.

Link to comment
Share on other sites

  • Deputy Sheriffs
Vor 1 Stunde, Micha82 sagte:

Den höchsten fps Zuwachs scheinen wohl Benutzer mit AMD Prozessoren zu verzeichnen.

Kann ich bestätigen (8700K, 1080Ti, 64GB RAM), getestet mit Vulkan 1.1 und 1.2: 

 

Die CPU ist nach wie vor der Flaschenhals, die GPU (hab ne GTX 1080 Ti) langweilt sich:

image.png

 

Ladezeit länger, RAM-Auslastung viel weniger, VRAM (11GB) ist voll, fps sind gleich, evtl. etwas flüssiger, auch das Nachladen 

 

Link to comment
Share on other sites

Wenn ich die Texturen auf minimum und die Anzahl der Objekte auf niedrig stelle habe ich keinen crash, dann sieht die Welt aber echt hässlich aus, vielleicht hilft das bei dir auch wenn dus mal testen willst.

Witzig ist das ich dann trotzdem nur 35 fps habe, mit OpenGL und Version 11.41 hätte ich mit dieser Einstellung vermutlich um die 60+fps.

Mit der Anzahl der Objekte auf Maximum und Texturqualität Hoch hatte ich vorher (11.41 OpenGL) ca. 30 fps und in extremen Situationen immerhin >20, mit Vulkan ca. 32 fps allerdings sind die Bodentexturen und viele Dinge (Kontrolleuchten / Sitze / Schalter etc. in der Zibo) extrem schlecht und wie oben schon beschrieben schließt sich Xplane dann sowieso ohne Fehlermeldung.

Link to comment
Share on other sites

Ich habe den neusten Nvidia Treiber installiert. Meine Karte taucht in den fähigen Karten auf. Habe vorsichtshalber alle Plugins deaktiviert, Standartmaschine von XP gewählt. Nach dem Aktivieren von Vulkan habe ich XP neu gestartet. Alle Fenster bleiben daraufhin schwarz. Da ich weiß welche Buttons im ersten Auswahlfenster kommen, die Maus dort hin und blind angeklickt. Spiel startet, aber immer noch alles schwarz und stürzt dann ab. Nach Neustart von XP teilt er mir mit das nicht die passenden Treiber vorhanden sind und er wieder zu open GL zurück kehrt. Puh, was kann ich jetzt noch machen? Aktueller Treiber 445.75. Nvidia/ CPU Intel

Link to comment
Share on other sites

Ich konnte bei mir eine große Verbesserung feststellen. (6700k, GTX1080, 64GB Ram) Ich war bislang immer CPU limitiert. Unter Vulkan hat sich bei mir vieles in den Arbeitsbereich der GTX 1080 (Standard, kein TI) verschoben. Die Grafikkarte ist nun in der Regel der limitierende Faktor und zeigt eine deutlich höhere Auslastung als zuvor.

Somit habe ich überwiegend einen spürbaren fps Zuwachs. Nur in großen Ballungsgebieten mit sehr viel X-Europe Gebäuden, wird wieder (wie gewohnt) die CPU zum limitierenden Faktor. Dies aber dennoch mit leicht besseren FPS als zuvor.

 

Ich muss aber dazu sagen, dass ich noch immer (auch unter Vulkan) die Settings.txt derart verändere, so dass ich keine "extended DSF" nutze und auch nur einen 1920x1080 Bildschirm betreibe. Aber seit dem ich die Beta teste, war ich zu 95% der Zeit tatsächlich im Bildschirmlimit von 60 fps (adaptive Einstellung in den Nvidia Optionen).

Link to comment
Share on other sites

Mit Vulkan habe ich einen Gewinn von 10-15 FPS (RTX2070, 7700, 32GB). Über Köln mit Günthers Szenerie und Ortho4xp+EuropeX dümpelte das immer unter 20 FPS rum. Jetzt bleibt es fast konstant auf 35 FPS. Allerdings mit den verwaschenen Texturen und Reshade funktioniert nicht mehr. Ich hab die Beta nochmal zurückgespielt, um zu überprüfen, ob der FPS-Schub an den verwaschenen Texturen liegt. Das scheint nicht der Fall. Auch ohne Vulkan hat die Einstellung der Texturen bei mir kaum Einfluss auf die FPS.

Bei mir läuft der Beta-Flusi jetzt nur noch mit Vulkan. Ist Vulkan deaktiviert, stürzt X-Plane kurz nach Start ab.

Link to comment
Share on other sites

Mit Orthos und X-Eu, 7 Iterationen des Flightmodels per Frame und üppiger Graphikeinstellung hatte ich bisher 25-35 FPS,

mit Ryzen 3950X, einer 1080TI und 64GByte RAM und einer Bildschirmauflösung von 1920X1200.

 

Micro Stutters gab es viele, und das Nachladen von Orthos dauerte manchmal gefühlt eine Ewigkeit (20 Sekunden?).

 

Mit der neuen Betaversion 11.50b1 hat sich das deutlich geändert.

 

Auch wenn das Rendering nocht nicht multicore ist und hier Optimierungen noch ausstehen, hat sich die Framerate trotzdem auf über 40FPS verbessert 🙂

Das Micro-Ruckeln ist ganz weg, das Nachladen von Orthos dauert "nur" noch 1-2 Sekunden, der weiche Flugverlauf begeistert.

Nach wie vor ist für die Framerate die CPU der Flaschenhals, allerdings hat sich das Verhältnis CPU/GPU deutlich verbessert.

 

Laut veröffentlichten Infos wurden alle (die meisten?) der Abläufe, die für das Ruckeln verantwotlich waren, auf separate Kerne verlegt.

Als Ergebnis zeigt sich bei mir während des Fluges eine CPU Auslastung von ca. 17% (2-3 Kerne).

 

Zwischendurch steigt die Belastung immer wieder für kurze Zeit auf über 70% (11-12 Kerne). Das sind wohl die Momente, in welchen die Antiruckel-Maßnahmen greifen. 🙂

Während des Startes des Programmes ist die CPU teilweise zu 100% beschäftigt.

 

Fazit:

Ich bin begeistert. Soviel Verbesserung habe ich für die Beta1 Version nicht erwartet.

Ein neuer Simulator, in das in einem kostenlosen Update!

Danke.

 

Gruß

Günther

Link to comment
Share on other sites

Für meinen vier Jahre alten PC (NVidia 1070) ist das Update ein wahrer Jungbrunnen. Standardcessna und Standardszenerie (EDWG) vorher 40 - 60 fps, jetzt 90 - 110 fps und wesentlich schnellere Ladezeiten.

freundliche Grüße

Gerold

XPlane.thumb.jpg.ccfaaf678278a292b6f674aea03d6f8b.jpg

Link to comment
Share on other sites

vor 2 Stunden , Micha82 sagte:

.... vielleicht hilft das bei dir auch wenn dus mal testen willst.....

danke für den Tip, inzwischen läuft es auch bei mir, sogar mit Vulcan, nachdem ich sämliche AddOns rausgeworfen und den ShaderCache gelöscht habe. Jetzt, wieder mit sämtlichen AddOns, läuft's. Der musste sich wohl erst an mein System gewöhnen.....

 

Berichtigung: Liegt am Flughafen (SBBE), da kackt er immer ab... das sieht nach viel Arbeit aus...

Link to comment
Share on other sites

Ich gebe jetzt auch mal meinen Senf dazu. 

Ich hab nen relativ schlechtes System: 

GTX 1060 6gb; i5 7500; 8gb Ram

Vor dem Update mit der Cessna über Berlin mit Orthos und X-Europe 35-40 Fps. Jetzt 50-65 Fps.

Klar, es gibt noch echt viele Fehler, Texturen, Schatten etc. aber bei diesem Performance Boost ist das zu verschmerzen. :)))

 

Link to comment
Share on other sites

vor 4 Stunden , Malthek sagte:

Mit Vulkan habe ich einen Gewinn von 10-15 FPS (RTX2070, 7700, 32GB). Über Köln mit Günthers Szenerie und Ortho4xp+EuropeX dümpelte das immer unter 20 FPS rum. Jetzt bleibt es fast konstant auf 35 FPS. Allerdings mit den verwaschenen Texturen und Reshade funktioniert nicht mehr. Ich hab die Beta nochmal zurückgespielt, um zu überprüfen, ob der FPS-Schub an den verwaschenen Texturen liegt. Das scheint nicht der Fall. Auch ohne Vulkan hat die Einstellung der Texturen bei mir kaum Einfluss auf die FPS.

Bei mir läuft der Beta-Flusi jetzt nur noch mit Vulkan. Ist Vulkan deaktiviert, stürzt X-Plane kurz nach Start ab.

 

Ergänzung: Jetzt habe ich plötzlich Eingabeverzögerungen von etwa 1 Sekunde. Egal ob über Tastatur, Maus oder Joystick. Das Phänomen zeigt sich in der Nähe der Start- oder Landebahn. Nach dem Abheben oder an einer Ramp ist es weg. Im Anflug wieder da.

Link to comment
Share on other sites

Die habe ich jetzt auch festgestellt, alleine das bewegen der Sicht hin und her hat eine starke Verzögerung mit Vulkan und genau wie du sagtest, nur am Airport. 

 

Zusätzlich konnte ich jetzt feststellen das ich keinen crash mehr habe wenn ich z.B. die REP C172 lade, mit der Zibo hatte ich maximal 30 Sekunden ohne crash.

Ich bin zurück auf die Version 11.41 und habe die fps verglichen.

Mit OpenGL (11.41) habe ich mit der C172 (REP) 53 fps im cockpit und 26 fps in freier Sicht auf etwa 500 Meter höhe und Blick Richtung "am meisten fps fressende Sicht".

Danach habe ich wieder die 11.50 b1 installiert, im Cockpit hatte ich 42fps (also 11fps weniger) und in freier SIcht wie o.g. auf die fps schwächste Stelle aber plötzlich 35 fps also etwa 9 fps mehr.

 

Mit der REP C172 hatte ich auch nichtmehr das Problem das die Bodentexturen plötzlich völlig verwaschen sind, hier schien alles wie vorher (Vorher mit Vulkan + Zibo waren die Texturen (egal was eingestellt war) extrem verwaschen, vorallem direkt unter der Position der eigenen Sicht).

 

Hatte dann einen kurzen Flug und wie ich oben schon sagte waren die Eingabeverzögerungen (wie auch Malthek beschrieb) plötzlich weg, am Boden auf der Startbahn kamen mir die 42 fps aber wie 10 oder so vor, jede Sichtänderung hatte eine deutliche Verzögerung.

Weiß im Moment nicht was ich von dem ganzen halten soll.. mit der Zibo funktioniert mit Vulkan auf meinem PC aktuell nichts richtig, mit einem vergleichsweiße wenig performance hungrigen Flieger wie der C172 läuft schon vieles besser aber eben auch nicht perfekt.

Link to comment
Share on other sites

Interessantes Video, danke dafür.

 

Stellt sich mir nur die Frage ob wir uns jetzt alle Grafikkarten mit 11GB Vram und mehr kaufen müssen?

Im Xplane Forum sind schon etliche Beiträge das Xplane sich mit 8GB Vram verabschiedet und auch hier wurde ja schon geschrieben das sogar die 11GB bei einigen direkt voll sind.

 

Es scheint aber stark auf die verwendeten FLugzeuge anzukommen, je performancehungriger desto schwieriger wird das ganze mit dem Vram.

Hatte vor kurzem noch meine RAM von 16 auf 32 gig erhöht, hätte ich mal lieber in eine Grafikkarte mit mehr Vram investiert..

 

Was ich aber gut finde ist das AMD Prozessoren jetzt gleichermaßen für XPlane taugen, man "musste" ja schon fast einen Intel haben vorher.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...