Jump to content

Recommended Posts

after using the new installer, I tried to install the liveries, that I had used b4 with the SIM.
I cannot install any and I am not talking many different liveries and only ones, that had worked.

I get the result shown in the pic.

 

Now I am probably doing something wrong with the "very clever, very simple livery installer".

Can anyone tell me what I am doing wrong?

20200503_LiveryInstaller.JPG

Link to post
Share on other sites
  • Replies 98
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Perhaps it would be wise to create instructions for this livery manager.  It may be a very clever liver manager once you stumble through this thread, but just telling people to download the manager an

I fixed it.   LivInst_2000.7z   Version 2.0.0.0 - Bumped to version 2.0.0.0 to avoid confusion with old LiveryManager - Fixed an issue where the ATC flight number wouldn't be s

I'm sure the tool is really simple and looks user friendly.  But if every repainter and every user has to install manually all their old repaints, its not really that simple then.  Instead of somethin

Posted Images

You either have to install manually or add the file 'LiveryInstaller.txt' to your zip file - both described in this thread just above your post...

 

But I do have another finding:

 

I do 'package' a manual installed livery, delete the original one and insert (by 'drag and drop') the new packed one - everything is fine in the livery installer as well as p3D (4.5 HF2). Now the aircraft.cfg file in the SimObjects\Airplanes\... folder looks different

- the new entry is at the end of the file

- there is a new line 'atc_parking'

- the lines 'atc_parking_types' and 'atc_parking_codes' are missing

 

Note that the LiverInstaller.txt file does contain these lines... Since these are txt files I can easily 'correct' this, but is this intended behahiour or is this a bug ?

 

Best regards,

Tom

  • Like 1
Link to post
Share on other sites
On ‎4‎/‎20‎/‎2020 at 8:42 AM, Tom A320 said:

No, instead of using the new "Livery Installer" you can still use the old "Livery Manager".

 

You can not anymore, as the old livery manager is gone after re-installing v1.3.1.0 of the busses. What can I do now to have my 10-12 liverys stored on my pc in .zip files running in the novel version again? I guess for me, the only option is to install them manually, no? Writing a .txt myself and including it into the .zip file would not really save me time, I guess.

Link to post
Share on other sites
  • 2 weeks later...

I just installed the A330 v1.0.1. That created a shortcut to the Aerosoft Livery manager but if I try and open it I get an unhandled exception error. If I choose continue it shows the livery manager but with no installed liveries. Error details attached. This seems to be related the installer adding files to an incorrect Documents folder. My Documents folder is on Drive D, but the AS installer is creating a folder on the default drive C. The installer created a folder named:

 

D:\Users\Kevin\Documents\Aerosoft\LiveryInstaller

 

but put nothing inside it, however it also created this folder

 

C:\Users\Kevin\Documents\Aerosoft\LiveryInstaller

 

and put the contents there. If I manually copy the files from C drive to the correct location on D and edit the shortcut accordingly the Livery Manager opens and finds my A330 and CRJ aircraft and liveries.

 

It seems the installer finds the correct Documents folder to install things (including the A330 itself) but for a few things it decides it can't find it and creates another folder in the default location. The installer for A330 v1.0.0.8 put everything in the correct place, as did the installer for the CRJ.

unhandled exception details.txt

Link to post
Share on other sites

To be honest this is a bit of a joke really, how there is no easy way to get back any the liveries we have built up unless the original painter republishes the livery with the missing file. 

 

I am not someone who is confident or familiar with manual process and instructions on how to do this are confusing and conflicting from lots of different people.

 

How I can get the old livery installer back now ive updated to new version? Is there not a quicker way to get the liveries back for those who are less tech savvy?

  • Like 1
Link to post
Share on other sites
On 5/4/2020 at 1:07 PM, Querer said:

 

You can not anymore, as the old livery manager is gone after re-installing v1.3.1.0 of the busses. What can I do now to have my 10-12 liverys stored on my pc in .zip files running in the novel version again? I guess for me, the only option is to install them manually, no? Writing a .txt myself and including it into the .zip file would not really save me time, I guess.


Doing it manually is a one time action. Then you can create the install packages with the new one for future setups. And with ~12 livery not so bad.

 

But attached link to the old managers.

6 minutes ago, dan747fan said:

To be honest this is a bit of a joke really, how there is no easy way to get back any the liveries we have built up unless the original painter republishes the livery with the missing file. 

 

I am not someone who is confident or familiar with manual process and instructions on how to do this are confusing and conflicting from lots of different people.

 

How I can get the old livery installer back now ive updated to new version? Is there not a quicker way to get the liveries back for those who are less tech savvy?

Have you ever looked into the forum?

Here is the link to the old ones. Install with them. Use the new one to create packages for future setups.

 

Link to post
Share on other sites
  • 2 weeks later...

Hi,

I have to admit that I was struggling too much with the new Livery Installer when it was published for the first time. Luckily Hans Hartmann published the updated version of the installer on page 2 of this post and another good friend of mine point me there. Now the subject is sorted for me successfully.

In regards to all this, there are at least 2 more things, which I would like to mention:

- there are unfortunately some third party liveries, which are not working properly with P3D v4.5 and especially with v5. Like it or not, we have to accept it and be careful when using them. These are normally very old liveries created several years ago when the requirements of the SIM were different;

- Our colleague Chucks1860 had posted a short manual on page 3 how a proper zip livery packet can be created with a combined method. There is no need of very deep computer knowledge to follow it, but the most important is to follow it strictly and do not jump over any of the steps he mentioned;

That is all and I sincerely hope that it will be not a big deal to follow the updated procedure.

Happy landings!

 

 

  • Like 1
Link to post
Share on other sites

I'm using AS_A320-A321-PROFESSIONAL_P3DV4_V1310 and Prepar3D_v4_Professional_4.5.14.34698

 

I  dragged Air Canada C-FXCD Airbus A320 CFM 1.0.0 By gustavoaguiar onto Livery Installer 2.1.0 and got this error message.

 

aclivery1.thumb.png.81c8421e000edb1f3489efe95a7d3000.png

 

Then I unpacked the file and started a manual install. I added the cfg file update and incremented it by one FLT, and saved the amended cfg file. (I'm using Notepad ++, not Notepad, so the file was saved as a cfg, not a txt.)

 

[FLTSIM.7]
title                    = Airbus A320 Air Canada C-FXCD
sim                    = A320
model                    =
panel                    =
sound                    =
texture                    = ACA_CFXCD
kb_checklists                = AirbusA321_check
kb_reference                = AirbusA321_ref
atc_id                    = C-FXCD
atc_airline                = AIR CANADA
atc_flight_number            = 3201
ui_manufacturer                = Airbus
ui_type                    = A320-214 CFM 
ui_variation                = Air Canada C-FXCD
ui_typerole                = Commercial Airliner
ui_createdby                = Aerosoft
atc_parking_types            = GATE 
atc_parking_codes            = TAM
description                = Airbus A320 - 214 CFM / Air Canada C-FXCD \nwww.aerosoft.com \nRepaint by Gustavo Aguiar (www.texturasbrasileiras.com)

 

aclivery2.thumb.png.17e8a3454a80c3f6b4e5522cd4b4f9b1.png

 

Then, I copied the Texture.ACA_CFXCD folder to D:\Prepar3D v4 Add-ons\Aerosoft Airbus\Aerosoft A320-A321 Professional\SimObjects\Airplanes\Aerosoft A320 CFM Professional and it now appears in the livery installer. As expected, no preview in P3DV4.

 

aclivery3.thumb.png.88cc60c21beccbc6469cf12fb0fa4018.png

 

So, I went back to the Livery Installer, selected Air Canada C-FXCD and packaged the selected livery, resulting in Airbus A320 Air Canada C-FXCD.zip. Then, back in Livery Installer, I again selected Air Canada C-FXCD and removed the selected livery.

 

aclivery4.thumb.png.e4601eb1885eee99c5523386af9d8b00.png

 

Then, I dragged the newly created zip file on the Livery Installer, and got a message that the livery had been installed and it was once again showing in the Livery Installer.

 

aclivery5.thumb.png.3a2e00ea00c5b031466dafe97bab9d94.png

 

I rebooted P3DV4 and the livery preview still does not show up. When I select the livery, the plane does not show up and I cannot change my views.

 

aclivery6.thumb.png.d53beb0627a7ce006f45862cbefff6f6.png

 

aclivery7.thumb.png.4ef27b5bf4e9fa2584c20e4753cdbf74.png

 

I went through this manual install, package, remove, reinstall new zip file for several liveries; some have since stopped working.

Can anyone advise what I'm doing wrong?

 

I'll say this again: Aerosoft, delete every P3D Airbus livery file and let the painters upload packaged versions that work with the Livery Installer.

 

I should have been halfway across North America now but I've been trying to get these liveries working; this has totally put me off simming for the day, if not the week.

Link to post
Share on other sites

Hi,

Can you please check several things:

- Please open your Texture.ACA_CFXCD folder and check if you have a file named texture.cfg in it?

- Check the content of subject file. It should contain the following 3 lines only: 

[fltsim]
fallback.1=..\..\Aerosoft A320-A321 Professional Base\Tex_FB_VC
fallback.2=..\..\Aerosoft A320-A321 Professional Base\Tex_FB_A320

- is there a file called thumbnail.jpg, which is your thumbnail picture of the AC? It should be located in the same folder Texture.ACA_CFXCD.

- I would modify the corresponding part in aircraft.cfg file to be as follows:

[FLTSIM.7]
title                    = Airbus A320 Air Canada C-FXCD
sim                    = A320
model                 = CFM
panel                    =
sound                    =
texture                    = ACA_CFXCD
kb_checklists                = 
kb_reference                = 
atc_id                    = C-FXCD
atc_airline                = AIR CANADA
atc_flight_number            = 
ui_manufacturer                = Airbus
ui_type                    = A320-214 CFM 
ui_variation                = Air Canada C-FXCD
ui_typerole                = Commercial Airliner
ui_createdby                = Aerosoft
atc_parking_types            = GATE 
atc_parking_codes            = TAM
description                = Aerosoft A320 professional CFM / Air Canada C-FXCD \n www.aerosoft.com \n Repaint by Gustavo Aguiar (www.texturasbrasileiras.com)

 

Hope the above helps.

Link to post
Share on other sites
15 hours ago, Goshob said:

- Please open your Texture.ACA_CFXCD folder and check if you have a file named texture.cfg in it?

- Check the content of subject file. It should contain the following 3 lines only: 

[fltsim]
fallback.1=..\..\Aerosoft A320-A321 Professional Base\Tex_FB_VC
fallback.2=..\..\Aerosoft A320-A321 Professional Base\Tex_FB_A320

 

My texture config had five lines:

[fltsim]
fallback.1=..\..\Aerosoft Airbus A320_A321 Base\Texture_Fallback_VC
fallback.2=..\..\Aerosoft Airbus A320_A321 Base\Texture_Fallback_A320
fallback.3=..\..\..\..\Scenery\Global\texture
fallback.4=..\..\..\..\..\..\Scenery\Global\texture

 

So, I replaced my five-line file with your three-line file.

 

15 hours ago, Goshob said:

- is there a file called thumbnail.jpg, which is your thumbnail picture of the AC? It should be located in the same folder Texture.ACA_CFXCD.

 

Yes.

 

Then, I modified the config file for FLTSIM.7 as you suggested.

 

Result: Plane loaded with black flight deck panels. I loaded another repaint that I used recently and that loaded fine, all panels visible.

 

Implemented new solution, that works for me: Uninstall A318/319, A320/321 and A330, and their associated utilities; fly PMDG737 and QualityWings787 Boeings instead.

 

I'll watch for Simmarket update notices to see if Aerosoft rectifies this livery installation boondoggle.

Link to post
Share on other sites

Hi,

With absolutely no bad feelings to the dialog above, I would like to mention several things and close the subject for me:

- it is a very well established democratic principal that people can do with their money whatever they want;

- there is a very good post https://forum.aerosoft.com/index.php?/topic/132486-optimizing-liveries-for-64-bit-verision/ from Mathijs Kok where he clearly describes what to be done with the old liveries. The second post in the same topic is linking to the instructions given by Aerosoft''s livery "guru" what and how to be done;

- having in mind that the Air Canada C-FXCD livery was published in 2018, it can be considered as a relatively old. Like it or not, it should have some modifications to be made compatible with the aircraft, which works under P3D v4.5. Moreover, I am not quite sure if it was made for the pro or 32 bit version of the Airbus;

- it took me no more than 5 min to modify the content of the file, keeping all the above in mind and make stated livery working with the latest version of the aircraft. With my full respect to the author of the livery who pretended to have copyright on it, I am not publishing the modifications.

Hope the above may help.

Wishing happy landings to all!

 

Link to post
Share on other sites

Net. Framework error .

I just installed the new A320 pro for P#D v5 and I tried to run the livery manager I get a net framework error and no aircraft show up.
This is a fresh clean install of the A320 pro .

Heres the details of the net framework.

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at Livery_Installer.MainWindow.cbxSim_SelectedIndexChanged(Object sender, EventArgs e)
   at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
   at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
   at Livery_Installer.MainWindow.MainWindow_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4180.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Livery Installer
    Assembly Version: 2.1.0.0
    Win32 Version: 2.1.0.0
    CodeBase: file:///C:/Users/t_han/Documents/Aerosoft/LiveryInstaller/Livery%20Installer.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4180.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


 

Link to post
Share on other sites

Hi, 

I'm another one with the .NET Unhanded Exception error. I have the latest v2.1.0.0 as packaged with the latest V5 installer.  
I'm running the latest Windows 10 build (2004) which might possibly be part of the issue - it only seems in the last few weeks people have begun to see this?
I have just built a new PC for P3D v5 so this is the first install of the new livery manager for me - so I don't have anything to benchmark against previously on earlier version of Windows 10.

Installation has been run (twice) with AV disabled and with administrator rights.
Running the livery manager both with and without admin rights yields the same result.
My Documents folder is in the default C:\users\xxx\documents location and the Aerosoft folder and sub-folders appear correct.

 

image.png.c38ecdd5242541908e07bf2ce9590263.png

 

log details also attached.

Thanks,

Mike

livery mgr unhandled exception.txt

Link to post
Share on other sites
10 minutes ago, mtjones83 said:

Hi, 

I'm another one with the .NET Unhanded Exception error. I have the latest v2.1.0.0 as packaged with the latest V5 installer.  
I'm running the latest Windows 10 build (2004) which might possibly be part of the issue - it only seems in the last few weeks people have begun to see this?
I have just built a new PC for P3D v5 so this is the first install of the new livery manager for me - so I don't have anything to benchmark against previously on earlier version of Windows 10.

Installation has been run (twice) with AV disabled and with administrator rights.
Running the livery manager both with and without admin rights yields the same result.
My Documents folder is in the default C:\users\xxx\documents location and the Aerosoft folder and sub-folders appear correct.

 

image.png.c38ecdd5242541908e07bf2ce9590263.png

 

log details also attached.

Thanks,

Mike

livery mgr unhandled exception.txt 3.81 kB · 0 downloads

What happens if you add an exclusion of the livery manager folder to your AV?

Link to post
Share on other sites
On 6/12/2020 at 9:40 AM, masterhawk said:

What happens if you add an exclusion of the livery manager folder to your AV?


Hi,

 

The exception doesn't improve things unfortunately! 😞

livery installer exception.PNG

Link to post
Share on other sites
  • 4 weeks later...

I wanted to update my post to share that I was able to run the latest Livery Manager in Win 10 2004.

I uninstalled the buses. Restarted the computer. I went ahead and downloaded and installed each of the Microsoft Visual C++ Libraries found here.

Restarted the PC .

Installed the buses with AV off and restarted once again.

Everything is working fine now.

Hope it helps.

 

Cheers.

Ed

  • Upvote 1
Link to post
Share on other sites
  • 2 months later...

I have converted all of my repaints for use/install with the new Livery Manager (V2.0).  Is there a chance the site administrators could create a new section/subform in the downloads section specifically for repaints using the new Livery Manager?  This way we can have separation from legacy livery manager repaints without requiring a complete search throughout the original threads or excessive workload for the site admins.   

 

Secondly, I converted a bunch of my favorite repaints, originally created for the Airbus Extended by Holgi for use with Livery Manager 2.0.  Would it be ethical for me to release these repaints in the above mentioned section provided credit was given to the original author?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...