Support overload. We are currently seeing 65% more demand for support then we normally see. We can only assume this is because more people are at home due to the corona crises. Our complete support staff is online and they are working flat out, but it will take some days before we can scale up resources. Please be patient.

Jump to content
juewittermqgmx.net

P3D V4 Schubhebel funktioniert nicht

Recommended Posts

Nach Umstieg auf P3D V4 funktioniert der Schubhebel des Joystick Black Widow XE nicht.  Eine Neukalibrierung im Gamecontroller unter Windows brachte bisher keinen Erfolg. Im P3D wird das Gerät angezeigt. Im Menue Controls-Calibration-Calibrate Device ist er unter Z Axis in Funktion (Schubhebel auf aus (unten) wird der Wert 255 (rechts) angezeigt, bei vollem Schub (Hebel oben) geht der angezeigte Wert auf 0 (links). Nach Starten eines Fluges sind alle Tasten und die Joystickfunktion vorhanden. Nur der Schubhebel zeigt keine Reaktion. Wer kann helfen.

Share this post


Link to post
Share on other sites

Die Werte, die der Schubhebel bringen muss

0 = Vollgas  (bei Dir ok)

16383 = Leerlauf (bei Dir 255 ist falsch)

 

gehe nochmals unter Windows Kalibrierung mit Raw Data anzeigen. Diese obigen Werte muss der Joystick für die Z Achse bringen. Eventuell  auch ein Reset (auf Standard zurücksetzen) auslösen. Der Status vom Joystick muss auch auf OK stehen. 

 

Ahoj

-Uwe

 

 

 

Share this post


Link to post
Share on other sites

Ich habe die Werte zurückgesetzt und neu kalibriert. Der Raw Wert bewegt sich nur zwischen 0 und 255. Nach dem Laden eines neuen Treibers V5.1 ist ein kalibrieren nicht vorgesehen. Im Gamecontroller erscheint jetzt der Name des Gerätes  "BLACK WIDOW XE Flight Stick". Der Status ist weiterhin OK. Im P3D erscheint nach wie vor der Name USB Game Controller. Gerät wird erkant und bewegt sich im Wertebereich -128 oben und 127 unten. Auch der Wechsel eines USB-Anschlusses führt nicht zum Erfolg. Der Schubhebel erfüllt nicht seine Funktion.

Gruß

Jürgen

Share this post


Link to post
Share on other sites

 Ich verschieb das mal ins allgemeine Forum, da nicht Flugzeug spezifisch. Deinstalliere den Treiber mal komplett. Ich habe in der Vergangenheit mit diesen Treibern nie gute Erfahrungen gemacht. Alle nötigen Konfigurationen können im Sim direkt gemacht werden.

Wenn das nicht hilft, wende dich mal an den Hersteller.

Share this post


Link to post
Share on other sites

Nun ja, einen hätte ich noch im Köcher.

Im P3D->Options->Other 

dort ist standardmäßig "Raw Input" (oder so ähnlich) anselektiert

ändere diese auf "DirectX Input" (oder so ähnlich)

Es kommt dann so eine Warnung, dass alle Eingabekonfigurationen gelöscht werden (o.s.ä.)

Zustimmen, abspeichern

P3D beenden

die P3D Standard.XML löschen (falls Du nicht weißt wo die sich befindet, hier fragen)

P3D starten

Joystick wieder unter den Optionen zuweisen.

 

Steht jetzt der richtige Joystick Name zur Verfügung ?

Funktioniert der Throttle (zugewiesen) einwandfrei ?

 

Wenn nicht, dann alles wieder zurück und IMO besseren Joystick kaufen gehen. Auch die Standard.xml einmal löschen

 

Falls Du den alten Joystick durch einen neuen ersetzt, dann vorher besser auch die Standard.xml löschen.

 

Ahoj

-Uwe

 

 

Share this post


Link to post
Share on other sites

Danke für die Unterstützung.

Der richtige Joystick Name ist vorhanden, jedoch der Schubhebel verweigert weiterhin seine Mitarbeit. Die Standard.xml konnte ich nicht im Verzeichnis vom P3D finden. 

 

Gruß

Jürgen

 

 

Share this post


Link to post
Share on other sites

Hallo Jürgen,

 

die Standard.xml Darei befindet sich hier:

  • C:\Users\[DU]\AppData\Roaming\Lockheed Martin\Prepar3D v4\Controls\Standard.xml

 

Share this post


Link to post
Share on other sites

Der Schubhebel hat kein Interesse, sich auf den neuen Flugsimulator einzulassen.

 

Da bleibt wohl nur der Umstieg auf ein neues Gerät.

Welches Gerät - Joystick mit Schubhebel und Tasten für Fahrwerk und Landeklappen ist für den P3D v4 (später auch für den neuen FS2020) empfehlenswert?

Ich habe schon ein wenig recherchiert: Thrustmaster - Hotes one, - Hotas 4, -Hotas X oder T1600 M FCS Hotas.

 

Danke allen für die Unterstützung

Gruß

Jürgen

Share this post


Link to post
Share on other sites

Hallo Jürgen,

 

ich habe meinen alten Saitek X52 hervorgekramt und muss nun eingestehen, 0-255 wäre für den Gashebel auch legal. Sorry, ich lag damit voll daneben, dass es von 0-16383 sein muss (das ist der Wert von meinem Thrustmaster HOTAS Warthog)

Also fangen wir nochmals von vorne an.

Wurde der Name Deines Widows in beiden Modis DirectInput und RawInput korrekt erkannt. Falls ja, dann wechsel bitte wieder auf RawInput. Ansonsten bleibe auf DirectInput.

Lösche nochmals die Standard.xml

 

Hast Du FSUIPC installiert ? Falls ja, temporär deaktiviern.

 

Starte den P3D, gehe in die Optionen->Axis Assignments->Controller (Listbox aufmachen).

Du solltest nun  3 Geräte vorfinden

-------

Mouse Yoke

Mouse Look

Dein Black Widow

-----

 

sonst nichts anderes. Ist das so richtig ? Falls doch weitere Geräte erscheinen, bei diesen alle Achsenzuordnungen erstmal löschen

Die beiden Mouse Yoke/Look kannst Du so lassen wie sie sind

 

Wähle Deinen Black Widow aus und lösche alle Achsenzuordnungen

Weise nun manuell die Achsen dem Widow zu

Aileron Axis

Elevator Axis

Rudder Axis

Throttle Axis    (nicht mit Engine throttle 1-4 axis verwechseln)  

 

abspeichern.  Szenario laden und ausprobieren.

 

In der Hoffnung es funktioniert nun.

-Uwe

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hallo Uwe,

 

jetzt hat es funktioniert. Der Schubhebel hat seine Verweigerungshaltung aufgegeben. Die Zuordnung der Throttle Axis war nicht richtig.

 

Danke!

 

Gruß

Jürgen

Share this post


Link to post
Share on other sites

Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...