Jump to content

Updater Stopped Working After Windows Update


Recommended Posts

Hi All,

 

I'm running Windows 10 and shortly after the most recent Windows update, the Aerosot Updater has stopped working.

 

When I run the program (in administrator mode) a blank white window opens for a few seconds, then closes. I've made no changes to my sim, or any Aerosoft products since it was working last. 

 

The only thing I can think of is a routine Windows update that happened recently.

 

Can the updater alone be re-installed?

 

Thanks in advance.


DB

Link to post
Share on other sites

I have the same problem. Since 2 Days, my Updater seems to start, then it get's black and the window disappears. I tried to reinstall one of the products, to make it appear again afterwards, but that did not do the trick. 

Link to post
Share on other sites
  • Deputy Sheriffs

Hmm, no problem here, the most recent windows updates were installed on my machine on 16.01.2020.

Please post a screenshot of the Windows Update history, to see if there is a difference:
2020-01-22_08h14_14.png

Link to post
Share on other sites

Here's my update history:

 

image.thumb.png.a8e67a9289942b99373da0cc5b1dde3f.png

 

 

It's acting a bit differently now. When the updater is opened, it tries to update itself, then I get the following message:

 

image.png.50e0069bbb44901b14b0f8902c888de2.png

 

....and the same thing happens on repeat once I close it with Ctrl Alt Del.

 

Any ideas?

 

Thanks

 

 

Link to post
Share on other sites
  • Developer

This is what I get when I use your XML files in ASUpdater\Products. Of course I had to change the path entries first or I wouldn't see anything.

image.png

 

Since you have a lot of AS products and are obviously using the updater for a while already, do you remember after which installation (or update) it stopped working for you?

Link to post
Share on other sites
On 27.1.2020 at 15:01, Hans Hartmann sagte:

Same here.

 

There are quite a few .NET Framework updates in your list. But my system has all updates installed too. I wonder if they actually can have something to do with the problem. @Beat578 did you install and windows updates recently?

Hi Hans. Not that I know, but I'll check back. I also try to reinstall the updater with the link Mathijs posted and will report back. The last AS Product I installed was the Update of the AS Geneva professional up to 1.1.0.2. Thanks for your help. And sorry for the late reply, i somehow missed your first post... 

Link to post
Share on other sites

Sorry about the delay.....work....

 

Just tried to uninstall and re-install the updater (with my anti-virus disabled).

 

It seems to have successfully installed, but I no longer have a link to start the updater from the Start Menu....just the uninstall link in the aerosoft - updater folder.

 

When I go to the actual location, everything is there, but the Updater still won't open...just a white window then a crash.after a few seconds..

 

Any ideas?

 

DB

Link to post
Share on other sites

I have the same Problem as Davii. Unistalled and re-installed the updater. Then i uninstalled and reinstalled Geneva scenery. I have the geneva.xml in my updater library (all other products have gone). still only white window and then a crash. I am out of ideas. Macaffee has nothing in quarantaine and it started as admin, so it should have all the rights it needs to install.

Link to post
Share on other sites
  • 2 weeks later...
  • Developer

We did some testing here and found out that one of the product files (in this case F14Extended_p3d4.xml) was corrupted.

 

I created a special version of the updater which logs the complete startup process: ASUpdater_Logging.7z

It creates a file ASUpdater_App_Log.txt in MyDocuments\Aerosoft\ASUpdater

 

Please try this special version and post your log file here.

 

Link to post
Share on other sites
On 2/19/2020 at 7:00 AM, Hans Hartmann said:

We did some testing here and found out that one of the product files (in this case F14Extended_p3d4.xml) was corrupted.

 

I created a special version of the updater which logs the complete startup process: ASUpdater_Logging.7z

It creates a file ASUpdater_App_Log.txt in MyDocuments\Aerosoft\ASUpdater

 

Please try this special version and post your log file here.

 

 

Thanks. Here is the file.

 

ASUpdater_App_Log.txt

 

DB

Link to post
Share on other sites

Hi Hans

Just returned from the holidays. I will try the log Version tonight as well. Had no luck with the updater the week before. And Windows did so many updates of stuff, it would be hard to go back to the point the updater still worked. 

I'll send my file tomorrow. Thanks for your continous support and help!

Link to post
Share on other sites
3 hours ago, Hans Hartmann said:

 

In your case, the updater stops while getting the paths to FS and X-Plane. I guess, I need to build yet another version to see what exactly is going on there. May be later today, if I find the time.

 

 

Great, thanks!


DB

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...