Jump to content
Flugkapitan

Loss of engine power in cruise

Recommended Posts

Greetings!

 

Yesterday evening I flew in the A330 from MPTO - MMMX. All was well during climbout. However, right after level off at FL380 the left engine lost power, starting surging slightly and airspeed started to decrease. There were not any warnings or caution indications whatsoever (see attached pic). Anyone have any idea what might have caused this? If so, what is the in-flight remedy? This has never happened before during countless flights I've made in this aircraft.

 

Regards,

Scott

2020-1-15_18-4-9-297.jpg

Share this post


Link to post
Share on other sites
12 minutes ago, Flugkapitan said:

Greetings!

 

Yesterday evening I flew in the A330 from MPTO - MMMX. All was well during climbout. However, right after level off at FL380 the left engine lost power, starting surging slightly and airspeed started to decrease. There were not any warnings or caution indications whatsoever (see attached pic). Anyone have any idea what might have caused this? If so, what is the in-flight remedy? This has never happened before during countless flights I've made in this aircraft.

 

Regards,

Scott

2020-1-15_18-4-9-297.jpg

I didn't have your problem, but yesterday I had a problem almost right at the same point, shortly after level following climbout.   In my case the aircraft went into an overspeed situation and disengaged auto thrust.  I was able to regain control, but as in your case no warning other than the alert coming on when it happened.

Share this post


Link to post
Share on other sites
33 minutes ago, Flugkapitan said:

Greetings!

 

Yesterday evening I flew in the A330 from MPTO - MMMX. All was well during climbout. However, right after level off at FL380 the left engine lost power, starting surging slightly and airspeed started to decrease. There were not any warnings or caution indications whatsoever (see attached pic). Anyone have any idea what might have caused this? If so, what is the in-flight remedy? This has never happened before during countless flights I've made in this aircraft.

 

Regards,

Scott

2020-1-15_18-4-9-297.jpg

 

 

Which version of the Airbus are you running?

 

Share this post


Link to post
Share on other sites

Hi Dave, no experimental update , today? 

 

Best.

 

Miquel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...