Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content

Recommended Posts

23 minutes ago, Branimir said:

I think it should work fine with some "sliders to the left" by some extent. I have never heard of GTX 1050 that has 3GB, I always though there are only 2 and 4 GB variants.

Yeah there is a 3GB GDDR5 version

Share this post


Link to post
Share on other sites
On 1/9/2020 at 6:30 PM, Branimir said:

I also started getting low FPS problem and I have never had it before even in BETA testing. Few days ago I made a successful flight from LJLJ to EDDF. Yesterday I powered on my PC, turnet off Hyperthreading to test this:

After turning it off I started P3D with CRJ and had 30+ FPS in cold and dark. As soon as I turned the AC power on and avionics came to life my FPS dropped to 15 or less FPS. I thought that HT set to off in BIOS is causing this problem. After a restart and turning the HT back on the problem was still there. I am 90% sure that turning HT off and back on has nothing to do with FPS problem. But it is interesting that this is the only change on my system between a smooth CRJ experience and low FPS problem.

I deleted the P3D cfg file, reinstalled the CRJ and there was no change.

Then I started searching for the problem. I tried FSLabs and PMDG NGXu and had 25+ FPS. CRJ is still having 15FPS on AC power and 30+ without AC. 

Then I turned all the settings to the left (LOW) in the P3D and still had exactly the same amount of FPS while on AC power. So P3D settings had no impact.

The only improvement was switching off the FO displays - FPS jumped to 20 but it is still quite low and if I also turn the CPT screen - FPS jumps to 30.

 

Was there maybe a Windows 10 update I don't know about it and started this problem?

 

I doubt my PC is underpowered for CRJ:

Windows 10 1903 18362.535

i7-7700 (4.2 GHz, HT enabled)

16GB DDR4 RAM

Gigabyte RTX 2070 Super Gaming OC

 

I am so confused about this problem :(

I have just reinstalled my GPU drivers and still doesn't make difference. :(

Share this post


Link to post
Share on other sites

I am having the same issue.  I wish i knew about this problem with the CRJ before made the purchase. I mean no disrespect to Hans and crew, but I feel ripped off.  $75 is a lot for an add-on, and I expected much more than this very poor performance.  I truly feel like a made a mistake in purchasing this product.  I know that the Aerosoft team is committed to resolving the issue, but for now this aircraft on day 1 is to remain grounded and in the hanger until this issue is resolved.  The stuttering completely ruins the experience.  All aircraft add-ons that I have do not have this issue and has very smooth performance making the experience much enjoyable.  I'm very disappointed with the CRJ...and I saw nothing of this issue on any reviews.....when it's obvious most folks are experiencing the stutter fest.  Such a shame.....  I made a mistake and now regretting it.  I'm so sorry for the negative comments, but I find this unacceptable for the amount of money that was paid. 

 

-Mark

Share this post


Link to post
Share on other sites
On 1/11/2020 at 9:25 AM, Branimir said:

I have just reinstalled my GPU drivers and still doesn't make difference. :(

 

One thing that will help a LITTLE is to disable Hyperthreading.  Standard advice is flight sim has long been to disable HT unless you have a very specific reason to have it enabled and then you'll have to use Affinity Mask to help the sim and other software running alongside the sim run as smooth as possible.  It's much easier just to turn off HT.

 

Another thing you can try is to omit the main P3D folder in your computer security.

 

Best wishes.

 

Share this post


Link to post
Share on other sites

HT was disabled for this system build.   AV (ESET) has been uninstalled to troubleshoot this issue with no improvements to the stuttering.  Having the same issue as discribed earlier in the thread:

"Same here. Its stutters. Taxiing is most noticeable... its like this       ---------..-----------------..------------..-----------------------..---------------..-------------..----------- (line smooth, dotdot stutter) Old CRJ was always smoothest addon i have, 30-45 steady.

And also CDT with EFB use. CDT stops me every flight. I understand this is being looked into as of 10th Dec there was a breakthrough  with Navigraph 1hr timeout problem?  Im yet to have a go at a landing unfortunately, But i imagine the stutters would be a problem with smooth flow."

 

-Mark

Share this post


Link to post
Share on other sites

Just the question which season did the users who have problems with the FPS use for testing?
If Winter would you test this with e.g. summer?

 

Wolfgang

Share this post


Link to post
Share on other sites

The only thing that fixed this issue was complete Windows 10 install and start from the beginning. It works perfectly smooth now. I started getting this problem about three weeks ago and a friend of mine also started getting similar issue at about the same time. I had this issue in all complex airliner addons. This might has something to do with a windows update?

 

But everything is fine now and all CPU cores are now running almost at 100% so it is now well utilised.

Share this post


Link to post
Share on other sites

tried everything  with the new update still getting stutters when taxiing and external view .all my other add ons Pmdg,Fslabs  Qw run smoothly.

gave up on this AC .

Share this post


Link to post
Share on other sites

I am averaging about 19-20fps in the cockpit when facing the glareshield area. If I pan away from that area, my fps goes way up to 30-40.Tried turning my settings way down, turning off dynamic lighting, reflections, MSAA, etc. This is coming from a higher end system. i7-9700k and a GTX 1070. Some of the other more detailed aircraft such as the QW787 or the NGXU, both started out as FPS hogs but got better with updates. Hopefully we can say the same for the CRJ in the future.

Share this post


Link to post
Share on other sites

If you guys are having low frame rates, please:

 

1. Post screen shots of the P3D Display, World, Lighting and Weather pages.

2. Post your system specs (so we don't have to refer to other posts in the threads).

3. Tell us what frame rates you're getting at the following points:

    a. At the gate (default and payware airports - and let us know the airport ICAO and scenery developer).

    b. During climb below 18,000ft.

    c. During cruise above 28,000ft.

4. Are you using any third party shaders (Tomato Shade, PTA)?

5. If you are using any third parrt weather textures, please include a screen shot of the weather texture resolutions.

 

Looking forward to hearing from you.

 

 

 

 

 

Share this post


Link to post
Share on other sites
37 minutes ago, DaveCT2003 said:

If you guys are having low frame rates, please:

 

1. Post screen shots of the P3D Display, World, Lighting and Weather pages.

2. Post your system specs (so we don't have to refer to other posts in the threads).

3. Tell us what frame rates you're getting at the following points:

    a. At the gate (default and payware airports - and let us know the airport ICAO and scenery developer).

    b. During climb below 18,000ft.

    c. During cruise above 28,000ft.

4. Are you using any third party shaders (Tomato Shade, PTA)?

5. If you are using any third parrt weather textures, please include a screen shot of the weather texture resolutions.

 

Looking forward to hearing from you.

 

 

 

 

 

Here are some screenshots providing some more details. I have tried two airports so far Flightbeam KPHX and the default MMGL. Flightbeam was around 19-20fps constant and MMGL was better at 18-40fps (but fps was very inconsistent). Once in the air away from any autogen my fps was more playable at around 28-40fps. So it is mostly at the airports or near the city where it is bad. I am using Tomatoshade as well as Active Sky, but even with the FPS issues that Tomatoshade is known for, my performance isn't this bad with other detailed addon aircraft.

 

Thanks for looking in to this.

Screenshot_7.jpg

Screenshot_6.jpg

Screenshot_5.jpg

Screenshot_4.jpg

Screenshot_3.jpg

Screenshot_2.jpg

Screenshot_1.jpg

Share this post


Link to post
Share on other sites
2 hours ago, sho69607 said:

Here are some screenshots providing some more details. I have tried two airports so far Flightbeam KPHX and the default MMGL. Flightbeam was around 19-20fps constant and MMGL was better at 18-40fps (but fps was very inconsistent). Once in the air away from any autogen my fps was more playable at around 28-40fps. So it is mostly at the airports or near the city where it is bad. I am using Tomatoshade as well as Active Sky, but even with the FPS issues that Tomatoshade is known for, my performance isn't this bad with other detailed addon aircraft.

 

Thanks for looking in to this.

 

 

You didn't provide screen shots of Weather textures, so I'm guessing that you aren't using any third party weather textures. If you are, then we need to look at those as well.

 

 

1. I don't have and have never worked with an i7-9700K, but I would have someone check your overclock settings.  Also, there is no reason to overclock that high for P3D (and you won't likely find software that pushes a sysetm harder than P3D so...).  4.5GHz should be plenty enough.  With your processor running at 5.0GHz and you running a GTX1070 you may well be creating a bottleneck. You can run MSI Afterburner in conjunction with RiveTuner to see if you do have a bottleneck, but I'd guess that you do.  We don't handle support in this area, so that is the limit of the advice that I can provide in this area.

 

2.  The guide or person who recommended you use those P3D is completely whacked. I'd disown them, or at least not listen to them anymore (about anything, because if they recommended those settings then you can be they give advice about many others things they are clueless about).  Disassociate yourself from this person or guide as quickly as you can, who knows how bad their next advice might be!  I mean this to be humorous, but with all good humor there is a healthy element of truth to it.

 

Let's get things sorted out.

 

A. Go to the C:\Users\[YOUR USERNAME]\AppData\Roaming\Lockheed Martin\Prepar3D v4 and cut and paste your Prepar3D.cfg file to your desktop. This will reset your settings and give you a fresh start.  The file will be rebuilt the next time you start P3D.  Later on after things are working normally you can delete this file from your desktop.

 

B. Navigate to the C:\Users\[YOUR USERNAME]\AppData\Local\Lockheed Martin\Prepar3D v4 directory and delete your "Shaders" folder. It will be rebuilt the next time you boot up P3D.

 

C. With the exception of display resolution (which is tailored to your monitor), match your settings to the graphic below.  NOTE:  I would start with Texture Resolution of 2048x2048 (most people can't tell the difference between 2048x2048 and 4096x4096 and 2048x2048 is pefectly fine for P3D.  If  you want to set this higher in the future then at least you'll have a baseline for system performance having run the P3D at 2048 for a while.  The other exception is MIPmap VC Panels, try it both ways on your system.  I don't know if the CRJ requires Wide View Aspect Ratio to be set or not, if not you might want to try it both ways to see which you prefer.  I usually prefer to use set it on.

 

D.  The best frame rate for P3D is actually 30 (29.97). Instead of using P3D to limit  your frame rates (which it doesn't really do), I would use MSI Afterburner and Rivatuner.  I can't provide  you with instructions on how to do this, but you can find them in the web (likely Youtube).  Since you'll be using other tools to limit your frame rate, keep  your Target frame rate as shown in the graphic below.

 

E. I've provided screen shots of the other P3D settings below. Just match your system to them.

 

F. NOTE:  I don't know if HDR is required for the CRJ as it is with the Aerosoft A330, but you might want to check and set accordingly.

 

Generally speaking there is no reason is max out   or use high settings in P3D or make most everything reflective and cast;/review shadows. Even Lockheed doesn't do this nor do they recommend it.  The examples below provide an even keel approach to balance quality and performance, and that is what you want to do for a good flight sim experience.  Happy Flights make us happy!

 

If you still have performance issues after changing  your settings then I would look at:

 

- Your overclocking,

- A CPU/GPU Bottleneck,

- If the installation process for the CRJ was done properly (previous version uninstalled and folders/files manually removed, installer run as Administrator with computer security disabled,

- Windows Updated,

- Drivers Updated (VERY important, I use Driver Booster Pro)

- Download the latest Graphics Driver, and before you install it use DDU wipe  your existing graphics driver, afterwards install the latest driver.

 

When you test your performance, it's important to do so wit and without a weather engine running.

 

Let me know how you make out!

 

 

 P3D Display.png

 

P3D World.png

 

 

P3D Lighting.png

 

P3D Weather.png

Share this post


Link to post
Share on other sites
On 2/11/2020 at 6:23 PM, DaveCT2003 said:

 

You didn't provide screen shots of Weather textures, so I'm guessing that you aren't using any third party weather textures. If you are, then we need to look at those as well.

 

 

1. I don't have and have never worked with an i7-9700K, but I would have someone check your overclock settings.  Also, there is no reason to overclock that high for P3D (and you won't likely find software that pushes a sysetm harder than P3D so...).  4.5GHz should be plenty enough.  With your processor running at 5.0GHz and you running a GTX1070 you may well be creating a bottleneck. You can run MSI Afterburner in conjunction with RiveTuner to see if you do have a bottleneck, but I'd guess that you do.  We don't handle support in this area, so that is the limit of the advice that I can provide in this area.

 

2.  The guide or person who recommended you use those P3D is completely whacked. I'd disown them, or at least not listen to them anymore (about anything, because if they recommended those settings then you can be they give advice about many others things they are clueless about).  Disassociate yourself from this person or guide as quickly as you can, who knows how bad their next advice might be!  I mean this to be humorous, but with all good humor there is a healthy element of truth to it.

 

Let's get things sorted out.

 

A. Go to the C:\Users\[YOUR USERNAME]\AppData\Roaming\Lockheed Martin\Prepar3D v4 and cut and paste your Prepar3D.cfg file to your desktop. This will reset your settings and give you a fresh start.  The file will be rebuilt the next time you start P3D.  Later on after things are working normally you can delete this file from your desktop.

 

B. Navigate to the C:\Users\[YOUR USERNAME]\AppData\Local\Lockheed Martin\Prepar3D v4 directory and delete your "Shaders" folder. It will be rebuilt the next time you boot up P3D.

 

C. With the exception of display resolution (which is tailored to your monitor), match your settings to the graphic below.  NOTE:  I would start with Texture Resolution of 2048x2048 (most people can't tell the difference between 2048x2048 and 4096x4096 and 2048x2048 is pefectly fine for P3D.  If  you want to set this higher in the future then at least you'll have a baseline for system performance having run the P3D at 2048 for a while.  The other exception is MIPmap VC Panels, try it both ways on your system.  I don't know if the CRJ requires Wide View Aspect Ratio to be set or not, if not you might want to try it both ways to see which you prefer.  I usually prefer to use set it on.

 

D.  The best frame rate for P3D is actually 30 (29.97). Instead of using P3D to limit  your frame rates (which it doesn't really do), I would use MSI Afterburner and Rivatuner.  I can't provide  you with instructions on how to do this, but you can find them in the web (likely Youtube).  Since you'll be using other tools to limit your frame rate, keep  your Target frame rate as shown in the graphic below.

 

E. I've provided screen shots of the other P3D settings below. Just match your system to them.

 

F. NOTE:  I don't know if HDR is required for the CRJ as it is with the Aerosoft A330, but you might want to check and set accordingly.

 

Generally speaking there is no reason is max out   or use high settings in P3D or make most everything reflective and cast;/review shadows. Even Lockheed doesn't do this nor do they recommend it.  The examples below provide an even keel approach to balance quality and performance, and that is what you want to do for a good flight sim experience.  Happy Flights make us happy!

 

If you still have performance issues after changing  your settings then I would look at:

 

- Your overclocking,

- A CPU/GPU Bottleneck,

- If the installation process for the CRJ was done properly (previous version uninstalled and folders/files manually removed, installer run as Administrator with computer security disabled,

- Windows Updated,

- Drivers Updated (VERY important, I use Driver Booster Pro)

- Download the latest Graphics Driver, and before you install it use DDU wipe  your existing graphics driver, afterwards install the latest driver.

 

When you test your performance, it's important to do so wit and without a weather engine running.

 

Let me know how you make out!

 

 

 P3D Display.png

 

P3D World.png

 

 

P3D Lighting.png

 

P3D Weather.png

Thanks for providing this info. I ultimately decided a complete reinstall of Windows to be the best course of action. After doing so my system runs much faster both with and without running P3D. There may have been outdated drivers, registry issues, and who knows what else going on with my computer.

Share this post


Link to post
Share on other sites
3 hours ago, sho69607 said:

Thanks for providing this info. I ultimately decided a complete reinstall of Windows to be the best course of action. After doing so my system runs much faster both with and without running P3D. There may have been outdated drivers, registry issues, and who knows what else going on with my computer.

 

Absolutely!  We have lost count of the number of people a Windows re-install has done great things for.  Nobody wants to do this, but when having the type of issues you were having it really is the best way to go.

 

Happy to have you back in the air!

 

Best wishes.

 

Share this post


Link to post
Share on other sites
On 2/11/2020 at 4:38 PM, sho69607 said:

Here are some screenshots providing some more details. I have tried two airports so far Flightbeam KPHX and the default MMGL. Flightbeam was around 19-20fps constant and MMGL was better at 18-40fps (but fps was very inconsistent). Once in the air away from any autogen my fps was more playable at around 28-40fps. So it is mostly at the airports or near the city where it is bad. I am using Tomatoshade as well as Active Sky, but even with the FPS issues that Tomatoshade is known for, my performance isn't this bad with other detailed addon aircraft.

 

Thanks for looking in to this.

 

Turn your Autogen and scenery draw distance down , that's set way too high and youwill gain a great deal of FPS back with it set lower , Medium is what i use with my GTX1080 and i set Active sky to limit the low level vis to about 20-25 miles to counter act the lack of autogen in the distance.....dynamic reflections will also hurt FPS, also i notice you have building shadows on ... imagine trying to draw the shadows on the buildings so far out .. Again this will hurt FPS with such a high Autogen draw distance.

Rich

Share this post


Link to post
Share on other sites
15 minutes ago, keenrw said:

Turn your Autogen and scenery draw distance down , that's set way too high and youwill gain a great deal of FPS back with it set lower , Medium is what i use with my GTX1080 and i set Active sky to limit the low level vis to about 20-25 miles to counter act the lack of autogen in the distance.....dynamic reflections will also hurt FPS, also i notice you have building shadows on ... imagine trying to draw the shadows on the buildings so far out .. Again this will hurt FPS with such a high Autogen draw distance.

Rich

 

He's already solved it my friend.  See his last post.   I also noted the Autogen in my earlier recommendations to him.

 

 

Best wishes!

Share this post


Link to post
Share on other sites

I have noted continuous frame rate fluctuations in all iterations of the CRJ Pro since the first beta. I have an older i4790K system, running at 4 gHz (but with a good GTX1080 TI GPU), and do not expect extremely high performance, but with frame rates locked at 30, I can maintain close to that with other high-end add-ons, including the PMDG NGXu, FSL A320 and Leonardo Maddog.

 

With the CRJ Pro, even if parked at a default airport, on the runway (away from the terminal), with default clear skies weather theme active, and all aircraft systems powered off, with no external programs running that interact with P3D, if I monitor the frame rates, they continually go from 25 down to about 15, and back up to 25. If I watch the CPU load in Microsoft Process Explorer, I will see P3D generating a recurring CPU spike that correlates with the frame rate drop.

 

I do not use either Navigraph or Nav Data Pro charts functionalty in the CRJ EFB. I am a Navigraph charts subscriber, but I prefer to use their iPad app, rather than displaying charts in-sim.

 

I always disable my antivirus before running P3D, as I know that AV file scanning can produce exactly those kind of fluctuations, and none of the other add-ons I use will produce those kind of regularly recurring frame rate drops - especially when sitting still with all aircraft systems unpowered. 
 

It certainly appears that with the Pro loaded, that some kind of additional process is running at regular intervals that impacts frame rates. Perhaps something to do with the new charts functionality? (Even though I have charts disabled).

Share this post


Link to post
Share on other sites
9 hours ago, JRBarrett said:

I have noted continuous frame rate fluctuations in all iterations of the CRJ Pro since the first beta. I have an older i4790K system, running at 4 gHz (but with a good GTX1080 TI GPU), and do not expect extremely high performance, but with frame rates locked at 30, I can maintain close to that with other high-end add-ons, including the PMDG NGXu, FSL A320 and Leonardo Maddog.

 

With the CRJ Pro, even if parked at a default airport, on the runway (away from the terminal), with default clear skies weather theme active, and all aircraft systems powered off, with no external programs running that interact with P3D, if I monitor the frame rates, they continually go from 25 down to about 15, and back up to 25. If I watch the CPU load in Microsoft Process Explorer, I will see P3D generating a recurring CPU spike that correlates with the frame rate drop.

 

I do not use either Navigraph or Nav Data Pro charts functionalty in the CRJ EFB. I am a Navigraph charts subscriber, but I prefer to use their iPad app, rather than displaying charts in-sim.

 

I always disable my antivirus before running P3D, as I know that AV file scanning can produce exactly those kind of fluctuations, and none of the other add-ons I use will produce those kind of regularly recurring frame rate drops - especially when sitting still with all aircraft systems unpowered. 
 

It certainly appears that with the Pro loaded, that some kind of additional process is running at regular intervals that impacts frame rates. Perhaps something to do with the new charts functionality? (Even though I have charts disabled).

 I did get some performance improvements by doing what was listed above, but the CRJ Pro is still pretty demanding in its current state. For now I have just been turning down some settings when I fly this aircraft. This should at least help with the FPS fluctuation problems.

Share this post


Link to post
Share on other sites

I observed a significant improvement in fps with the CRJ Pro when I switched off NVIDIA's image sharpening. No idea why, because in any other aircraft and situation the impact on performance is almost negligible and the GPU was clearly not the bottleneck...

Share this post


Link to post
Share on other sites

I want to try this but for some reasont I can't open nVidia control panel

Share this post


Link to post
Share on other sites
On 2/17/2020 at 5:01 PM, sho69607 said:

 I did get some performance improvements by doing what was listed above, but the CRJ Pro is still pretty demanding in its current state. For now I have just been turning down some settings when I fly this aircraft. This should at least help with the FPS fluctuation problems.

 

You can save performance profiles in P3D...I assume you know this already, but just in case you do not -- you can save your settings profiles so that you can switch between slider settings quickly and easily (for example, you could make one for "CRJ" with the slider settings you want to use with the CRJ).

 

I noticed on your initial screenshots of your settings, you're running a couple of sliders that will really hurt your fps with the 1070 card -- shadow settings -- and Special Effects sliders (both of them).   The special effects sliders are actually primarily cpu-bound, but running them full right isn't helping matters.

 

Another thing is the 2xSSAA + dynamic lighting.  Be careful running that especially at night with a 1070 card.  Any card really.

2 hours ago, Branimir said:

I want to try this but for some reasont I can't open nVidia control panel

 

Sounds like something is wrong with your driver.

 

If it were me I would install new driver using the "clean install" option on the installer.

 

After doing that, if you STILL cannot open the nvidia control panel, I would download DDU (Display Driver Uninstaller) from Guru3D or similar site.  That prog will get everything out from the old driver(s).

 

Share this post


Link to post
Share on other sites

I tried it with no improvement .the a330 is very good performance compared to the crj

Share this post


Link to post
Share on other sites

Yesterday I made a complete Windows reinstall because all of the Windows 10 UWP apps/programs were not working and the problem was that the nVidia control panel is now a UWP based application. After full Windows reinstallation I loaded the CRJ for the first time since reinstall and had around 30FPS. Today I started P3D again and CRJ has 15FPS again. Image sharpening is set to OFF.

Share this post


Link to post
Share on other sites

After some flights with the CRJ Pro I personally found the displays as the root cause for the poor performance on my system. With FO Rendering disabled I get a significant FPS boost and the FPS fluctuation decreased as well, still the Performance is not nearly as good as in the A330 (a totally diffrent development, i know :) ). However I hope that this is only a temporary solution since all my other Aircrafts, including the very Hardware demanding PMDG NGXU work perfectly fine with all displays enabled. I really love regional LH operations out of Munich and Frankfurt but with the current Performance the plane is only partly enjoyable.  

Share this post


Link to post
Share on other sites
On 3/5/2020 at 4:43 PM, DKB said:

After some flights with the CRJ Pro I personally found the displays as the root cause for the poor performance on my system. With FO Rendering disabled I get a significant FPS boost and the FPS fluctuation decreased as well, still the Performance is not nearly as good as in the A330 (a totally diffrent development, i know :) ). However I hope that this is only a temporary solution since all my other Aircrafts, including the very Hardware demanding PMDG NGXU work perfectly fine with all displays enabled. I really love regional LH operations out of Munich and Frankfurt but with the current Performance the plane is only partly enjoyable.  

You have the same problem as me. No matter what settings I have i always get 15FPS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...