Jump to content
alfatango

Aerosoft Professional 318/9/20/21 CTD

Recommended Posts

Three days ago I used the Airbus Professional 319 (v. 1.2.5.0) and everything was OK.

 

After the flight, the computer was shut down and not used till today.

 

Today, I started the PC again, fired P3D (V4.5HF2) and the 'bus would not load, with CTD after selecting the plane (black screen for a few seconds and then CTD).

 

Same happens with all Airbus Professional models (318/9/20/21)

 

I have tried to uninstall the Airbus, re-install it, update with the 1.2.5.2 experimental updates, to no avail: P3D crashes to desktop upon selection of any Airbus professional.

 

All other aircraft add-ons (including Aerosoft's CRJ 700/900) work OK.

 

Is anyone else experimenting the same behaviour? Maybe a hidden Windows update in between?

 

Thanks for any help

 

Alfatango

Share this post


Link to post
3 hours ago, alfatango said:

Three days ago I used the Airbus Professional 319 (v. 1.2.5.0) and everything was OK.

 

After the flight, the computer was shut down and not used till today.

 

Today, I started the PC again, fired P3D (V4.5HF2) and the 'bus would not load, with CTD after selecting the plane (black screen for a few seconds and then CTD).

 

Same happens with all Airbus Professional models (318/9/20/21)

 

I have tried to uninstall the Airbus, re-install it, update with the 1.2.5.2 experimental updates, to no avail: P3D crashes to desktop upon selection of any Airbus professional.

 

All other aircraft add-ons (including Aerosoft's CRJ 700/900) work OK.

 

Is anyone else experimenting the same behaviour? Maybe a hidden Windows update in between?

 

Thanks for any help

 

Alfatango

 

I am unable to directly load any of the Airbus Professionals without a CTD. I have to load into a default aircraft, and then load the Airbus, and that works for me.

 

Please take a look in your Windows Event Viewer and let us know which module is called out by the error?

 

Many thanks.

 

Share this post


Link to post

Many thanks to you, Dave.

 

Yes, I try also to load a default plane before selecting the Airbus Professional, but the result is the same.

 

If I load the Airbus first, I never get to the scenery loading progress bar screen - the sim crashes after a few seconds of black screen.

If I load a default aircraft, everything is fine, then, when I go to "change vehicle", select the Airbus, the screen goeas black for a few seconds and then CTD.

 

The Event Viewer error log is as follows:

Log Name:      Application
Source:        Application Error
Date:          09/11/2019 08:11:27
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      LAPTOP-SAOMJFOR
Description:
Faulting application name: Prepar3D.exe, version: 4.5.13.32097, time stamp: 0x5d8abf93
Faulting module name: KERNELBASE.dll, version: 10.0.18362.418, time stamp: 0xfba22159
Exception code: 0xc0020001
Fault offset: 0x000000000003a839
Faulting process ID: 0x1a70
Faulting application start time: 0x01d596cc88974003
Faulting application path: C:\FltSim\Lockheed Martin\Prepar3D v4\Prepar3D.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: 9a89e69e-5a4d-4c8b-a045-78f881d5228a
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-11-09T07:11:27.553122200Z" />
    <EventRecordID>3115</EventRecordID>
    <Channel>Application</Channel>
    <Computer>LAPTOP-SAOMJFOR</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Prepar3D.exe</Data>
    <Data>4.5.13.32097</Data>
    <Data>5d8abf93</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>10.0.18362.418</Data>
    <Data>fba22159</Data>
    <Data>c0020001</Data>
    <Data>000000000003a839</Data>
    <Data>1a70</Data>
    <Data>01d596cc88974003</Data>
    <Data>C:\FltSim\Lockheed Martin\Prepar3D v4\Prepar3D.exe</Data>
    <Data>C:\WINDOWS\System32\KERNELBASE.dll</Data>
    <Data>9a89e69e-5a4d-4c8b-a045-78f881d5228a</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

 

What baffles me, is that I have never had problems with the Airbus before, I was able to load it directly from the welcome screen, and then from one day to the next the behaviour changed.

 

On retrospective, I realised that the last thing I had done before switching off P3D on the last successful session was installing and activating a scenery, so - even if I do not understand how a scenery could cause this CTD - I deactivated it, but without effect, still CTD.

 

All other airplans add-ons, including pretty complex ones and even Aerosoft's own CRJ 700/900 work flawlessly as before.

 

Any help will be very much appreciated, as at this stage I wonder whether even a P3D client reinstall would be helpful.

 

alfatango

 

Share this post


Link to post

NOW I am totally confused, as it seems that the behaviour is not consistent.

 

Out of maybe 15 attempts, I had:

 

2 successful selection of the Airbus by loading an add-on plane first and then selecting Vehicle -> Airbus Professional (once the 320, once the 319)

1 successful selection of the Airbus (320) directly from the welcome screen, 

no successful attempt when loading first a default plane and then selecting the Airbus (but this might be just a statistic)

10+ CTDs, even when repeating the same procedure that was successful in the previous attempt.

 

FWIW, and in case it gives a hint to the programmers, on at least one of the successful attempts (actually, the only case when I looked at it), while running the checklist I noticed that the elevator would not move on the MFD display/FTL CTL page but did move in the exterior view and did normally pitch the plane during flight.

 

Thick mystery....

 

I confirm that at least 7 or 8 other add on planes work as ususal.

 

alfatango  

Share this post


Link to post

The fact other aircraft work does not mean a lot. We use the very latest compilers and options and almost no add-on does that.

Something on your system changed (duh)...and there is unfortunately very little we can do to assist you. If code works on all systems except some it means those systems have something that is not as we expect it. 

  • Like 1

Share this post


Link to post

Thank you Mathijs for your support.

 

I am now able to consistently reproduce the issue:

 

The Aerosoft Airbus Professional, and only this add-on, crashes on selection, if and only if I change the simulator time of the day in the welcome screen.

 

Leaving the time of day unchanged (=system time) when selecting the Airbus and then changing it after loading the plane works fine. This is the workaround I am using now.

 

In case the developers/programmers are interested in looking into this, the extended appcrashview report includes:

 

Sig[0].Name=Application Name
Sig[0].Value=Prepar3D.exe
Sig[1].Name=Application Version
Sig[1].Value=4.5.13.32097
Sig[2].Name=Application Timestamp
Sig[2].Value=5d8abf93
Sig[3].Name=Fault Module Name
Sig[3].Value=KERNELBASE.dll
Sig[4].Name=Fault Module Version
Sig[4].Value=10.0.18362.418
Sig[5].Name=Fault Module Timestamp
Sig[5].Value=fba22159
Sig[6].Name=Exception Code
Sig[6].Value=c0020001 (My note: this is labelled as "the string binding is invalid")
Sig[7].Name=Exception Offset
Sig[7].Value=000000000003a839
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=10.0.18362.2.0.0.768.101
 

 

alfatango

Share this post


Link to post

That is a 'known' issue.  Although we never have seen in in our test on the A320 series, I got one PMDG aircraft that does it consistently on my laptop and we have seen issues like this every since P3d V4.0 was released. We have no explanation.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...