Support overload. We are currently seeing 65% more demand for support then we normally see. We can only assume this is because more people are at home due to the corona crises. Our complete support staff is online and they are working flat out, but it will take some days before we can scale up resources. Please be patient.

Jump to content

Recommended Posts

Hello,

 

I recently contacted Honeycomb regarding the instructions for installing the driver and assigning the switches to the proper functions of the aircraft (lighting and electrical) in P3D (XPlane works great). Currently it seems the assignments do not work and the method for using the software/driver are not working either. Honeycomb informed me Aerosoft created the driver/software and was working the issue.

 

 Any idea when we can expect an updated working version of the software? I know there’s a lot happening at Aerosoft (really looking forward to the A330) but any insight or information would be appreciated. I couldn’t find a post on this issue but if there is one my apologies.l

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I have just received my Alpha Yoke and from my side, I can recommend to use LINDA instead of the honeycomb software,

It is much easier to assign any function of many given Modules even with switches and not only buttons.

Even with PMDG NGX and other it is as easy as with any other switch panel.

 

And by the way, what a great yoke is this !!!

 

Share this post


Link to post
Share on other sites

Tom,

 

i did use the URL contained in the literature with the yoke which is how I got the driver and software. Is it different from the link you provided?

 

Mathijs,

 

Thanks for the information. I know all of you are busy, but how will we know when the new software is available?

 

Will

Share this post


Link to post
Share on other sites
11 hours ago, VAFPilot said:

Mathijs,

Thanks for the information. I know all of you are busy, but how will we know when the new software is available?

 

 

You can also check it in the program, see screenshot.

 

image.png

Share this post


Link to post
Share on other sites

This is a bit irritating. When I select "Updates" in the program, it says: "A new Version is available"  (spelling!). But where can I find it? According to the AS updater I have version 1.0.2.1 installed, which seems to be the latest.

 

This is a very nice peace of hardware. I bought mine on Saturday in Lelystad. However, the software seems to be a little bit unfinished to me.

I'm looking forward to the Bravo Throttle. I have already preordered it.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 10/30/2019 at 10:07 AM, Mathijs Kok said:

There is a new driver on the way that should made assigning controls easier.

 

A suggestion : would be great to be able to give a small script : example for BCN light, to insure proper synchronisation between switch and "result" :

 

button 21

(A:LIGHT BEACON, bool) ! if{ (>K:TOGGLE_BEACON_LIGHTS) }

button 22

(A:LIGHT BEACON, bool)  if{ (>K:TOGGLE_BEACON_LIGHTS) }

 

Would give more flexibility to customize the behaviour without adding extra gauge in each aircraft.

 

Gerard

Share this post


Link to post
Share on other sites
Vor 1 Stunde, Rainero sagte:

This is a very nice peace of hardware.

 

Of course it should be "piece of hardware". Oh this spell checking.....

  • Thanks 1

Share this post


Link to post
Share on other sites
vor 1 hour , gaab sagte:

 

A suggestion : would be great to be able to give a small script : example for BCN light, to insure proper synchronisation between switch and "result" :

 

button 21

(A:LIGHT BEACON, bool) ! if{ (>K:TOGGLE_BEACON_LIGHTS) }

button 22

(A:LIGHT BEACON, bool)  if{ (>K:TOGGLE_BEACON_LIGHTS) }

 

Would give more flexibility to customize the behaviour without adding extra gauge in each aircraft.

 

Gerard

Hi Gerard,

 

thanks for the suggestion. We'll discuss if we can add this feature in the future. 

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, Rainero said:

This is a bit irritating. When I select "Updates" in the program, it says: "A new Version is available"  (spelling!). But where can I find it? According to the AS updater I have version 1.0.2.1 installed, which seems to be the latest.

 

I have the same problem indeed.

Share this post


Link to post
Share on other sites

But for those of us who don't know how to interpret or write this type of code (for a lack of better terms) how do we get it working?

 

Also, the current software seems to do weird things. For example, when I switch views from interior to exterior it moves the flap switch up/down (I simply installed the yoke software and made no adjustments/assignments.)  Mechanically the yoke works for basic flight control but the switches are completely useless at this point. And since it's interfering with my flap operations I had to uninstall it. I was hoping it wouldn't interfere so that I could use the AS Updater when a new release is out but I can't tolerate how bad this is.

 

It works perfectly in XPlane: I don't understand why it's so complicated in P3D.

 

No offense to Aerosoft, but I don't understand why Honeycomb didn't develop their own software/driver for their product or hire out. But it should have shipped with a CD or a link to the Honeycomb site. For example, Saitek has its own software for its products: why not Honeycomb?

  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, VAFPilot said:

Also, the current software seems to do weird things.

...

Saitek has its own software for its products: why not Honeycomb?

 

I am guessing that P3D behaves like FSX, which means it will automatically assign your buttons to some functions when you install the yoke. As far as I know there is no consistent convention for button assignments, so this is very likely to fail and you will have switches assigned to apparently random functions. All you need to do to fix your problems is to go into the P3D controls page and assign the switches to the functions you want.

 

As far as I can tell without actually trying it, the Aerosoft program just loads and saves custom sets of assignments. I think you can do this already in P3D. You can certainly do it with FSUIPC (although you won't get the last three positions of the mag switch). I am presuming this is something like the program that comes with Saitek hardware does, although like many people I never bothered with it because it isn't required for basic functionality.

 

Also, as far as I can tell, the Honeycomb yoke doesn't come with a driver and nor does it need one, unless someone tells me otherwise. I am pretty sure it is just a standard joystick and it works fine as a native Windows device.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
vor 2 Stunden , VAFPilot sagte:

It works perfectly in XPlane: I don't understand why it's so complicated in P3D.

 

In my case I found that the numbering of the starter switch was wrong in X-Plane.

 

image.thumb.png.8e956accf918a4b69ab75ad9f235bd59.png

 

In the settings 5 was assigned to: Magnetos off, 4 to Magnetos right and so forth.

It seems that 5 should read 1, 4 should 2 etc. instead.

 

The correct assignment for me is:

 

image.thumb.png.02ba567ffa4404dee65d1470860e849b.png

 

I tested it with the Cessna Skyhawk.

 

 

 

Share this post


Link to post
Share on other sites
vor 1 hour , MarkHurst sagte:

 

I am guessing that P3D behaves like FSX, which means it will automatically assign your buttons to some functions when you install the yoke. As far as I know there is no consistent convention for button assignments, so this is very likely to fail and you will have switches assigned to apparently random functions. All you need to do to fix your problems is to go into the P3D controls page and assign the switches to the functions you want.

 

As far as I can tell without actually trying it, the Aerosoft program just loads and saves custom sets of assignments. I think you can do this already in P3D. You can certainly do it with FSUIPC (although you won't get the last three positions of the mag switch). I am presuming this is something like the program that comes with Saitek hardware does, although like many people I never bothered with it because it isn't required for basic functionality.

 

Also, as far as I can tell, the Honeycomb yoke doesn't come with a driver and nor does it need one, unless someone tells me otherwise. I am pretty sure it is just a standard joystick and it works fine as a native Windows device.

That is correct,

 

thanks for the explanation, Mark.

 

To add to this, the extra software is basically useful for assigning more non-standard functionality whereas FSX/P3D e.g. only allows for toggeling of certain functions instead of actually setting distinct states. This will be extended in the future and the yoke is otherwise working, can be assigned and used like any other plug&play device.

Share this post


Link to post
Share on other sites
1 hour ago, Rainero said:

 

In my case I found that the numbering of the starter switch was wrong in X-Plane.

 

I do not know which XP11 version you are using, but please note that Austin corrected this and other errors in the latest 11.40 beta.

Share this post


Link to post
Share on other sites

I was using 11.36. I just updated to 11.40r2 and now the numbering is correct.

Thx.

Share this post


Link to post
Share on other sites

Question :

 

in AddOn menu of Prepar3D, there is a Show (or Hide) Button Bindings. But I don't see anything...

 

Thanks

 

Share this post


Link to post
Share on other sites

Well,

 

I've already assigned the buttons in P3D natively and it still does not work (did that when I first received the yoke a few weeks ago). And to note,  not all lights on the Alpha yoke have corresponding assignments in P3D. Since the switches aren't working even though I've assigned them I thought that was what the driver/software would do. As it stands nothing works for the switches (at least for me).

 

If anyone has been able to get the corresponding switches to work in P3D for the Alpha yoke I would certainly appreciate succint instructions on how it was accomplished.

  • Upvote 1

Share this post


Link to post
Share on other sites

Guys, I've been using the yoke with, znd without the Honeycomb drivers since June. I'm sure I can help.

 

I'll be back at my computer tomorrow and I'll start the support to help you.

 

Share this post


Link to post
Share on other sites
vor 7 Stunden , gaab sagte:

Question :

 

in AddOn menu of Prepar3D, there is a Show (or Hide) Button Bindings. But I don't see anything...

 

Thanks

 

Gerard,

 

that's supposed to show a green text message with the corresponding function, when you press a button that has been assigned via the software. Are you sure that is not what's happening?

Share this post


Link to post
Share on other sites
17 hours ago, BenBaron said:

Gerard,

 

that's supposed to show a green text message with the corresponding function, when you press a button that has been assigned via the software. Are you sure that is not what's happening?

 

Hmmm. I went to "Options", "Add-ons..." and all I see are scenery addons: nothing there about button bindings.

Share this post


Link to post
Share on other sites
18 hours ago, BenBaron said:

Gerard,

 

that's supposed to show a green text message with the corresponding function, when you press a button that has been assigned via the software. Are you sure that is not what's happening?

 

I thought so, but no message.

 

Edit1 : adding a text in the YokeConfig.json display a message (because I suspected that the fonction to display must be specified somewhere !!!)

But, no way to add it using the YokeInput utility. Updating manually the templates or profiles is not sufficient, as the text is not copied to the active profile by the YokeInput.

 

--------------------

      "ButtonNumber": 0,
      "PressEvent": [
        {

      "ButtonNumber": 0,
      "PressEvent": [
        {
          "Variable": ">K:PARKING_BRAKES",
          "Value": "",
          "Repeat": false,
          "DE": "Parking Brakes DE",
          "EN": "Parking Brakes EN",
          "FR": "Parking Brakes FE",
          "ES": "Parking Brakes ES"

        }
---------------------------

BTW, I would like to change the text color.

I tried modifying in the [DISPLAY] section (which works great for other Prepar3D messages...)

InfoUpperLeftTextColorUser
InfoUpperLeftTextColorNonUser

with no luck.

 

Thanks for your support

 

Gérard

 

Edit 2 : there are hundreds of error messages in the contenterror.txt file when the yoke add-on is activated...

 

[error.xxx]
error=Gauge/Script Error
Type: Unknown
Name: Unknown
Error: Empty parentheses or closing parenthese missing: "()"

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...