Jump to content
Sign in to follow this  
Heinz Flichtbeil

MAC Catalina Problems with X-Plane 11

Recommended Posts

Hello,

 

if there are problems with the new OSX Catalina and X-Plane 11 like

"Resources/rand.bin" file not found!

This must be installed for me to have random numbers.

 

or

mac.xpl or xyz.app couldn't be opened .....

 

The please try this (tip from Laminar Research):


1.    Open Terminal
2.    Enter the command "xattr -d com.apple.quarantine"
3.    Find the X-Plane 11 folder in Finder and then drag the X-Plane.app (or the .app which is not working) from the Finder window into the Terminal window.
4.    This should complete the command to make it read "xattr -d com.apple.quarantine /<path to X-Plane>\ X-Plane.app"
5.    Hit Enter
6.    Try launching X-Plane once again.

 

Most times you have to do this also for all .xpl plugins like mac.xpl or for all .app files.

 

--------------------------------------------------------------------------------------------

And here are some older (but up to Catalina) possibilities:

 

Please try this:

Go to System Preferences.
Security & Privacy
Change the following settings (possibly temporary):
General tab, allow applications downloaded from:
Here select "anywhere". May be you have to open the little padlock symbol at the left bottom of the window before (Admin password required).
After the installation you should set yor gatekeeper with higher security (as you want) again.
 
Another way ist to use the right mouse button and start the application (with open).
 
Sierra and High Sierra (up to Catalina):
Here the option "anywhere" don't exists anymore and without some changes the right mouse button solution don't work.
 
You only can reconfigure your gatekeeper with a terminal command to the El Capitan standard (with "anywhere" available):
 
Open a terminal app.
Put in this command:
sudo spctl --master-disable
Now "anaywhere" is available and you can install your app like described with El Capitan (see above).
 
After that you shall enable your gatekeeper (with Sierra Standard) again with this command:
sudo spctl --master-enable
 
You need administrator rights for that.
 
Here you find an article about the problem:
 
And see here too (for Catalina):

All steps with your own risk.
 
If this all will not work, then the best way is to contact the apropriate Addon developers.
 

 

Greets Heinz

 

Share this post


Link to post
Share on other sites

More possibilities for Catalina and Mojave (or older)... with X-Plane 11.

 

System Settings - Security - Privacy - Accessibility - X-Plane must be enabled.

And

Right-click on the X-Plane 11 folder.
Then click on "Information" in the window.
In the next window click on "Share & access rights". In german (teilen & Zugriffsrechte).
Then continue clicking on the gear icon and set read and write permissions for the highlighted user (you) and then click "Apply to All Subfolders".

 

Greets Heinz

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...