Jump to content

Airspeed issue

William G

Recommended Posts

For the last several flights I have had a non functioning airspeed indicator.

I  made sure I have removed the pitot tube cover, confirming in external view that it goes away.

I have not turned on the pitot tube heat on the ground, and turning it on once airborne does not fix the airspeed indicator.

I have had previous flights where it worked as expected so I can't figure out why it no longer works.

every thing is marked good on the shift-2 condition page.

It has continued to do this through a couple of simulator/ computer  restarts

I am using FSX steam

Link to comment
Share on other sites

I found that the SP-ASR version's airspeed indicator works fine.

I would not be be surprised if the other flights I mentioned that worked were in this version so the issue is with the regular version.

I notice the SP-ASR is better on other areas such as more accurate Idle RPM and so forth.

Link to comment
Share on other sites

I decided to take a more scientific approach, since before I had been using RW weather and what ever temps that gave me with the resulting inconsistent results


I can confirm it is icing and given enough time  the pitot heat does restore the ASI function, It just takes much longer than I have been used to in the past.


Other aircraft may be the same but since there is no issue with turning the pitot heat on immediately after start I never ran into this before. in future I will not be quite as stingy with it's use on the ground.

Thanks for your time, sorry to have troubled you     WG


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy & Terms of Use