!! Windows 7 no longer supported !!

As Microsoft will stop supporting Windows 7 on Jan 20th we will be unable to test any of our
products on that platform. It may work, or it may not, but no guarantees from our side. 

Jump to content
Sign in to follow this  

Hardware throttles not working on airbus pro

Recommended Posts



I have the Aerosoft pro 64bit bundle running on p3d 4.5 (O/S is Win 10)  I normally fly with the warthog joystick and throttle.

After installing the aircraft , I set the configurator to 2 engines and made sure my stick and throttle were fully calibrated .


All my other aircraft, including PMDG, A2A and the Majestic Q400 work fine with this setup.


When I load up any of the airbus aircraft however I either have no movement at all from the throttles or occasionally it will move slightly then freeze again with no further movement. This is with them set up in the p3d control setup page.


I have followed the throttle setup guide and done some googling, however most of the issues are with older versions of the aircraft.


I have tried setting them through FSUIPC with the same result.


I have also tried with a saitek and ch product throttle quadrant just to confirm it’s not a hardware issue.


Is there anything obvious i’m Missing to try and get the throttles working with my hardware?


thanks in advance












Share this post

Link to post
Share on other sites

I'm using the Airbus with the Saitek X55 without any probems. Does only the tthrottle not work or also the rudder?

Have you setup the throttle in both configurators for the A31x and A32x?

Please show a screenshot of the configurator.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...