Jump to content

Recommended Posts

As far as we can tell all our products are at this moment compatible with Prepar3d version 4.5.

Note that all new aircraft releases will demand this version.

We do advise a full install and not just the client update as we have seen this cause serious issues previously! Also because there are changes to the content that can affect scenery.

 

Update, SimStarter will need an update.

Link to post
Share on other sites
  • Herman locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...